summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2007-10-09 13:22:08 +0000
committerMarkus Dittrich <markusle@gentoo.org>2007-10-09 13:22:08 +0000
commit8a8498775d825f053be8529aff3900e6cc57a115 (patch)
tree88a3e15810607481f5393466ee20477d335b55fe /sci-libs/itpp
parentUnmasked >=udev-115-r2 (diff)
downloadgentoo-2-8a8498775d825f053be8529aff3900e6cc57a115.tar.gz
gentoo-2-8a8498775d825f053be8529aff3900e6cc57a115.tar.bz2
gentoo-2-8a8498775d825f053be8529aff3900e6cc57a115.zip
Fixed weird quoting issue that seems to trip up itpp's configure (see bug #195189).
(Portage version: 2.1.3.12)
Diffstat (limited to 'sci-libs/itpp')
-rw-r--r--sci-libs/itpp/ChangeLog6
-rw-r--r--sci-libs/itpp/itpp-4.0.0_rc2.ebuild6
2 files changed, 8 insertions, 4 deletions
diff --git a/sci-libs/itpp/ChangeLog b/sci-libs/itpp/ChangeLog
index 350ddd63bc4d..5dc725d1e152 100644
--- a/sci-libs/itpp/ChangeLog
+++ b/sci-libs/itpp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/itpp
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.51 2007/10/09 11:20:06 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.52 2007/10/09 13:22:08 markusle Exp $
+
+ 09 Oct 2007; Markus Dittrich <markusle@gentoo.org> itpp-4.0.0_rc2.ebuild:
+ Fixed weird quoting issue that seems to trip up itpp's configure
+ (see bug #195189).
09 Oct 2007; Raúl Porcel <armin76@gentoo.org> itpp-3.10.12.ebuild:
sparc stable wrt #190183
diff --git a/sci-libs/itpp/itpp-4.0.0_rc2.ebuild b/sci-libs/itpp/itpp-4.0.0_rc2.ebuild
index ff59e6b0d01c..4d4a30c53fa5 100644
--- a/sci-libs/itpp/itpp-4.0.0_rc2.ebuild
+++ b/sci-libs/itpp/itpp-4.0.0_rc2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-4.0.0_rc2.ebuild,v 1.2 2007/10/08 14:56:00 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-4.0.0_rc2.ebuild,v 1.3 2007/10/09 13:22:08 markusle Exp $
inherit fortran flag-o-matic
@@ -53,14 +53,14 @@ src_compile() {
myconf="${myconf} --with-fft=-lfftw3"
fi
+
if use minimal; then
myconf="${myconf} --disable-comm --disable-fixed --disable-optim --disable-protocol --disable-signal --disable-srccode"
fi
econf $(use_enable doc html-doc) \
$(use_enable debug) \
- $(use_with lapack) \
- "${myconf}" \
+ ${myconf} \
|| die "econf failed"
emake || die "emake failed"
}