summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-10-18 20:41:24 +0000
committerJustin Lecher <jlec@gentoo.org>2012-10-18 20:41:24 +0000
commit144a9f93ec1a037894f8f0843354e515b7878624 (patch)
treedb6413c55eca7b7a5f7f40b3b7073e2282358f97 /sci-libs/libbufr
parentadd virtual/glu dep (bug #438828) (diff)
downloadgentoo-2-144a9f93ec1a037894f8f0843354e515b7878624.tar.gz
gentoo-2-144a9f93ec1a037894f8f0843354e515b7878624.tar.bz2
gentoo-2-144a9f93ec1a037894f8f0843354e515b7878624.zip
sci-libs/libbufr: Remove virtual/fortran and always call fortran-2_pkg_setup as intend by the updated fortran-2.eclass
(Portage version: 2.2.0_alpha141/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sci-libs/libbufr')
-rw-r--r--sci-libs/libbufr/ChangeLog7
-rw-r--r--sci-libs/libbufr/libbufr-000360.ebuild23
-rw-r--r--sci-libs/libbufr/libbufr-000387.ebuild13
-rw-r--r--sci-libs/libbufr/metadata.xml4
4 files changed, 22 insertions, 25 deletions
diff --git a/sci-libs/libbufr/ChangeLog b/sci-libs/libbufr/ChangeLog
index 112f1f317a0b..70f7699aa2ff 100644
--- a/sci-libs/libbufr/ChangeLog
+++ b/sci-libs/libbufr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/libbufr
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libbufr/ChangeLog,v 1.9 2012/10/07 09:08:03 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libbufr/ChangeLog,v 1.10 2012/10/18 20:41:24 jlec Exp $
+
+ 18 Oct 2012; Justin Lecher <jlec@gentoo.org> libbufr-000360.ebuild,
+ libbufr-000387.ebuild, metadata.xml:
+ Remove virtual/fortran and always call fortran-2_pkg_setup as intend by the
+ updated fortran-2.eclass
07 Oct 2012; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Drop maintainer due retirement, #24135.
diff --git a/sci-libs/libbufr/libbufr-000360.ebuild b/sci-libs/libbufr/libbufr-000360.ebuild
index a12a9d81e61f..274bb524f902 100644
--- a/sci-libs/libbufr/libbufr-000360.ebuild
+++ b/sci-libs/libbufr/libbufr-000360.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libbufr/libbufr-000360.ebuild,v 1.8 2011/06/21 15:15:13 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libbufr/libbufr-000360.ebuild,v 1.9 2012/10/18 20:41:24 jlec Exp $
EAPI=2
@@ -19,10 +19,7 @@ KEYWORDS="~amd64 ~x86"
IUSE="debug doc examples"
-RDEPEND="
- virtual/fortran
- "
-
+RDEPEND=""
DEPEND="sys-apps/findutils"
S=${WORKDIR}/${MY_P}
@@ -63,7 +60,7 @@ src_prepare() {
local config="config/config.$target$CNAME$R64$A64"
- sed -i -e "s:DEBUG = -O2:DEBUG = -g:g" $config
+ sed -i -e "s:DEBUG = -O2:DEBUG = -g:g" $config || die
# add local CFLAGS to and build flags
use debug || sed -i -e "s|\$(DEBUG)|${CFLAGS}|" $config
@@ -72,7 +69,7 @@ src_prepare() {
sed -i \
-e "s|-o|${LDFLAGS} -o|" \
examples/Makefile \
- bufrtables/Makefile
+ bufrtables/Makefile || die
# updated for newer gcc
epatch "${FILESDIR}"/${P}-gcc-includes.patch
}
@@ -128,20 +125,20 @@ src_install() {
}
pkg_postinst() {
- elog
+ echo
elog "This is the only GPL'd BUFR decoder library written in C/Fortran"
elog "but the build system is an old kluge that pre-dates the discovery"
- elog "of fire. File bugs as usual if you have build/runtime problems."
- elog ""
+ elog "of fire. File bugs as usual if you have build/runtime problems."
+ echo
elog "The default BUFR tables are stored in /usr/share/bufrtables, so"
elog "add your local tables there if needed. Only a static lib is"
elog "installed currently, as shared lib support is incomplete (feel"
elog "free to submit a patch :)"
- elog ""
+ echo
elog "The installed user-land bufr utilities are just the examples;"
elog "the main library is really all there is (and there are no man"
elog "pages either). Install the examples and use the source, Luke..."
- elog
+ echo
}
generate_files() {
diff --git a/sci-libs/libbufr/libbufr-000387.ebuild b/sci-libs/libbufr/libbufr-000387.ebuild
index 9e78431060be..fff1d7d767ad 100644
--- a/sci-libs/libbufr/libbufr-000387.ebuild
+++ b/sci-libs/libbufr/libbufr-000387.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libbufr/libbufr-000387.ebuild,v 1.6 2011/06/21 15:15:13 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libbufr/libbufr-000387.ebuild,v 1.7 2012/10/18 20:41:24 jlec Exp $
EAPI=3
@@ -15,14 +15,9 @@ SRC_URI="http://www.ecmwf.int/products/data/software/download/software_files/${M
LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-# needs someone to test on these: ~alpha ~hppa ~ia64 ~sparc etc ...
-
IUSE="debug doc examples"
-RDEPEND="
- virtual/fortran
- "
-
+RDEPEND=""
DEPEND="sys-apps/findutils"
S=${WORKDIR}/${MY_P}
@@ -45,7 +40,7 @@ pkg_setup() {
esac
elog "Note non-GNU compilers are not currently supported on non-x86"
- elog "architectures. If you need it, please subit a patch..."
+ elog "architectures. If you need it, please subit a patch..."
export target="linux"
export A64=""
diff --git a/sci-libs/libbufr/metadata.xml b/sci-libs/libbufr/metadata.xml
index fc1a353bc931..69b4f2ff1403 100644
--- a/sci-libs/libbufr/metadata.xml
+++ b/sci-libs/libbufr/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-geosciences</herd>
-<longdescription>This is mainly just an open source BUFR library from ECMWF
+ <herd>sci-geosciences</herd>
+ <longdescription>This is mainly just an open source BUFR library from ECMWF
that comes with a few example toolss (some of which are built and installed).
</longdescription>
</pkgmetadata>