summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2006-05-13 22:22:12 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2006-05-13 22:22:12 +0000
commitca6546e3a0eaedbcc1d65bf1e56d1475a985eb1c (patch)
tree7dbe0268141eca32fc1b915802a17a0234d67ad7 /sci-libs/libghemical/libghemical-2.00.ebuild
parentAlways build shared libraries, so other programs can link against them withou... (diff)
downloadgentoo-2-ca6546e3a0eaedbcc1d65bf1e56d1475a985eb1c.tar.gz
gentoo-2-ca6546e3a0eaedbcc1d65bf1e56d1475a985eb1c.tar.bz2
gentoo-2-ca6546e3a0eaedbcc1d65bf1e56d1475a985eb1c.zip
(#132835) Bump to latest release. Ebuild based on work of Donald E. Curtis. Patch to fix blas/lapack detection by me.
(Portage version: 2.1_pre10-r5)
Diffstat (limited to 'sci-libs/libghemical/libghemical-2.00.ebuild')
-rw-r--r--sci-libs/libghemical/libghemical-2.00.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sci-libs/libghemical/libghemical-2.00.ebuild b/sci-libs/libghemical/libghemical-2.00.ebuild
new file mode 100644
index 000000000000..b196a32cb4e1
--- /dev/null
+++ b/sci-libs/libghemical/libghemical-2.00.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libghemical/libghemical-2.00.ebuild,v 1.1 2006/05/13 22:22:12 spyderous Exp $
+
+inherit autotools eutils
+
+DESCRIPTION="Ghemical supports both quantum-mechanics (semi-empirical and ab initio) models and molecular mechanics models (there is an experimental Tripos 5.2-like force field for organic molecules). Also a tool for reduced protein models is included. Geometry optimization, molecular dynamics and a large set of visualization tools are currently available."
+HOMEPAGE="http://bioinformatics.org/ghemical/"
+SRC_URI="http://www.bioinformatics.org/ghemical/download/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE="mopac7 mpqc"
+RDEPEND="mopac7? ( sci-chemistry/mopac7 )
+ mpqc? ( >=sci-chemistry/mpqc-2.3.1-r1
+ virtual/blas
+ virtual/lapack )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.15"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}-really-find-blas-and-lapack.patch
+ cd "${S}"
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ $(use_enable mopac7) \
+ $(use_enable mpqc) \
+ || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+}