summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-10-18 16:56:01 +0000
committerJustin Lecher <jlec@gentoo.org>2012-10-18 16:56:01 +0000
commit749026dab1ccc6794746ad9fb915466990f74a3f (patch)
tree0215555983ba189efc190e957a0ebdc672b3cca4 /sci-libs/libpdb
parentsci-libs/libpdb++: Straighten ebuild by cleaning the buildsystem (diff)
downloadgentoo-2-749026dab1ccc6794746ad9fb915466990f74a3f.tar.gz
gentoo-2-749026dab1ccc6794746ad9fb915466990f74a3f.tar.bz2
gentoo-2-749026dab1ccc6794746ad9fb915466990f74a3f.zip
sci-libs/libpdb: Straighten ebuild by cleaning the buildsystem
(Portage version: 2.2.0_alpha141/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sci-libs/libpdb')
-rw-r--r--sci-libs/libpdb/ChangeLog11
-rw-r--r--sci-libs/libpdb/files/libpdb-991112-dynlib+flags.patch46
-rw-r--r--sci-libs/libpdb/libpdb-991112-r1.ebuild44
-rw-r--r--sci-libs/libpdb/libpdb-991112.ebuild6
-rw-r--r--sci-libs/libpdb/metadata.xml8
5 files changed, 106 insertions, 9 deletions
diff --git a/sci-libs/libpdb/ChangeLog b/sci-libs/libpdb/ChangeLog
index e99b07f4a552..16773fce077e 100644
--- a/sci-libs/libpdb/ChangeLog
+++ b/sci-libs/libpdb/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-libs/libpdb
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libpdb/ChangeLog,v 1.1 2010/03/07 10:42:38 jlec Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libpdb/ChangeLog,v 1.2 2012/10/18 16:56:01 jlec Exp $
+
+*libpdb-991112-r1 (18 Oct 2012)
+
+ 18 Oct 2012; Justin Lecher <jlec@gentoo.org> libpdb-991112.ebuild,
+ +libpdb-991112-r1.ebuild, +files/libpdb-991112-dynlib+flags.patch,
+ metadata.xml:
+ Straighten ebuild by cleaning the buildsystem
*libpdb-991112 (07 Mar 2010)
diff --git a/sci-libs/libpdb/files/libpdb-991112-dynlib+flags.patch b/sci-libs/libpdb/files/libpdb-991112-dynlib+flags.patch
new file mode 100644
index 000000000000..72048b684a93
--- /dev/null
+++ b/sci-libs/libpdb/files/libpdb-991112-dynlib+flags.patch
@@ -0,0 +1,46 @@
+ Makefile | 17 +++++++++++------
+ 1 file changed, 11 insertions(+), 6 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 760a427..de7e724 100644
+--- a/Makefile
++++ b/Makefile
+@@ -8,16 +8,16 @@
+ # RANLIB should be ':'
+ #
+ SHELL = /bin/sh
+-RANLIB = :
++#RANLIB = :
+ NOTHING =
+ LINTOPT = -o $(NOTHING)
+
+ OPT = -O -g
+ DEBUG =
+-CFLAGS = $(OPT) $(DEBUG)
++CFLAGS += -fPIC
+ LIBRARY = pdb
+
+-LIBARCH = lib$(LIBRARY).a
++LIBARCH = lib$(LIBRARY)
+ LINTLIB = llib-l$(LIBRARY).ln
+ OBJS = pdb_read.o pdb_sprntf.o pdb_sscanf.o pdb_write.o pdbrun.o ms.o
+ SRCS = pdb_read.c pdb_sprntf.c pdb_sscanf.c pdb_write.c pdbrun.c ms.c
+@@ -27,10 +27,15 @@ all: $(LIBARCH) $(LINTLIB)
+ install: $(LIBARCH)
+ install -F /usr/local/lib $(LIBARCH)
+
+-$(LIBARCH): $(OBJS)
++$(LIBARCH).so: $(OBJS)
++ $(CC) $(LDFLAGS) -shared -Wl,--soname,libpdb.so.0 -o libpdb.so.0.1 $(OBJS)
++ ln -sf libpdb.so.0.1 libpdb.so.0
++ ln -sf libpdb.so.0.1 libpdb.so
++
++$(LIBARCH).a: $(OBJS)
+ @echo "Loading $(LIBARCH) ... "
+- @ar cru $(LIBARCH) $(OBJS)
+- @$(RANLIB) $(LIBARCH)
++ $(AR) cru $@ $(OBJS)
++ $(RANLIB) $@
+ @echo "done"
+
+ $(LINTLIB): $(SRCS) $(HDRS)
diff --git a/sci-libs/libpdb/libpdb-991112-r1.ebuild b/sci-libs/libpdb/libpdb-991112-r1.ebuild
new file mode 100644
index 000000000000..b39728730b95
--- /dev/null
+++ b/sci-libs/libpdb/libpdb-991112-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libpdb/libpdb-991112-r1.ebuild,v 1.1 2012/10/18 16:56:01 jlec Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="PDB Record I/O Libraries -- c version"
+HOMEPAGE="http://www.cgl.ucsf.edu/Overview/software.html"
+SRC_URI="mirror://gentoo/${P}.shar"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-arch/sharutils"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ "${EPREFIX}/usr/bin/unshar" "${DISTDIR}"/${A} || die
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-dynlib+flags.patch
+ tc-export CC RANLIB AR
+}
+
+src_compile() {
+ emake ${PN}.so
+ use static-libs && emake ${PN}.a
+}
+
+src_install() {
+ dolib.so ${PN}.so*
+ use static-libs && dolib.a ${PN}.a
+
+ insinto /usr/include/${PN}
+ doins *.h
+}
diff --git a/sci-libs/libpdb/libpdb-991112.ebuild b/sci-libs/libpdb/libpdb-991112.ebuild
index a8748c110718..afc6f0abbed2 100644
--- a/sci-libs/libpdb/libpdb-991112.ebuild
+++ b/sci-libs/libpdb/libpdb-991112.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libpdb/libpdb-991112.ebuild,v 1.2 2010/03/07 11:29:01 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libpdb/libpdb-991112.ebuild,v 1.3 2012/10/18 16:56:01 jlec Exp $
EAPI="3"
-inherit eutils toolchain-funcs
+inherit eutils multilib toolchain-funcs
DESCRIPTION="PDB Record I/O Libraries -- c version"
HOMEPAGE="http://www.cgl.ucsf.edu/Overview/software.html"
diff --git a/sci-libs/libpdb/metadata.xml b/sci-libs/libpdb/metadata.xml
index c6856dc7f2cf..210ad0db014c 100644
--- a/sci-libs/libpdb/metadata.xml
+++ b/sci-libs/libpdb/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
-<maintainer>
- <email>jlec@gentoo.org</email>
-</maintainer>
+ <herd>sci</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
</pkgmetadata>