summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-04-18 19:15:19 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-04-18 19:15:19 +0000
commitececb46b75db5ccf3b26b097c580a16435c8fa85 (patch)
treef07ccd6d2e028fc7fbd8a4411d8e3c99d7906544 /sci-libs/netcdf-fortran
parentx86 stable, bug #409403 (diff)
downloadgentoo-2-ececb46b75db5ccf3b26b097c580a16435c8fa85.tar.gz
gentoo-2-ececb46b75db5ccf3b26b097c580a16435c8fa85.tar.bz2
gentoo-2-ececb46b75db5ccf3b26b097c580a16435c8fa85.zip
Initial import
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/netcdf-fortran')
-rw-r--r--sci-libs/netcdf-fortran/ChangeLog10
-rw-r--r--sci-libs/netcdf-fortran/metadata.xml14
-rw-r--r--sci-libs/netcdf-fortran/netcdf-fortran-4.2.ebuild39
3 files changed, 63 insertions, 0 deletions
diff --git a/sci-libs/netcdf-fortran/ChangeLog b/sci-libs/netcdf-fortran/ChangeLog
new file mode 100644
index 000000000000..d9ee5a722a66
--- /dev/null
+++ b/sci-libs/netcdf-fortran/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-libs/netcdf-fortran
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf-fortran/ChangeLog,v 1.1 2012/04/18 19:15:19 bicatali Exp $
+
+*netcdf-fortran-4.2 (18 Apr 2012)
+
+ 18 Apr 2012; Sébastien Fabbro <bicatali@gentoo.org>
+ +netcdf-fortran-4.2.ebuild, +metadata.xml:
+ Initial import
+
diff --git a/sci-libs/netcdf-fortran/metadata.xml b/sci-libs/netcdf-fortran/metadata.xml
new file mode 100644
index 000000000000..58e9c9c4b152
--- /dev/null
+++ b/sci-libs/netcdf-fortran/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+<longdescription lang="en">
+ NetCDF (network Common Data Form) is an interface for scientific
+ data access and a freely-distributed software library that provides an
+ implementation of the interface. The netCDF library also defines a
+ machine-independent format for representing scientific data.
+ Together, the interface, library, and format support the creation,
+ access, and sharing of scientific data.
+ This is the FORTRAN 77 and 90 library on top of the C library.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-libs/netcdf-fortran/netcdf-fortran-4.2.ebuild b/sci-libs/netcdf-fortran/netcdf-fortran-4.2.ebuild
new file mode 100644
index 000000000000..57f852641874
--- /dev/null
+++ b/sci-libs/netcdf-fortran/netcdf-fortran-4.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf-fortran/netcdf-fortran-4.2.ebuild,v 1.1 2012/04/18 19:15:19 bicatali Exp $
+
+EAPI=4
+
+inherit autotools-utils fortran-2
+
+DESCRIPTION="Scientific library and interface for array oriented data access"
+HOMEPAGE="http://www.unidata.ucar.edu/software/netcdf/"
+SRC_URI="ftp://ftp.unidata.ucar.edu/pub/netcdf/${P}.tar.gz"
+
+LICENSE="UCAR-Unidata"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples static-libs"
+
+RDEPEND="sci-libs/netcdf
+ virtual/fortran"
+
+DEPEND="${RDEPEND}
+ dev-lang/cfortran"
+
+FORTRAN_STANDARD="77 90"
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_prepare() {
+ # use system cfortran
+ rm -f fortran/cfortran.h || die
+ autotools-utils_src_prepare
+}
+
+src_install() {
+ autotools-utils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}