summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-03-07 18:58:23 +0000
committerJustin Lecher <jlec@gentoo.org>2010-03-07 18:58:23 +0000
commit6aa60b1f87336c1c36a820c8389ae90981b31051 (patch)
tree34a4c791e83d5f1db8cd59f860a925e9278cb704 /sci-libs/netcdf
parentinclude fix (diff)
downloadgentoo-2-6aa60b1f87336c1c36a820c8389ae90981b31051.tar.gz
gentoo-2-6aa60b1f87336c1c36a820c8389ae90981b31051.tar.bz2
gentoo-2-6aa60b1f87336c1c36a820c8389ae90981b31051.zip
Moved to EAPI=3 for PREFIX support, keyworded for *-linux, tested by me
(Portage version: 2.2_rc65/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/netcdf')
-rw-r--r--sci-libs/netcdf/netcdf-4.0.1-r1.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/sci-libs/netcdf/netcdf-4.0.1-r1.ebuild b/sci-libs/netcdf/netcdf-4.0.1-r1.ebuild
index cf7478832ad7..013b5308ed64 100644
--- a/sci-libs/netcdf/netcdf-4.0.1-r1.ebuild
+++ b/sci-libs/netcdf/netcdf-4.0.1-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/netcdf-4.0.1-r1.ebuild,v 1.4 2010/02/12 17:41:23 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/netcdf-4.0.1-r1.ebuild,v 1.5 2010/03/07 18:58:23 jlec Exp $
-EAPI=2
+EAPI="3"
inherit eutils autotools
@@ -13,7 +13,7 @@ HOMEPAGE="http://www.unidata.ucar.edu/software/netcdf/"
LICENSE="UCAR-Unidata"
SLOT="0"
IUSE="doc fortran hdf5 szip cxx"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
RDEPEND="hdf5? ( >=sci-libs/hdf5-1.8[zlib,szip?,fortran?] )"
DEPEND="${RDEPEND}
@@ -46,11 +46,12 @@ src_prepare() {
src_configure() {
local myconf
if use hdf5; then
- myconf="--with-hdf5=/usr --with-zlib=/usr"
- use szip && myconf="${myconf} --with-szlib=/usr"
+ myconf="--with-hdf5=${EPREFIX}/usr --with-zlib=${EPREFIX}/usr"
+ use szip && myconf="${myconf} --with-szlib=${EPREFIX}/usr"
fi
+
econf \
- --docdir=/usr/share/doc/${PF} \
+ --docdir=${EPREFIX}/usr/share/doc/${PF} \
--enable-shared \
$(use_enable fortran f77) \
$(use_enable fortran f90) \