summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-06-21 08:33:42 +0000
committerJustin Lecher <jlec@gentoo.org>2011-06-21 08:33:42 +0000
commit9ffd1b72a40a88fd36223b105a649225bfc0de78 (patch)
tree15aa7e7316bbf7559996408cde2dbf06e11d24ba /sci-libs/netcdf
parentAdded fortran-2.eclass support (diff)
downloadgentoo-2-9ffd1b72a40a88fd36223b105a649225bfc0de78.tar.gz
gentoo-2-9ffd1b72a40a88fd36223b105a649225bfc0de78.tar.bz2
gentoo-2-9ffd1b72a40a88fd36223b105a649225bfc0de78.zip
Added fortran-2.eclass support
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/netcdf')
-rw-r--r--sci-libs/netcdf/ChangeLog6
-rw-r--r--sci-libs/netcdf/netcdf-3.6.3.ebuild4
-rw-r--r--sci-libs/netcdf/netcdf-4.1.1-r4.ebuild7
3 files changed, 11 insertions, 6 deletions
diff --git a/sci-libs/netcdf/ChangeLog b/sci-libs/netcdf/ChangeLog
index 570c2e61d813..0be10ab897cb 100644
--- a/sci-libs/netcdf/ChangeLog
+++ b/sci-libs/netcdf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/netcdf
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/ChangeLog,v 1.90 2011/06/08 15:13:24 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/ChangeLog,v 1.91 2011/06/21 08:33:42 jlec Exp $
+
+ 21 Jun 2011; Justin Lecher <jlec@gentoo.org> netcdf-3.6.3.ebuild,
+ netcdf-4.1.1-r4.ebuild:
+ Added fortran-2.eclass support
08 Jun 2011; Jeroen Roovers <jer@gentoo.org> netcdf-3.6.3.ebuild,
netcdf-4.1.1-r4.ebuild:
diff --git a/sci-libs/netcdf/netcdf-3.6.3.ebuild b/sci-libs/netcdf/netcdf-3.6.3.ebuild
index b9d017b24db3..a9c0abd197cd 100644
--- a/sci-libs/netcdf/netcdf-3.6.3.ebuild
+++ b/sci-libs/netcdf/netcdf-3.6.3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/netcdf-3.6.3.ebuild,v 1.16 2011/06/08 15:13:24 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/netcdf-3.6.3.ebuild,v 1.17 2011/06/21 08:33:42 jlec Exp $
EAPI=2
-inherit eutils toolchain-funcs flag-o-matic autotools
+inherit eutils fortran-2 toolchain-funcs flag-o-matic autotools
DESCRIPTION="Scientific library and interface for array oriented data access"
SRC_URI="ftp://ftp.unidata.ucar.edu/pub/netcdf/${P}.tar.gz"
diff --git a/sci-libs/netcdf/netcdf-4.1.1-r4.ebuild b/sci-libs/netcdf/netcdf-4.1.1-r4.ebuild
index 395b59889534..85505ca007b7 100644
--- a/sci-libs/netcdf/netcdf-4.1.1-r4.ebuild
+++ b/sci-libs/netcdf/netcdf-4.1.1-r4.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/netcdf-4.1.1-r4.ebuild,v 1.10 2011/06/08 15:13:24 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/netcdf-4.1.1-r4.ebuild,v 1.11 2011/06/21 08:33:42 jlec Exp $
-EAPI="3"
+EAPI=3
-inherit autotools autotools-utils
+inherit autotools autotools-utils fortran-2
DESCRIPTION="Scientific library and interface for array oriented data access"
HOMEPAGE="http://www.unidata.ucar.edu/software/netcdf/"
@@ -33,6 +33,7 @@ PATCHES=(
)
pkg_setup() {
+ fortran-2_pkg_setup
if use hdf5 && has_version sci-libs/hdf5[mpi]; then
export CC=mpicc
if use cxx; then