summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2009-07-21 08:01:31 +0000
committerChristian Faulhammer <fauli@gentoo.org>2009-07-21 08:01:31 +0000
commit03e7582d62304f5c442df3fc69b3c073667989bf (patch)
tree1bd111a779af50748b553a153ddc6f009c9ea112 /sci-libs/parmgridgen/files
parentAllow yasm also for x86 since it's the preferred application. (diff)
downloadgentoo-2-03e7582d62304f5c442df3fc69b3c073667989bf.tar.gz
gentoo-2-03e7582d62304f5c442df3fc69b3c073667989bf.tar.bz2
gentoo-2-03e7582d62304f5c442df3fc69b3c073667989bf.zip
add patch for forced --as-needed linker flag (bug 272653), patch provided by Priit Laes <amd@astore20.com> in bug 232491; ported to EAPI 2
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'sci-libs/parmgridgen/files')
-rw-r--r--sci-libs/parmgridgen/files/parmgridgen-1.0-as-needed.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/sci-libs/parmgridgen/files/parmgridgen-1.0-as-needed.patch b/sci-libs/parmgridgen/files/parmgridgen-1.0-as-needed.patch
new file mode 100644
index 000000000000..4f9addda4228
--- /dev/null
+++ b/sci-libs/parmgridgen/files/parmgridgen-1.0-as-needed.patch
@@ -0,0 +1,19 @@
+--- MGridGen/Lib/Makefile.am.old 2009-03-10 09:28:13.000000000 +0200
++++ MGridGen/Lib/Makefile.am 2009-03-10 09:28:07.000000000 +0200
+@@ -8,3 +8,5 @@
+ lib_LTLIBRARIES = libMGridGen.la
+ libMGridGen_la_SOURCES = aratio.c coarsen.c kwayfm.c match.c merge.c mgridgen.c refine.c setup.c
+ libMGridGen_la_LDFLAGS = -no-undefined -export-dynamic -version-info 1:0:0
++
++libMGridGen_la_LIBADD = ../IMlib/libIMlib.la
+--- ParMGridGen/ParLib/Makefile.am.old 2009-03-10 09:31:43.000000000 +0200
++++ ParMGridGen/ParLib/Makefile.am 2009-03-10 09:35:13.000000000 +0200
+@@ -8,3 +8,8 @@
+ lib_LTLIBRARIES = libParMGridGen.la
+ libParMGridGen_la_SOURCES = comm.c debug.c grsetup.c ikeysort.c memory.c move.c parmgridgen.c setup.c util.c
+ libParMGridGen_la_LDFLAGS = -no-undefined -export-dynamic -version-info 1:0:0
++
++libParMGridGen_la_LIBADD = \
++ $(top_builddir)/MGridGen/IMlib/libIMlib.la \
++ $(top_builddir)/MGridGen/Lib/libMGridGen.la \
++ ../IMParMetis-2.0/ParMETISLib/libIMparmetis.la