summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-27 15:04:35 +0000
committerJustin Lecher <jlec@gentoo.org>2013-02-27 15:04:35 +0000
commit3eba6499a5b1c2801939a42a295bc353ddfe33f8 (patch)
tree57937585efe8627d33361c5353ea2d4afe2951bf /sci-libs/punc
parentsci-libs/ccp4-libs: Add missing dep on virtual/pkgconfig; use tc-getPKG_CONFI... (diff)
downloadgentoo-2-3eba6499a5b1c2801939a42a295bc353ddfe33f8.tar.gz
gentoo-2-3eba6499a5b1c2801939a42a295bc353ddfe33f8.tar.bz2
gentoo-2-3eba6499a5b1c2801939a42a295bc353ddfe33f8.zip
sci-libs/punc: Detect superlu via pkg-config
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sci-libs/punc')
-rw-r--r--sci-libs/punc/ChangeLog5
-rw-r--r--sci-libs/punc/punc-1.5.ebuild4
2 files changed, 6 insertions, 3 deletions
diff --git a/sci-libs/punc/ChangeLog b/sci-libs/punc/ChangeLog
index ed0680d778e9..68c9fab2c0f9 100644
--- a/sci-libs/punc/ChangeLog
+++ b/sci-libs/punc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-libs/punc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/punc/ChangeLog,v 1.18 2013/02/21 22:05:32 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/punc/ChangeLog,v 1.19 2013/02/27 15:04:35 jlec Exp $
+
+ 27 Feb 2013; Justin Lecher <jlec@gentoo.org> punc-1.5.ebuild:
+ Detect superlu via pkg-config
21 Feb 2013; Justin Lecher <jlec@gentoo.org> punc-1.5.ebuild, metadata.xml:
Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of plain pkg-config;
diff --git a/sci-libs/punc/punc-1.5.ebuild b/sci-libs/punc/punc-1.5.ebuild
index 0c206c976562..0683e65ef521 100644
--- a/sci-libs/punc/punc-1.5.ebuild
+++ b/sci-libs/punc/punc-1.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/punc/punc-1.5.ebuild,v 1.8 2013/02/21 22:05:32 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/punc/punc-1.5.ebuild,v 1.9 2013/02/27 15:04:35 jlec Exp $
EAPI=4
@@ -66,7 +66,7 @@ src_configure() {
export FETK_LIBRARY="${fetk_lib}"
export FETK_LAPACK_LIBRARY="$($(tc-getPKG_CONFIG) --libs lapack)"
export FETK_BLAS_LIBRARY="${fetk_lib}"
- export FETK_SUPERLU_LIBRARY="-lsuperlu"
+ export FETK_SUPERLU_LIBRARY="$($(tc-getPKG_CONFIG) --libs superlu)"
export FETK_ARPACK_LIBRARY="${fetk_lib}"
export FETK_UMFPACK_LIBRARY="${fetk_lib}"
export FETK_CGCODE_LIBRARY="${fetk_lib}"