summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-02-19 15:16:22 +0000
committerJustin Lecher <jlec@gentoo.org>2011-02-19 15:16:22 +0000
commit94af1766fc04d0681c58d16c0f06c9fc49ffa222 (patch)
treeceb57082066850a73e1b99a3ee53fd2141588686 /sci-libs/tamu_anova
parentppc64 stable wrt #349887 (diff)
downloadgentoo-2-94af1766fc04d0681c58d16c0f06c9fc49ffa222.tar.gz
gentoo-2-94af1766fc04d0681c58d16c0f06c9fc49ffa222.tar.bz2
gentoo-2-94af1766fc04d0681c58d16c0f06c9fc49ffa222.zip
new addition, written by me
(Portage version: 2.2.0_alpha24/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/tamu_anova')
-rw-r--r--sci-libs/tamu_anova/ChangeLog10
-rw-r--r--sci-libs/tamu_anova/files/0.2.1-gentoo.patch35
-rw-r--r--sci-libs/tamu_anova/metadata.xml8
-rw-r--r--sci-libs/tamu_anova/tamu_anova-0.2.1.ebuild26
4 files changed, 79 insertions, 0 deletions
diff --git a/sci-libs/tamu_anova/ChangeLog b/sci-libs/tamu_anova/ChangeLog
new file mode 100644
index 000000000000..47907a3efd13
--- /dev/null
+++ b/sci-libs/tamu_anova/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-libs/tamu_anova
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/tamu_anova/ChangeLog,v 1.1 2011/02/19 15:16:22 jlec Exp $
+
+*tamu_anova-0.2.1 (19 Feb 2011)
+
+ 19 Feb 2011; Justin Lecher <jlec@gentoo.org> +files/0.2.1-gentoo.patch,
+ +tamu_anova-0.2.1.ebuild, +metadata.xml:
+ new addition, written by me
+
diff --git a/sci-libs/tamu_anova/files/0.2.1-gentoo.patch b/sci-libs/tamu_anova/files/0.2.1-gentoo.patch
new file mode 100644
index 000000000000..4d4c1f4a0af1
--- /dev/null
+++ b/sci-libs/tamu_anova/files/0.2.1-gentoo.patch
@@ -0,0 +1,35 @@
+diff --git a/Makefile.am b/Makefile.am
+index 6b11b79..ba5fac3 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,11 +1,11 @@
+-inst_LIBRARIES = libtamuanova.a
++lib_LTLIBRARIES = libtamuanova.la
+ pkginclude_HEADERS = tamu_anova.h
+-libtamuanova_a_SOURCES = anova_1.c anova_2.c
+-instdir = /usr/lib/
++libtamuanova_la_SOURCES = anova_1.c anova_2.c
++libtamuanova_la_LIBADD = $(GSL_LIBS)
+
+ TESTS = $(check_PROGRAMS)
+ check_PROGRAMS = test
+-test_LDADD = libtamuanova.a -lgsl -lgslcblas -lm
++test_LDADD = libtamuanova.la $(GSL_LIBS) -lm
+ test_SOURCES = test.c
+
+ CLEANFILES = test.dat
+diff --git a/configure.ac b/configure.ac
+index 7008594..1f161c3 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -7,6 +7,10 @@ AM_INIT_AUTOMAKE([gnu no-dependencies])
+ AC_CONFIG_HEADER([config.h])
+
+ AC_PROG_MAKE_SET
++AC_PROG_LIBTOOL
++PKG_PROG_PKG_CONFIG
++
++PKG_CHECK_MODULES(GSL, [ gsl ])
+
+ dnl Check for which system.
+ AC_CANONICAL_HOST
diff --git a/sci-libs/tamu_anova/metadata.xml b/sci-libs/tamu_anova/metadata.xml
new file mode 100644
index 000000000000..c6856dc7f2cf
--- /dev/null
+++ b/sci-libs/tamu_anova/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>jlec@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/sci-libs/tamu_anova/tamu_anova-0.2.1.ebuild b/sci-libs/tamu_anova/tamu_anova-0.2.1.ebuild
new file mode 100644
index 000000000000..8fae01ffe907
--- /dev/null
+++ b/sci-libs/tamu_anova/tamu_anova-0.2.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/tamu_anova/tamu_anova-0.2.1.ebuild,v 1.1 2011/02/19 15:16:22 jlec Exp $
+
+EAPI="4"
+
+inherit autotools eutils
+
+DESCRIPTION="ANOVA Extensions to the GNU Scientific Library"
+HOMEPAGE="http://www.stat.tamu.edu/~aredd/tamuanova"
+SRC_URI="http://www.stat.tamu.edu/~aredd/tamuanova/${PN}-0.2.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-2"
+IUSE=""
+
+RDEPEND="sci-libs/gsl"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${PN}-0.2
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-gentoo.patch
+ eautoreconf
+}