summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2014-11-05 12:28:48 +0000
committerAaron W. Swenson <titanofold@gentoo.org>2014-11-05 12:28:48 +0000
commit3759d4ac357a27a7702566434b0f4e967eec09aa (patch)
tree419c7279e11a8fdf073a2052af0cea574dec5c21 /sci-libs
parentVersion bump. (diff)
downloadgentoo-2-3759d4ac357a27a7702566434b0f4e967eec09aa.tar.gz
gentoo-2-3759d4ac357a27a7702566434b0f4e967eec09aa.tar.bz2
gentoo-2-3759d4ac357a27a7702566434b0f4e967eec09aa.zip
Fix bug 496408. Get value of RUBY_SO_NAME instead of LIBRUBY_SO. Remove old
and broken versions. (Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key D1BBFDA0)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/geos/ChangeLog11
-rw-r--r--sci-libs/geos/files/3.4.2-ruby_so_name.patch12
-rw-r--r--sci-libs/geos/geos-3.3.8-r1.ebuild99
-rw-r--r--sci-libs/geos/geos-3.4.2-r1.ebuild (renamed from sci-libs/geos/geos-3.4.2.ebuild)7
4 files changed, 25 insertions, 104 deletions
diff --git a/sci-libs/geos/ChangeLog b/sci-libs/geos/ChangeLog
index c6998b64106d..5ce042cbc41a 100644
--- a/sci-libs/geos/ChangeLog
+++ b/sci-libs/geos/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-libs/geos
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/ChangeLog,v 1.86 2013/12/22 13:47:54 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/ChangeLog,v 1.87 2014/11/05 12:28:48 titanofold Exp $
+
+*geos-3.4.2-r1 (05 Nov 2014)
+
+ 05 Nov 2014; Aaron W. Swenson <titanofold@gentoo.org> -geos-3.3.8-r1.ebuild,
+ -geos-3.4.2.ebuild, +geos-3.4.2-r1.ebuild, +files/3.4.2-ruby_so_name.patch:
+ Fix bug 496408. Get value of RUBY_SO_NAME instead of LIBRUBY_SO. Remove old
+ and broken versions.
22 Dec 2013; Agostino Sarubbo <ago@gentoo.org> geos-3.4.1-r1.ebuild:
Stable for ppc64, wrt bug #485974
diff --git a/sci-libs/geos/files/3.4.2-ruby_so_name.patch b/sci-libs/geos/files/3.4.2-ruby_so_name.patch
new file mode 100644
index 000000000000..4168e5c0263f
--- /dev/null
+++ b/sci-libs/geos/files/3.4.2-ruby_so_name.patch
@@ -0,0 +1,12 @@
+diff -Naur geos-3.4.2.orig/macros/ruby.m4 geos-3.4.2/macros/ruby.m4
+--- a/macros/ruby.m4 2013-08-25 11:10:32.000000000 -0400
++++ b/macros/ruby.m4 2014-11-05 06:35:39.347830878 -0500
+@@ -38,7 +38,7 @@
+ RUBY_EXTENSION_DIR=`$RUBY -rrbconfig -e 'puts RbConfig::CONFIG[["sitearchdir"]] || Config::CONFIG[["sitearchdir"]]'`
+
+ dnl Get Ruby shared library name, this does not include the lib prefix or extension name
+- RUBY_SO_NAME=`$RUBY -rrbconfig -e 'puts RbConfig::CONFIG[["LIBRUBY_SO"]] || Config::CONFIG[["RUBY_SO_NAME"]]'`
++ RUBY_SO_NAME=`$RUBY -rrbconfig -e 'puts RbConfig::CONFIG[["RUBY_SO_NAME"]] || Config::CONFIG[["RUBY_SO_NAME"]]'`
+
+ dnl Get Ruby shared libary name
+ RUBY_SHARED_LIB=`$RUBY -rrbconfig -e 'puts RbConfig::CONFIG[["LIBRUBY"]] || Config::CONFIG[["LIBRUBY"]]'`
diff --git a/sci-libs/geos/geos-3.3.8-r1.ebuild b/sci-libs/geos/geos-3.3.8-r1.ebuild
deleted file mode 100644
index df77c618bd10..000000000000
--- a/sci-libs/geos/geos-3.3.8-r1.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/geos-3.3.8-r1.ebuild,v 1.7 2013/04/12 07:08:26 vincent Exp $
-
-EAPI=4
-
-PYTHON_DEPEND="python? 2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-inherit autotools eutils python
-
-DESCRIPTION="Geometry engine library for Geographic Information Systems"
-HOMEPAGE="http://trac.osgeo.org/geos/"
-SRC_URI="http://download.osgeo.org/geos/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 arm ppc ppc64 x86 ~x64-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
-IUSE="doc php python ruby static-libs"
-
-RDEPEND="
- php? ( >=dev-lang/php-5.3[-threads] )
- ruby? ( dev-lang/ruby )
-"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )
- php? ( dev-lang/swig )
- python? ( dev-lang/swig )
- ruby? ( dev-lang/swig )
-"
-
-pkg_setup() {
- use python && python_pkg_setup
-}
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/3.2.0-python.patch \
- "${FILESDIR}"/3.2.0-darwin.patch \
- "${FILESDIR}"/3.3.2-solaris-isnan.patch
- eautoreconf
- echo "#!${EPREFIX}/bin/bash" > py-compile
-}
-
-src_configure() {
- econf \
- $(use_enable python) \
- $(use_enable ruby) \
- $(use_enable php) \
- $(use_enable static-libs static)
-}
-
-src_compile() {
- emake
-
- if use python; then
- emake -C swig/python clean
- python_copy_sources swig/python
- building() {
- emake \
- PYTHON_CPPFLAGS="-I${EPREFIX}$(python_get_includedir)" \
- PYTHON_LDFLAGS="$(python_get_library -l)" \
- SWIG_PYTHON_CPPFLAGS="-I${EPREFIX}$(python_get_includedir)" \
- pyexecdir="${EPREFIX}$(python_get_sitedir)" \
- pythondir="${EPREFIX}$(python_get_sitedir)"
- }
- python_execute_function -s --source-dir swig/python building
- fi
-
- use doc && emake -C "${S}/doc" doxygen-html
-}
-
-src_install() {
- default
-
- if use python; then
- installation() {
- emake \
- DESTDIR="${D}" \
- pyexecdir="${EPREFIX}$(python_get_sitedir)" \
- pythondir="${EPREFIX}$(python_get_sitedir)" \
- install
- }
- python_execute_function -s --source-dir swig/python installation
- python_clean_installation_image
- fi
-
- use doc && dohtml -r doc/doxygen_docs/html/*
-
- find "${ED}" -name '*.la' -exec rm -f {} +
-}
-
-pkg_postinst() {
- use python && python_mod_optimize geos/geos.py
-}
-
-pkg_postrm() {
- use python && python_mod_cleanup geos/geos.py
-}
diff --git a/sci-libs/geos/geos-3.4.2.ebuild b/sci-libs/geos/geos-3.4.2-r1.ebuild
index aed409ab85fc..5b127a61875f 100644
--- a/sci-libs/geos/geos-3.4.2.ebuild
+++ b/sci-libs/geos/geos-3.4.2-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/geos-3.4.2.ebuild,v 1.1 2013/10/21 00:26:42 titanofold Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/geos-3.4.2-r1.ebuild,v 1.1 2014/11/05 12:28:48 titanofold Exp $
EAPI="5"
@@ -28,7 +28,8 @@ DEPEND="${RDEPEND}
"
src_prepare() {
- epatch "${FILESDIR}"/3.4.2-solaris-isnan.patch
+ epatch "${FILESDIR}"/3.4.2-solaris-isnan.patch \
+ "${FILESDIR}"/3.4.2-ruby_so_name.patch
eautoreconf
echo "#!${EPREFIX}/bin/bash" > py-compile
}