summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-08-01 00:32:27 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-08-01 00:32:27 +0000
commit6305c1bb3cd91a68e0fd8cde2caaa9307f588de0 (patch)
tree23f0c8a1dfb8243f7aa906b0a72453cda6434cd6 /sci-libs
parentKeywording ~amd64 (diff)
downloadgentoo-2-6305c1bb3cd91a68e0fd8cde2caaa9307f588de0.tar.gz
gentoo-2-6305c1bb3cd91a68e0fd8cde2caaa9307f588de0.tar.bz2
gentoo-2-6305c1bb3cd91a68e0fd8cde2caaa9307f588de0.zip
Synced patch with fixed version from blas-atlas CVS tree to enable compilation on ppc using gcc-4 (see blas-atlas Changelog entry from 05/07/2006). This fixes bug #142294.
(Portage version: 2.1.1_pre3-r5)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/lapack-atlas/ChangeLog9
-rw-r--r--sci-libs/lapack-atlas/files/3.7.11-allow-any-gcc-version.patch21
2 files changed, 25 insertions, 5 deletions
diff --git a/sci-libs/lapack-atlas/ChangeLog b/sci-libs/lapack-atlas/ChangeLog
index 07eb2e61ca73..1bf8ed5575e3 100644
--- a/sci-libs/lapack-atlas/ChangeLog
+++ b/sci-libs/lapack-atlas/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-libs/lapack-atlas
# Copyright 2004-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/ChangeLog,v 1.14 2006/07/27 00:18:07 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/ChangeLog,v 1.15 2006/08/01 00:32:27 markusle Exp $
+
+ 31 Jul 2006; Markus Dittrich <markusle@gentoo.org>
+ files/3.7.11-allow-any-gcc-version.patch:
+ Synced patch with fixed version from blas-atlas CVS tree to enable
+ compilation on ppc using gcc-4 (see blas-atlas Changelog entry
+ from 05/07/2006). Thanks to Matti Bickel <kabel@cat0.de> for
+ pointing this out. This fixes bug #142294.
26 Jul 2006; Markus Dittrich <markusle@gentoo.org>
lapack-atlas-3.7.11.ebuild, lapack-atlas-3.7.11-r1.ebuild:
diff --git a/sci-libs/lapack-atlas/files/3.7.11-allow-any-gcc-version.patch b/sci-libs/lapack-atlas/files/3.7.11-allow-any-gcc-version.patch
index 6dfd33ab74af..a9690c78f7e5 100644
--- a/sci-libs/lapack-atlas/files/3.7.11-allow-any-gcc-version.patch
+++ b/sci-libs/lapack-atlas/files/3.7.11-allow-any-gcc-version.patch
@@ -1,7 +1,6 @@
-diff -urN ATLAS.orig/config.c ATLAS/config.c
---- ATLAS.orig/config.c 2006-01-16 19:08:16.000000000 -0800
-+++ ATLAS/config.c 2006-01-16 19:27:22.000000000 -0800
-@@ -712,11 +712,6 @@
+--- ATLAS-old/config.c 2005-08-21 08:30:17.000000000 -0500
++++ ATLAS/config.c 2006-05-07 16:36:02.000000000 -0500
+@@ -712,25 +712,12 @@
gcc, major, minor, patch);
if (major == -1)
iret = 0;
@@ -13,3 +12,17 @@ diff -urN ATLAS.orig/config.c ATLAS/config.c
else if (mach == IA64Itan || mach == IA64Itan2 || MachIsUS(mach) ||
mach == Dec21164 || mach == Dec21264)
{
+ if (major == 3)
+ iret = 1;
+ }
+-/*
+- * Need 3.2 or newer to make altivec work
+- */
+- else if ((OS == OSLinux || comp != 3) && (mach == PPCG4 || mach == PPCG5))
+- {
+- if (major >= 3 && minor >= 3)
+- iret = 1;
+- }
+ else iret = 1; /* any gcc is fine, take first in path */
+ return (iret);
+ }