summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2005-04-03 15:23:48 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2005-04-03 15:23:48 +0000
commit633a15166e2986c197af91ea1496bc2e6f11e7a0 (patch)
tree745ba01723903f35131dec6aeb63d8db19ac1275 /sci-libs
parentadded ~ppc64 (diff)
downloadgentoo-2-633a15166e2986c197af91ea1496bc2e6f11e7a0.tar.gz
gentoo-2-633a15166e2986c197af91ea1496bc2e6f11e7a0.tar.bz2
gentoo-2-633a15166e2986c197af91ea1496bc2e6f11e7a0.zip
version bump.
(Portage version: 2.0.51.19)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/acml/ChangeLog9
-rw-r--r--sci-libs/acml/Manifest6
-rw-r--r--sci-libs/acml/acml-2.1.0.ebuild4
-rw-r--r--sci-libs/acml/acml-2.5.0.ebuild73
-rw-r--r--sci-libs/acml/files/digest-acml-2.5.02
5 files changed, 88 insertions, 6 deletions
diff --git a/sci-libs/acml/ChangeLog b/sci-libs/acml/ChangeLog
index aca3fa8c11d2..f5b366c6d928 100644
--- a/sci-libs/acml/ChangeLog
+++ b/sci-libs/acml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/acml
-# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/ChangeLog,v 1.2 2004/12/28 19:55:41 swegener Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/ChangeLog,v 1.3 2005/04/03 15:23:48 kugelfang Exp $
+
+*acml-2.5.0 (03 Apr 2005)
+
+ 03 Apr 2005; Danny van Dyk <kugelfang@gentoo.org> +acml-2.5.0.ebuild:
+ Version bump to acml-2.5.0.
*acml-2.1.0 (28 Dec 2004)
diff --git a/sci-libs/acml/Manifest b/sci-libs/acml/Manifest
index 123a449a84a7..c18958d35ba6 100644
--- a/sci-libs/acml/Manifest
+++ b/sci-libs/acml/Manifest
@@ -1,7 +1,9 @@
-MD5 77b49fdfaa00483398312db5545b3303 acml-2.1.0.ebuild 1720
MD5 bc804fb790576358f1c9418d8c2f5a4d ChangeLog 757
+MD5 77b49fdfaa00483398312db5545b3303 acml-2.1.0.ebuild 1720
MD5 c9bfe708975ddd233f47166b8f1053f6 metadata.xml 390
-MD5 3b43533f073305dc2ed60f13091025a0 files/digest-acml-2.1.0 134
+MD5 77b49fdfaa00483398312db5545b3303 acml-2.5.0.ebuild 1720
MD5 e92e9b2507e25e7826de1be1cce7c7ae files/c-ACML.blas 465
+MD5 3b43533f073305dc2ed60f13091025a0 files/digest-acml-2.1.0 134
MD5 ed54e2d6cb585bafe8a23f0a5d07c02b files/f77-ACML.blas 430
MD5 035015e5be8999d26202cfb042029acc files/f77-ACML.lapack 441
+MD5 991ee1ce068d43f39da5177877a6b4ee files/digest-acml-2.5.0 134
diff --git a/sci-libs/acml/acml-2.1.0.ebuild b/sci-libs/acml/acml-2.1.0.ebuild
index 7a4c08d522fc..a5ee84525793 100644
--- a/sci-libs/acml/acml-2.1.0.ebuild
+++ b/sci-libs/acml/acml-2.1.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/acml-2.1.0.ebuild,v 1.2 2004/12/29 18:45:06 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/acml-2.1.0.ebuild,v 1.3 2005/04/03 15:23:48 kugelfang Exp $
inherit eutils
diff --git a/sci-libs/acml/acml-2.5.0.ebuild b/sci-libs/acml/acml-2.5.0.ebuild
new file mode 100644
index 000000000000..3c668b59c118
--- /dev/null
+++ b/sci-libs/acml/acml-2.5.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/acml-2.5.0.ebuild,v 1.1 2005/04/03 15:23:48 kugelfang Exp $
+
+inherit eutils
+
+DESCRIPTION="AMD Core Math Library (ACML) for x86 and amd64 CPUs"
+HOMEPAGE="http://www.developwithamd.com/appPartnerProg/acml/forms/index.cfm?action=home"
+
+MY_PV=${PV//\./\-}
+S=${WORKDIR}
+
+SRC_URI="amd64? ( acml-64bit-${MY_PV}.tgz )
+ x86? ( acml-32bit-${MY_PV}.tgz )"
+RESTRICT="fetch nostrip"
+IUSE=""
+LICENSE="ACML"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+RDEPEND="virtual/libc
+ sci-libs/blas-config
+ sci-libs/lapack-config"
+PROVIDE="virtual/blas
+ virtual/lapack"
+
+src_unpack() {
+ unpack ${A}
+ if [ "${ARCH}" == "amd64" ]; then
+ export SUFFIX="64"
+ else
+ export SUFFIX="32"
+ fi
+ (DISTDIR="${S}" unpack contents${SUFFIX}.tgz)
+
+ # Remove non-gnu libraries...
+ # TODO: probably a useflag for non-gnu libraries to be used ?
+ rm -Rf ${S}/pgi* install*.sh README*
+ mv Doc doc
+
+}
+
+src_compile() {
+ return
+}
+
+src_install() {
+ # Documentation
+ cd ${S}/doc
+ dodoc acml.*
+
+ # Headers
+ mkdir -p ${D}/usr/include/acml/
+ cp ${S}/gnu${SUFFIX}/include/* ${D}/usr/include/acml/
+
+ # Libraries
+ mkdir -p ${D}/usr/$(get_libdir)/
+ cp ${S}/gnu${SUFFIX}/lib/* ${D}/usr/$(get_libdir)/
+ unset SUFFIX
+
+ # Configfiles
+ mkdir -p ${D}/usr/$(get_libdir)/{blas,lapack}
+ for x in ${FILESDIR}/*.{blas,lapack}; do
+ y="$(basename $x)"
+ cp $x ${D}/usr/$(get_libdir)/${y/*\.}/${y/\.*}
+ done
+}
+
+pkg_postinst() {
+ einfo "To use ACML's BLAS features, you have to issue (as root):"
+ einfo "\n\t/usr/bin/blas-config ACML"
+ einfo "To use ACML's LAPACK features, you have to issue (as root):"
+ einfo "\n\t/usr/bin/lapack-config ACML"
+}
diff --git a/sci-libs/acml/files/digest-acml-2.5.0 b/sci-libs/acml/files/digest-acml-2.5.0
new file mode 100644
index 000000000000..811de400ad4b
--- /dev/null
+++ b/sci-libs/acml/files/digest-acml-2.5.0
@@ -0,0 +1,2 @@
+MD5 48a96211b5af7413d45dc8a06767906b acml-64bit-2-5-0.tgz 25893994
+MD5 d4fa77b6e6ca9625f9c6a61fc7d919a0 acml-32bit-2-5-0.tgz 51348288