summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-03-07 19:14:51 +0000
committerJustin Lecher <jlec@gentoo.org>2010-03-07 19:14:51 +0000
commit67bcb0d3bc6d7ca68a29dccc787e5230bc0eae83 (patch)
tree07697dd22471884c9c91dcffd4da55970555de5e /sci-libs
parentMoved to EAPI=3 for PREFIX support, imported prefix patches from overlay, key... (diff)
downloadgentoo-2-67bcb0d3bc6d7ca68a29dccc787e5230bc0eae83.tar.gz
gentoo-2-67bcb0d3bc6d7ca68a29dccc787e5230bc0eae83.tar.bz2
gentoo-2-67bcb0d3bc6d7ca68a29dccc787e5230bc0eae83.zip
Moved to EAPI=3 for PREFIX support, imported prefix patches from overlay, keyworded {amd64,x86}-linux
(Portage version: 2.2_rc65/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/cblas-reference/ChangeLog11
-rw-r--r--sci-libs/cblas-reference/cblas-reference-20030223-r5.ebuild69
2 files changed, 78 insertions, 2 deletions
diff --git a/sci-libs/cblas-reference/ChangeLog b/sci-libs/cblas-reference/ChangeLog
index 970f88f3d10d..4f77c77f2b87 100644
--- a/sci-libs/cblas-reference/ChangeLog
+++ b/sci-libs/cblas-reference/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-libs/cblas-reference
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cblas-reference/ChangeLog,v 1.32 2008/04/21 14:54:44 bicatali Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cblas-reference/ChangeLog,v 1.33 2010/03/07 19:14:51 jlec Exp $
+
+*cblas-reference-20030223-r5 (07 Mar 2010)
+
+ 07 Mar 2010; Justin Lecher (jlec) <jlec@gentoo.org>
+ +cblas-reference-20030223-r5.ebuild:
+ Moved to EAPI=3 for PREFIX support, imported prefix patches from overlay,
+ keyworded {amd64,x86}-linux
21 Apr 2008; Sébastien Fabbro <bicatali@gentoo.org>
cblas-reference-20030223-r4.ebuild:
diff --git a/sci-libs/cblas-reference/cblas-reference-20030223-r5.ebuild b/sci-libs/cblas-reference/cblas-reference-20030223-r5.ebuild
new file mode 100644
index 000000000000..87acdd47b407
--- /dev/null
+++ b/sci-libs/cblas-reference/cblas-reference-20030223-r5.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cblas-reference/cblas-reference-20030223-r5.ebuild,v 1.1 2010/03/07 19:14:51 jlec Exp $
+
+EAPI="3"
+
+inherit autotools eutils fortran multilib
+
+MyPN="${PN/-reference/}"
+
+DESCRIPTION="C wrapper interface to the F77 reference BLAS implementation"
+LICENSE="public-domain"
+HOMEPAGE="http://www.netlib.org/blas/"
+SRC_URI="http://www.netlib.org/blas/blast-forum/${MyPN}.tgz"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+
+RDEPEND="virtual/blas
+ app-admin/eselect-cblas"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+FORTRAN="gfortran g77 ifc"
+ESELECT_PROF=reference
+S="${WORKDIR}/CBLAS"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-autotool.patch
+ eautoreconf
+
+ cp "${FILESDIR}"/eselect.cblas.reference "${T}"/
+ sed -i -e "s:/usr:${EPREFIX}/usr:" "${T}"/eselect.cblas.reference || die
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ sed -i -e 's/\.so\([\.0-9]\+\)\?/\1.dylib/g' \
+ "${T}"/eselect.cblas.reference || die
+ fi
+}
+
+src_configure() {
+ econf \
+ --libdir="${EPREFIX}"/usr/$(get_libdir)/blas/reference \
+ --with-blas="$(pkg-config --libs blas)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README || die "failed to install docs"
+ insinto /usr/share/doc/${PF}
+ doins cblas_example*c || die "install examples failed"
+ eselect cblas add $(get_libdir) "${T}"/eselect.cblas.reference ${ESELECT_PROF}
+}
+
+pkg_postinst() {
+ local p=cblas
+ local current_lib=$(eselect ${p} show | cut -d' ' -f2)
+ if [[ ${current_lib} == ${ESELECT_PROF} || -z ${current_lib} ]]; then
+ # work around eselect bug #189942
+ local configfile="${EROOT}"/etc/env.d/${p}/$(get_libdir)/config
+ [[ -e ${configfile} ]] && rm -f ${configfile}
+ eselect ${p} set ${ESELECT_PROF}
+ elog "${p} has been eselected to ${ESELECT_PROF}"
+ else
+ elog "Current eselected ${p} is ${current_lib}"
+ elog "To use ${p} ${ESELECT_PROF} implementation, you have to issue (as root):"
+ elog "\t eselect ${p} set ${ESELECT_PROF}"
+ fi
+}