summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-22 14:30:07 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-22 14:30:07 +0000
commit7ec05aa641e1455c52cdc0bca2b90504274765df (patch)
treeb0fd3770392245cf89e0874d3f029554e735a86d /sci-libs
parentStable for HPPA (bug #322297). (diff)
downloadgentoo-2-7ec05aa641e1455c52cdc0bca2b90504274765df.tar.gz
gentoo-2-7ec05aa641e1455c52cdc0bca2b90504274765df.tar.bz2
gentoo-2-7ec05aa641e1455c52cdc0bca2b90504274765df.zip
Parallel build fix, #187759
(Portage version: 2.2_rc67/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/netcdf/ChangeLog6
-rw-r--r--sci-libs/netcdf/files/netcdf-3.6.3-parallel.patch17
-rw-r--r--sci-libs/netcdf/netcdf-3.6.3.ebuild5
3 files changed, 25 insertions, 3 deletions
diff --git a/sci-libs/netcdf/ChangeLog b/sci-libs/netcdf/ChangeLog
index 392343184cec..1d9bbc835f16 100644
--- a/sci-libs/netcdf/ChangeLog
+++ b/sci-libs/netcdf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/netcdf
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/ChangeLog,v 1.66 2010/04/27 16:13:14 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/ChangeLog,v 1.67 2010/06/22 14:30:06 jlec Exp $
+
+ 22 Jun 2010; Justin Lecher <jlec@gentoo.org> netcdf-3.6.3.ebuild,
+ +files/netcdf-3.6.3-parallel.patch:
+ Parallel build fix, #187759
*netcdf-4.1.1 (27 Apr 2010)
diff --git a/sci-libs/netcdf/files/netcdf-3.6.3-parallel.patch b/sci-libs/netcdf/files/netcdf-3.6.3-parallel.patch
new file mode 100644
index 000000000000..14364b831ccf
--- /dev/null
+++ b/sci-libs/netcdf/files/netcdf-3.6.3-parallel.patch
@@ -0,0 +1,17 @@
+diff --git a/f90/Makefile.am b/f90/Makefile.am
+index ee56177..e9828eb 100644
+--- a/f90/Makefile.am
++++ b/f90/Makefile.am
+@@ -64,10 +64,12 @@ if UPPER_CASE_MOD
+ nodist_include_HEADERS = TYPESIZES.mod NETCDF.mod
+ TYPESIZES.mod: typeSizes.o
+ NETCDF.mod: $(NETCDF_O)
++BUILT_SOURCES = TYPESIZES.mod
+ else
+ nodist_include_HEADERS = typesizes.mod netcdf.mod
+ typesizes.mod: typeSizes.o
+ netcdf.mod: $(NETCDF_O)
++BUILT_SOURCES = typesizes.mod
+ endif
+
+ # This is what we are building: a convenience library of F90 functions.
diff --git a/sci-libs/netcdf/netcdf-3.6.3.ebuild b/sci-libs/netcdf/netcdf-3.6.3.ebuild
index fd37a24ad0c7..ddc67df3683a 100644
--- a/sci-libs/netcdf/netcdf-3.6.3.ebuild
+++ b/sci-libs/netcdf/netcdf-3.6.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/netcdf-3.6.3.ebuild,v 1.13 2009/12/07 18:30:46 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/netcdf-3.6.3.ebuild,v 1.14 2010/06/22 14:30:06 jlec Exp $
EAPI=2
@@ -29,6 +29,7 @@ pkg_setup() {
src_prepare() {
epatch "${FILESDIR}"/${P}-as-needed.patch
+ epatch "${FILESDIR}"/${P}-parallel.patch
eautoreconf
}