summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-02-07 17:00:10 +0000
committerMichał Górny <mgorny@gentoo.org>2013-02-07 17:00:10 +0000
commit7f0fa6e48bbedc67740684f694caa107a43e979a (patch)
tree51c0f526d2e4eeafc3920cb852ad8b57a0d96e7f /sci-libs
parentfix parallel build problem, which renders nawk useless (bug #455786) (diff)
downloadgentoo-2-7f0fa6e48bbedc67740684f694caa107a43e979a.tar.gz
gentoo-2-7f0fa6e48bbedc67740684f694caa107a43e979a.tar.bz2
gentoo-2-7f0fa6e48bbedc67740684f694caa107a43e979a.zip
Migrate to distutils-r1. Backport patch for test failures.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/scipy/ChangeLog10
-rw-r--r--sci-libs/scipy/files/scipy-0.11.0-test_basic.patch48
-rw-r--r--sci-libs/scipy/scipy-0.11.0-r1.ebuild136
3 files changed, 192 insertions, 2 deletions
diff --git a/sci-libs/scipy/ChangeLog b/sci-libs/scipy/ChangeLog
index 29c9c30c55cc..432d3153951f 100644
--- a/sci-libs/scipy/ChangeLog
+++ b/sci-libs/scipy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/scipy
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/ChangeLog,v 1.82 2012/12/13 16:07:11 jlec Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/ChangeLog,v 1.83 2013/02/07 17:00:10 mgorny Exp $
+
+*scipy-0.11.0-r1 (07 Feb 2013)
+
+ 07 Feb 2013; Michał Górny <mgorny@gentoo.org>
+ +files/scipy-0.11.0-test_basic.patch, +scipy-0.11.0-r1.ebuild:
+ Migrate to distutils-r1. Backport patch for test failures.
13 Dec 2012; Justin Lecher <jlec@gentoo.org> scipy-0.11.0.ebuild,
metadata.xml:
diff --git a/sci-libs/scipy/files/scipy-0.11.0-test_basic.patch b/sci-libs/scipy/files/scipy-0.11.0-test_basic.patch
new file mode 100644
index 000000000000..0b1018a3b9c0
--- /dev/null
+++ b/sci-libs/scipy/files/scipy-0.11.0-test_basic.patch
@@ -0,0 +1,48 @@
+From 6c1cd446bb6c3ffcc131de5b81e21b481400c334 Mon Sep 17 00:00:00 2001
+From: Pauli Virtanen <pav@iki.fi>
+Date: Sat, 3 Nov 2012 17:13:30 +0200
+Subject: [PATCH] TST: special: fix test_basic.py:cephes_vs_amos_mass_test
+
+---
+ scipy/special/tests/test_basic.py | 22 ++++++++++++++--------
+ 1 file changed, 14 insertions(+), 8 deletions(-)
+
+diff --git a/scipy/special/tests/test_basic.py b/scipy/special/tests/test_basic.py
+index 973322a..6ef4f7f 100644
+--- a/scipy/special/tests/test_basic.py
++++ b/scipy/special/tests/test_basic.py
+@@ -1770,17 +1770,23 @@ def test_iv_cephes_vs_amos_mass_test(self):
+ x = np.random.pareto(0.2, N) * (-1)**np.random.randint(2, size=N)
+
+ imsk = (np.random.randint(8, size=N) == 0)
+- v[imsk] = v.astype(int)
++ v[imsk] = v[imsk].astype(int)
+
+- c1 = special.iv(v, x)
+- c2 = special.iv(v, x+0j)
++ old_err = np.seterr(all='ignore')
++ try:
++ c1 = special.iv(v, x)
++ c2 = special.iv(v, x+0j)
+
+- # deal with differences in the inf cutoffs
+- c1[abs(c1) > 1e300] = np.inf
+- c2[abs(c2) > 1e300] = np.inf
++ # deal with differences in the inf and zero cutoffs
++ c1[abs(c1) > 1e300] = np.inf
++ c2[abs(c2) > 1e300] = np.inf
++ c1[abs(c1) < 1e-300] = 0
++ c2[abs(c2) < 1e-300] = 0
+
+- dc = abs(c1/c2 - 1)
+- dc[np.isnan(dc)] = 0
++ dc = abs(c1/c2 - 1)
++ dc[np.isnan(dc)] = 0
++ finally:
++ np.seterr(**old_err)
+
+ k = np.argmax(dc)
+
+--
+1.7.10
+
diff --git a/sci-libs/scipy/scipy-0.11.0-r1.ebuild b/sci-libs/scipy/scipy-0.11.0-r1.ebuild
new file mode 100644
index 000000000000..875729614079
--- /dev/null
+++ b/sci-libs/scipy/scipy-0.11.0-r1.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.11.0-r1.ebuild,v 1.1 2013/02/07 17:00:10 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2} )
+
+inherit eutils fortran-2 distutils-r1 flag-o-matic multilib toolchain-funcs
+
+DESCRIPTION="Scientific algorithms library for Python"
+HOMEPAGE="http://www.scipy.org/ http://pypi.python.org/pypi/scipy"
+SRC_URI="
+ mirror://sourceforge/${PN}/${P}.tar.gz
+ doc? (
+ http://docs.scipy.org/doc/${P}/${PN}-html.zip -> ${P}-html.zip
+ http://docs.scipy.org/doc/${P}/${PN}-ref.pdf -> ${P}-ref.pdf
+ )"
+
+LICENSE="BSD LGPL-2"
+SLOT="0"
+IUSE="doc test umfpack"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+CDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/arpack
+ virtual/cblas
+ virtual/lapack
+ umfpack? ( sci-libs/umfpack )"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ doc? ( app-arch/unzip )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ umfpack? ( dev-lang/swig )"
+
+RDEPEND="${CDEPEND}
+ dev-python/imaging[$(python_gen_usedep python2*)]"
+
+DOCS=( HACKING.rst.txt README.txt THANKS.txt LATEST.txt TOCHANGE.txt )
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ if use doc; then
+ unzip -qo "${DISTDIR}"/${P}-html.zip -d html || die
+ fi
+}
+
+pc_incdir() {
+ pkg-config --cflags-only-I $@ | \
+ sed -e 's/^-I//' -e 's/[ ]*-I/:/g'
+}
+
+pc_libdir() {
+ pkg-config --libs-only-L $@ | \
+ sed -e 's/^-L//' -e 's/[ ]*-L/:/g'
+}
+
+pc_libs() {
+ pkg-config --libs-only-l $@ | \
+ sed -e 's/[ ]-l*\(pthread\|m\)[ ]*//g' \
+ -e 's/^-l//' -e 's/[ ]*-l/,/g'
+}
+
+python_prepare_all() {
+ local libdir="${EPREFIX}"/usr/$(get_libdir)
+
+ # scipy automatically detects libraries by default
+ export {FFTW,FFTW3,UMFPACK}=None
+ use umfpack && unset UMFPACK
+ # the missing symbols are in -lpythonX.Y, but since the version can
+ # differ, we just introduce the same scaryness as on Linux/ELF
+ [[ ${CHOST} == *-darwin* ]] \
+ && append-ldflags -bundle "-undefined dynamic_lookup" \
+ || append-ldflags -shared
+ [[ -z ${FC} ]] && export FC="$(tc-getFC)"
+ # hack to force F77 to be FC until bug #278772 is fixed
+ [[ -z ${F77} ]] && export F77="$(tc-getFC)"
+ export F90="${FC}"
+ export SCIPY_FCONFIG="config_fc --noopt --noarch"
+ append-fflags -fPIC
+
+ cat >> site.cfg <<-EOF
+ [blas]
+ include_dirs = $(pc_incdir cblas)
+ library_dirs = $(pc_libdir cblas blas):${libdir}
+ blas_libs = $(pc_libs cblas blas)
+ [lapack]
+ library_dirs = $(pc_libdir lapack):${libdir}
+ lapack_libs = $(pc_libs lapack)
+ EOF
+
+ local PATCHES=(
+ "${FILESDIR}"/${P}-test_basic.patch
+ )
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ distutils-r1_python_compile ${SCIPY_FCONFIG}
+}
+
+python_test() {
+ local test_dir="${BUILD_DIR}"/build/tests
+ mkdir -p "${test_dir}" || die
+ local PYTHONPATH=${test_dir}:${PYTHONPATH}
+
+ export PYTHONPATH
+
+ esetup.py install --install-lib="${test_dir}" \
+ --install-scripts="${test_dir}/bin" ${SCIPY_FCONFIG}
+
+ cd "${TMPDIR}" || die
+ "${PYTHON}" -c "
+import scipy, sys
+r = scipy.test('full', verbose=10)
+sys.exit(0 if r.wasSuccessful() else 1)" || die "Tests fail with ${EPYTHON}"
+}
+
+python_install() {
+ distutils-r1_python_install ${SCIPY_FCONFIG}
+
+ if use doc; then
+ dohtml -r "${WORKDIR}"/html/.
+ dodoc "${DISTDIR}"/${P}*pdf
+ fi
+}
+
+pkg_postinst() {
+ elog "You might want to set the variable SCIPY_PIL_IMAGE_VIEWER"
+ elog "to your prefered image viewer if you don't like the default one. Ex:"
+ elog "\t echo \"export SCIPY_PIL_IMAGE_VIEWER=display\" >> ~/.bashrc"
+}