summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2005-12-18 18:09:03 +0000
committerMarkus Dittrich <markusle@gentoo.org>2005-12-18 18:09:03 +0000
commit9e069b9e961ecdaaf4e4c97c441c24023088cd8c (patch)
treed988b94d7b957eac360908d143e06d5bd5f20c25 /sci-libs
parentStable on ppc64 (diff)
downloadgentoo-2-9e069b9e961ecdaaf4e4c97c441c24023088cd8c.tar.gz
gentoo-2-9e069b9e961ecdaaf4e4c97c441c24023088cd8c.tar.bz2
gentoo-2-9e069b9e961ecdaaf4e4c97c441c24023088cd8c.zip
Fixed compilation problems when using cmake-2.2.x and when compiling against python 2.4.x. Also corrected installation path of vtk jar file. This fixes bugs #112119, #103343, #113597.
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/vtk/ChangeLog7
-rw-r--r--sci-libs/vtk/Manifest16
-rw-r--r--sci-libs/vtk/vtk-4.2.6.ebuild27
3 files changed, 32 insertions, 18 deletions
diff --git a/sci-libs/vtk/ChangeLog b/sci-libs/vtk/ChangeLog
index 72c0894599a6..8f9ff47b978d 100644
--- a/sci-libs/vtk/ChangeLog
+++ b/sci-libs/vtk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/vtk
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/ChangeLog,v 1.5 2005/10/08 17:29:34 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/ChangeLog,v 1.6 2005/12/18 18:09:03 markusle Exp $
+
+ 18 Dec 2005; Markus Dittrich <markusle@gentoo.org> vtk-4.2.6.ebuild:
+ Fixed compilation problems when using cmake-2.2.x and when compiling against
+ python 2.4.x. Also corrected installation path of vtk jar file. This fixes
+ bugs #112119, #103343, #113597.
08 Oct 2005; Thomas Matthijs <axxo@gentoo.org> vtk-4.2.6.ebuild:
use java-pkg_dojar not dojar
diff --git a/sci-libs/vtk/Manifest b/sci-libs/vtk/Manifest
index 194b8cf94890..e17800977fc1 100644
--- a/sci-libs/vtk/Manifest
+++ b/sci-libs/vtk/Manifest
@@ -1,15 +1,5 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 96fb073e8b5e945d7bc08ef031cd6918 ChangeLog 777
+MD5 5c8c1a47810a4ec75712acd24a0d97fa vtk-4.2.6.ebuild 5826
+MD5 d573ad6a45f251d216562e2e360ca7f6 ChangeLog 1039
+MD5 4118533a691d09c1f81d0d97998eb34c metadata.xml 253
MD5 9aa6be7b823601bf2e88869264d90673 files/digest-vtk-4.2.6 207
MD5 7ba663b347dd89aa7ca2f19e50641057 files/vtk-4.2.6-gcc34.patch 1739
-MD5 4118533a691d09c1f81d0d97998eb34c metadata.xml 253
-MD5 21ca482edaa6c443539e965925756091 vtk-4.2.6.ebuild 5216
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFDSAIc/rLF9B432nYRAlqHAJsHOUqMTvmF1OaMNv6kD6gepchdQwCgzzl2
-j9PZ2JJLle5cw1Y2nVBdeok=
-=TESY
------END PGP SIGNATURE-----
diff --git a/sci-libs/vtk/vtk-4.2.6.ebuild b/sci-libs/vtk/vtk-4.2.6.ebuild
index 15162592f391..1c267c2b927c 100644
--- a/sci-libs/vtk/vtk-4.2.6.ebuild
+++ b/sci-libs/vtk/vtk-4.2.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-4.2.6.ebuild,v 1.6 2005/10/08 17:29:34 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-4.2.6.ebuild,v 1.7 2005/12/18 18:09:03 markusle Exp $
# TODO: need to fix Examples/CMakeLists.txt to build other examples
@@ -71,12 +71,31 @@ src_compile() {
CMAKE_VARIABLES="${CMAKE_VARIABLES} -DVTK_USE_MPI:BOOL=ON"
use !threads && CMAKE_VARIABLES="${CMAKE_VARIABLES} -DVTK_USE_PARALLEL:BOOL=ON"
fi
- use python && CMAKE_VARIABLES="${CMAKE_VARIABLES} -DVTK_WRAP_PYTHON:BOOL=ON"
+
+ if use python; then
+
+ #determine installed python version
+ local tmp="$(/usr/bin/python -V 2>&1 )"
+ local PY_VERSION="${tmp#Python }"
+ local PY_MAJOR="$(echo ${PY_VERSION} | cut -d. -f1)"
+ local PY_MINOR="$(echo ${PY_VERSION} | cut -d. -f2)"
+ local PY_VERSION="${PY_MAJOR}.${PY_MINOR}"
+
+ # set variables
+ CMAKE_VARIABLES="${CMAKE_VARIABLES} -DVTK_WRAP_PYTHON:BOOL=ON"
+ CMAKE_VARIABLES="${CMAKE_VARIABLES} -DPYTHON_INCLUDE_PATH:PATH=/usr/include/python${PY_VERSION}"
+ CMAKE_VARIABLES="${CMAKE_VARIABLES} -DPYTHON_LIBRARY:PATH=/usr/lib/libpython${PY_VERSION}.so"
+ fi
+
use tcltk && CMAKE_VARIABLES="${CMAKE_VARIABLES} -DVTK_WRAP_TCL:BOOL=ON"
use threads && CMAKE_VARIABLES="${CMAKE_VARIABLES} -DVTK_USE_PARALLEL:BOOL=ON"
use patented && CMAKE_VARIABLES="${CMAKE_VARIABLES} -DVTK_USE_PATENTED:BOOL=ON"
- cmake ${CMAKE_VARIABLES} . || die "cmake configuration failed"
+ # run cmake twice to achieve proper
+ # configuration with cmake 2.2.x
+ cmake ${CMAKE_VARIABLES} . && cmake ${CMAKE_VARIABLES} . \
+ || die "cmake configuration failed"
+
emake || die "emake failed"
}
@@ -132,7 +151,7 @@ src_install() {
echo "LDPATH=${LDPATH}" > ${T}/40${PN}
echo "VTK_DATA_ROOT=/usr/share/${PN}/data" >> ${T}/40${PN}
if use java; then
- echo "CLASSPATH=/usr/share/${PN}/${PN}.jar" >> ${T}/40${PN}
+ echo "CLASSPATH=/usr/share/${PN}/lib/${PN}.jar" >> ${T}/40${PN}
echo "LD_LIBRARY_PATH=/usr/lib/${PN}" >> ${T}/40${PN}
fi
use tcltk && echo "TCLLIBPATH=/usr/lib/${PN}/tcl" >> ${T}/40${PN}