summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2005-12-19 16:09:31 +0000
committerMarkus Dittrich <markusle@gentoo.org>2005-12-19 16:09:31 +0000
commita4a6d21535b4a6817f1eaf1bd9662b9dfb987e1b (patch)
tree815be312289ef9be7807520c273999bcedc5d329 /sci-libs
parentinitial import wrt bug#96454 (diff)
downloadgentoo-2-a4a6d21535b4a6817f1eaf1bd9662b9dfb987e1b.tar.gz
gentoo-2-a4a6d21535b4a6817f1eaf1bd9662b9dfb987e1b.tar.bz2
gentoo-2-a4a6d21535b4a6817f1eaf1bd9662b9dfb987e1b.zip
Use python eclass functions to determine installed python version.
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/vtk/ChangeLog5
-rw-r--r--sci-libs/vtk/Manifest4
-rw-r--r--sci-libs/vtk/vtk-4.2.6.ebuild18
3 files changed, 11 insertions, 16 deletions
diff --git a/sci-libs/vtk/ChangeLog b/sci-libs/vtk/ChangeLog
index 8f9ff47b978d..4487016cf3f5 100644
--- a/sci-libs/vtk/ChangeLog
+++ b/sci-libs/vtk/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-libs/vtk
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/ChangeLog,v 1.6 2005/12/18 18:09:03 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/ChangeLog,v 1.7 2005/12/19 16:09:31 markusle Exp $
+
+ 19 Dec 2005; Markus Dittrich <markusle@gentoo.org> vtk-4.2.6.ebuild:
+ Use python eclass functions to determine installed python version.
18 Dec 2005; Markus Dittrich <markusle@gentoo.org> vtk-4.2.6.ebuild:
Fixed compilation problems when using cmake-2.2.x and when compiling against
diff --git a/sci-libs/vtk/Manifest b/sci-libs/vtk/Manifest
index 668f240b4f6a..8d2e97e694f2 100644
--- a/sci-libs/vtk/Manifest
+++ b/sci-libs/vtk/Manifest
@@ -1,5 +1,5 @@
-MD5 09d0c769012539017ce446dedff1a1d9 vtk-4.2.6.ebuild 5830
-MD5 b8c57334ae30a2aeb9511538ca584580 ChangeLog 1043
+MD5 7a4163b5bbdb5f02eb4c1d67289fb0b7 vtk-4.2.6.ebuild 5553
+MD5 16f2385929b046e8f245c9e4e170fa9c ChangeLog 1184
MD5 4118533a691d09c1f81d0d97998eb34c metadata.xml 253
MD5 9aa6be7b823601bf2e88869264d90673 files/digest-vtk-4.2.6 207
MD5 7ba663b347dd89aa7ca2f19e50641057 files/vtk-4.2.6-gcc34.patch 1739
diff --git a/sci-libs/vtk/vtk-4.2.6.ebuild b/sci-libs/vtk/vtk-4.2.6.ebuild
index 1c267c2b927c..06226ad24821 100644
--- a/sci-libs/vtk/vtk-4.2.6.ebuild
+++ b/sci-libs/vtk/vtk-4.2.6.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-4.2.6.ebuild,v 1.7 2005/12/18 18:09:03 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-4.2.6.ebuild,v 1.8 2005/12/19 16:09:31 markusle Exp $
# TODO: need to fix Examples/CMakeLists.txt to build other examples
-inherit distutils eutils flag-o-matic toolchain-funcs versionator java-pkg
+inherit distutils eutils flag-o-matic toolchain-funcs versionator java-pkg python
MY_PV="$(get_version_component_range 1-2)"
@@ -73,18 +73,10 @@ src_compile() {
fi
if use python; then
-
- #determine installed python version
- local tmp="$(/usr/bin/python -V 2>&1 )"
- local PY_VERSION="${tmp#Python }"
- local PY_MAJOR="$(echo ${PY_VERSION} | cut -d. -f1)"
- local PY_MINOR="$(echo ${PY_VERSION} | cut -d. -f2)"
- local PY_VERSION="${PY_MAJOR}.${PY_MINOR}"
-
- # set variables
+ python_version
CMAKE_VARIABLES="${CMAKE_VARIABLES} -DVTK_WRAP_PYTHON:BOOL=ON"
- CMAKE_VARIABLES="${CMAKE_VARIABLES} -DPYTHON_INCLUDE_PATH:PATH=/usr/include/python${PY_VERSION}"
- CMAKE_VARIABLES="${CMAKE_VARIABLES} -DPYTHON_LIBRARY:PATH=/usr/lib/libpython${PY_VERSION}.so"
+ CMAKE_VARIABLES="${CMAKE_VARIABLES} -DPYTHON_INCLUDE_PATH:PATH=/usr/include/python${PYVER}"
+ CMAKE_VARIABLES="${CMAKE_VARIABLES} -DPYTHON_LIBRARY:PATH=/usr/lib/libpython${PYVER}.so"
fi
use tcltk && CMAKE_VARIABLES="${CMAKE_VARIABLES} -DVTK_WRAP_TCL:BOOL=ON"