summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2010-01-21 23:38:27 +0000
committerMarkus Dittrich <markusle@gentoo.org>2010-01-21 23:38:27 +0000
commita5fd38bc9c2fe92d5384dd5f696089936b58a935 (patch)
tree8c1fab4330b8b584f01a4173fa388c993c5721c0 /sci-libs
parentFix Makefile to respect user CFLAGS (diff)
downloadgentoo-2-a5fd38bc9c2fe92d5384dd5f696089936b58a935.tar.gz
gentoo-2-a5fd38bc9c2fe92d5384dd5f696089936b58a935.tar.bz2
gentoo-2-a5fd38bc9c2fe92d5384dd5f696089936b58a935.zip
Added patch to allow compilation against boost-1.42 (fixes #301684).
(Portage version: 2.1.7.16/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/vtk/ChangeLog6
-rw-r--r--sci-libs/vtk/files/vtk-5.4.2-boost-property_map.patch72
-rw-r--r--sci-libs/vtk/vtk-5.4.2-r1.ebuild5
3 files changed, 80 insertions, 3 deletions
diff --git a/sci-libs/vtk/ChangeLog b/sci-libs/vtk/ChangeLog
index 65800dd25fc6..c2c2bee4e23a 100644
--- a/sci-libs/vtk/ChangeLog
+++ b/sci-libs/vtk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/vtk
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/ChangeLog,v 1.60 2010/01/16 20:16:29 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/ChangeLog,v 1.61 2010/01/21 23:38:26 markusle Exp $
+
+ 21 Jan 2010; Markus Dittrich <markusle@gentoo.org> vtk-5.4.2-r1.ebuild,
+ +files/vtk-5.4.2-boost-property_map.patch:
+ Added patch to allow compilation against boost-1.42 (fixes #301684).
16 Jan 2010; Markus Dittrich <markusle@gentoo.org> vtk-5.4.2-r1.ebuild:
Updated handling of mycmakeargs from cmake-utils.eclass.
diff --git a/sci-libs/vtk/files/vtk-5.4.2-boost-property_map.patch b/sci-libs/vtk/files/vtk-5.4.2-boost-property_map.patch
new file mode 100644
index 000000000000..abba0d2ff5ae
--- /dev/null
+++ b/sci-libs/vtk/files/vtk-5.4.2-boost-property_map.patch
@@ -0,0 +1,72 @@
+diff -Naur VTK/Infovis/Testing/Cxx/TestBoostAdapter.cxx VTK.new/Infovis/Testing/Cxx/TestBoostAdapter.cxx
+--- VTK/Infovis/Testing/Cxx/TestBoostAdapter.cxx 2008-11-01 15:22:38.000000000 -0400
++++ VTK.new/Infovis/Testing/Cxx/TestBoostAdapter.cxx 2010-01-21 17:53:23.000000000 -0500
+@@ -36,7 +36,7 @@
+ #include <boost/graph/strong_components.hpp>
+ #include <boost/graph/dijkstra_shortest_paths.hpp>
+ #include <boost/graph/transitive_closure.hpp>
+-#include <boost/property_map.hpp>
++#include <boost/property_map/property_map.hpp>
+ #include <boost/vector_property_map.hpp>
+
+ #include "vtkGraph.h"
+diff -Naur VTK/Infovis/vtkBoostBreadthFirstSearch.cxx VTK.new/Infovis/vtkBoostBreadthFirstSearch.cxx
+--- VTK/Infovis/vtkBoostBreadthFirstSearch.cxx 2008-12-02 11:42:38.000000000 -0500
++++ VTK.new/Infovis/vtkBoostBreadthFirstSearch.cxx 2010-01-21 17:52:56.000000000 -0500
+@@ -46,7 +46,7 @@
+
+ #include <boost/graph/visitors.hpp>
+ #include <boost/graph/breadth_first_search.hpp>
+-#include <boost/property_map.hpp>
++#include <boost/property_map/property_map.hpp>
+ #include <boost/vector_property_map.hpp>
+ #include <boost/pending/queue.hpp>
+
+diff -Naur VTK/Parallel/vtkPBGLBreadthFirstSearch.cxx VTK.new/Parallel/vtkPBGLBreadthFirstSearch.cxx
+--- VTK/Parallel/vtkPBGLBreadthFirstSearch.cxx 2008-12-04 16:17:46.000000000 -0500
++++ VTK.new/Parallel/vtkPBGLBreadthFirstSearch.cxx 2010-01-21 17:53:58.000000000 -0500
+@@ -50,7 +50,7 @@
+ #include <boost/graph/distributed/breadth_first_search.hpp>
+ #include <boost/parallel/algorithm.hpp>
+ #include <boost/graph/visitors.hpp>
+-#include <boost/property_map.hpp>
++#include <boost/property_map/property_map.hpp>
+ #include <boost/vector_property_map.hpp>
+ #include <boost/pending/queue.hpp>
+
+diff -Naur VTK/Parallel/vtkPBGLMinimumSpanningTree.cxx VTK.new/Parallel/vtkPBGLMinimumSpanningTree.cxx
+--- VTK/Parallel/vtkPBGLMinimumSpanningTree.cxx 2008-12-04 16:17:46.000000000 -0500
++++ VTK.new/Parallel/vtkPBGLMinimumSpanningTree.cxx 2010-01-21 17:54:18.000000000 -0500
+@@ -48,7 +48,7 @@
+ #include <boost/graph/distributed/dehne_gotz_min_spanning_tree.hpp>
+ #include <boost/graph/distributed/vertex_list_adaptor.hpp>
+ #include <boost/parallel/global_index_map.hpp>
+-#include <boost/property_map.hpp>
++#include <boost/property_map/property_map.hpp>
+ #include <boost/vector_property_map.hpp>
+ #include <boost/pending/queue.hpp>
+
+diff -Naur VTK/Parallel/vtkPBGLShortestPaths.cxx VTK.new/Parallel/vtkPBGLShortestPaths.cxx
+--- VTK/Parallel/vtkPBGLShortestPaths.cxx 2009-02-23 16:08:57.000000000 -0500
++++ VTK.new/Parallel/vtkPBGLShortestPaths.cxx 2010-01-21 17:54:36.000000000 -0500
+@@ -49,7 +49,7 @@
+
+ #include <boost/graph/distributed/delta_stepping_shortest_paths.hpp>
+ #include <boost/parallel/algorithm.hpp>
+-#include <boost/property_map.hpp>
++#include <boost/property_map/property_map.hpp>
+ #include <boost/vector_property_map.hpp>
+
+ #include <vtksys/stl/utility> // for pair
+diff -Naur VTK/Parallel/vtkPBGLVertexColoring.cxx VTK.new/Parallel/vtkPBGLVertexColoring.cxx
+--- VTK/Parallel/vtkPBGLVertexColoring.cxx 2008-07-31 13:56:53.000000000 -0400
++++ VTK.new/Parallel/vtkPBGLVertexColoring.cxx 2010-01-21 17:53:40.000000000 -0500
+@@ -47,7 +47,7 @@
+
+ #include <boost/graph/distributed/boman_et_al_graph_coloring.hpp>
+ #include <boost/parallel/algorithm.hpp>
+-#include <boost/property_map.hpp>
++#include <boost/property_map/property_map.hpp>
+
+ #include <vtksys/stl/utility> // for pair
+
diff --git a/sci-libs/vtk/vtk-5.4.2-r1.ebuild b/sci-libs/vtk/vtk-5.4.2-r1.ebuild
index 5f4feeba9dc2..479517e67f02 100644
--- a/sci-libs/vtk/vtk-5.4.2-r1.ebuild
+++ b/sci-libs/vtk/vtk-5.4.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.4.2-r1.ebuild,v 1.2 2010/01/16 20:16:29 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.4.2-r1.ebuild,v 1.3 2010/01/21 23:38:26 markusle Exp $
EAPI="2"
inherit eutils flag-o-matic toolchain-funcs versionator java-pkg-opt-2 python qt3 qt4 cmake-utils
@@ -44,7 +44,7 @@ RDEPEND="mpi? ( || (
DEPEND="${RDEPEND}
java? ( >=virtual/jdk-1.5 )
- boost? ( dev-libs/boost )
+ boost? ( >=dev-libs/boost-1.40.0 )
>=dev-util/cmake-2.6"
S="${WORKDIR}"/VTK
@@ -73,6 +73,7 @@ pkg_setup() {
src_prepare() {
epatch "${FILESDIR}"/${P}-cg-path.patch
epatch "${FILESDIR}"/${PN}-5.2.0-tcl-install.patch
+ epatch "${FILESDIR}"/${P}-boost-property_map.patch
sed -e "s:@VTK_TCL_LIBRARY_DIR@:/usr/$(get_libdir):" \
-i Wrapping/Tcl/pkgIndex.tcl.in \
|| die "Failed to fix tcl pkgIndex file"