summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-03-07 22:56:28 +0000
committerJustin Lecher <jlec@gentoo.org>2010-03-07 22:56:28 +0000
commitb63bcb3840494e79e017f2a6912fd75faac74566 (patch)
treee685c30b9e220baf61e1dff16d08d6a4b193240e /sci-libs
parentamd64/arm stable, bug #295357 (diff)
downloadgentoo-2-b63bcb3840494e79e017f2a6912fd75faac74566.tar.gz
gentoo-2-b63bcb3840494e79e017f2a6912fd75faac74566.tar.bz2
gentoo-2-b63bcb3840494e79e017f2a6912fd75faac74566.zip
corrected usage of distutils and EPAI=3
(Portage version: 2.2_rc65/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/gdal/gdal-1.6.3-r1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sci-libs/gdal/gdal-1.6.3-r1.ebuild b/sci-libs/gdal/gdal-1.6.3-r1.ebuild
index 8efe7bfb834f..76bfe4d8ee8f 100644
--- a/sci-libs/gdal/gdal-1.6.3-r1.ebuild
+++ b/sci-libs/gdal/gdal-1.6.3-r1.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.6.3-r1.ebuild,v 1.1 2010/03/07 19:32:30 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.6.3-r1.ebuild,v 1.2 2010/03/07 22:56:28 jlec Exp $
EAPI="3"
WANT_AUTOCONF="2.5"
RUBY_OPTIONAL="yes"
USE_RUBY="ruby18"
+PYTHON_DEPEND="2"
inherit autotools distutils eutils perl-module ruby toolchain-funcs
@@ -67,6 +68,7 @@ pkg_setup() {
elog "User-specified configure options are not set."
elog "If needed, set GDAL_CONFIGURE_OPTS to enable grass support."
fi
+ python_set_active_version 2
}
src_prepare() {
@@ -88,8 +90,6 @@ src_prepare() {
src_configure() {
- distutils_python_version
-
local pkg_conf="${GDAL_CONFIGURE_OPTS}"
local use_conf=""
@@ -120,7 +120,7 @@ src_configure() {
fi
if useq python ; then
- use_conf="--with-pymoddir=${EPREFIX}/usr/$(get_libdir)/python${PYVER}/site-packages \
+ use_conf="--with-pymoddir=${EPREFIX}/$(python_get_sitedir) \
${use_conf}"
fi