summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-03-04 13:22:18 +0000
committerJustin Lecher <jlec@gentoo.org>2012-03-04 13:22:18 +0000
commitbbe69f163a5701799346824bb13489eeca0cb2ff (patch)
tree3dad164b20c004814bd8a68df51d9b17b78fc202 /sci-libs
parentIUPAC-InChi license added (diff)
downloadgentoo-2-bbe69f163a5701799346824bb13489eeca0cb2ff.tar.gz
gentoo-2-bbe69f163a5701799346824bb13489eeca0cb2ff.tar.bz2
gentoo-2-bbe69f163a5701799346824bb13489eeca0cb2ff.zip
Import Version Bump from sci overlay prepared by Reinis Danne
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/inchi/ChangeLog10
-rw-r--r--sci-libs/inchi/inchi-1.04.ebuild61
-rw-r--r--sci-libs/inchi/metadata.xml4
3 files changed, 71 insertions, 4 deletions
diff --git a/sci-libs/inchi/ChangeLog b/sci-libs/inchi/ChangeLog
index 594bf60a4ca7..df78dc444673 100644
--- a/sci-libs/inchi/ChangeLog
+++ b/sci-libs/inchi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/inchi
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/inchi/ChangeLog,v 1.1 2011/03/26 15:18:23 jlec Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/inchi/ChangeLog,v 1.2 2012/03/04 13:22:18 jlec Exp $
+
+*inchi-1.04 (04 Mar 2012)
+
+ 04 Mar 2012; Justin Lecher <jlec@gentoo.org> +inchi-1.04.ebuild,
+ metadata.xml:
+ Import Version Bump from sci overlay prepared by Reinis Danne
*inchi-1.03 (26 Mar 2011)
diff --git a/sci-libs/inchi/inchi-1.04.ebuild b/sci-libs/inchi/inchi-1.04.ebuild
new file mode 100644
index 000000000000..f5b0f1fcc5ca
--- /dev/null
+++ b/sci-libs/inchi/inchi-1.04.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/inchi/inchi-1.04.ebuild,v 1.1 2012/03/04 13:22:18 jlec Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A program and library for generating standard and non-standard InChI and InChIKeys"
+HOMEPAGE="http://www.iupac.org/inchi/"
+SRC_URI="
+ http://www.inchi-trust.org/sites/default/files/inchi-${PV}/INCHI-1-API.ZIP -> ${P}.zip
+ doc? ( http://www.inchi-trust.org/sites/default/files/inchi-${PV}/INCHI-1-DOC.ZIP -> ${P}-doc.zip )"
+
+LICENSE="IUPAC-InChi"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S="${WORKDIR}"/INCHI-1-API
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.03-shared.patch
+}
+
+src_compile() {
+ for dir in INCHI/gcc/inchi-1 INCHI_API/gcc_so_makefile; do
+ pushd ${dir} > /dev/null
+ emake \
+ C_COMPILER=$(tc-getCC) \
+ CPP_COMPILER=$(tc-getCXX) \
+ LINKER="$(tc-getCXX) ${LDFLAGS}" \
+ SHARED_LINK="$(tc-getCC) ${LDFLAGS} -shared" \
+ C_COMPILER_OPTIONS="\${P_INCL} -ansi -DCOMPILE_ANSI_ONLY ${CFLAGS} -c " \
+ CPP_COMPILER_OPTIONS="\${P_INCL} -D_LIB -ansi ${CXXFLAGS} -frtti -c " \
+ C_OPTIONS="${CFLAGS} -fPIC -c " \
+ LINKER_OPTIONS="${LDFLAGS}" \
+ CREATE_MAIN= \
+ ISLINUX=1
+ popd
+ done
+}
+
+src_install() {
+ dodoc readme*.txt
+ if use doc ; then
+ cd "${WORKDIR}/INCHI-1-DOC/"
+ docinto doc
+ dodoc *.pdf readme.txt
+ fi
+ cd "${S}/INCHI/gcc/inchi-1"
+ dobin inchi-1
+ cd "${S}/INCHI_API/gcc_so_makefile/result"
+ rm *gz
+ dolib.so lib*
+ insinto /usr/include
+ doins ../../inchi_main/inchi_api.h
+}
diff --git a/sci-libs/inchi/metadata.xml b/sci-libs/inchi/metadata.xml
index 035d004c2e92..f6b8d04f1abf 100644
--- a/sci-libs/inchi/metadata.xml
+++ b/sci-libs/inchi/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-chemistry</herd>
-<longdescription>
+ <herd>sci-chemistry</herd>
+ <longdescription>
Program v1.03 implementing IUPAC (Standard) InChI/InChIKey version 1.
</longdescription>
</pkgmetadata>