summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-01-29 22:57:00 +0000
committerMichał Górny <mgorny@gentoo.org>2015-01-29 22:57:00 +0000
commitcea9b7cde8dafa8c9d44cfcf02067628c2edd784 (patch)
tree08b10ede4bc499c1a0ab25fa07ca45b170a5e41e /sci-libs
parentFix qt5 build. (diff)
downloadgentoo-2-cea9b7cde8dafa8c9d44cfcf02067628c2edd784.tar.gz
gentoo-2-cea9b7cde8dafa8c9d44cfcf02067628c2edd784.tar.bz2
gentoo-2-cea9b7cde8dafa8c9d44cfcf02067628c2edd784.zip
Convert to CPU_FLAGS_X86.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/fftw/ChangeLog8
-rw-r--r--sci-libs/fftw/fftw-3.3.3-r2.ebuild16
-rw-r--r--sci-libs/fftw/fftw-3.3.4.ebuild16
-rw-r--r--sci-libs/fftw/metadata.xml2
4 files changed, 22 insertions, 20 deletions
diff --git a/sci-libs/fftw/ChangeLog b/sci-libs/fftw/ChangeLog
index 2f9191d0f920..1b255f256630 100644
--- a/sci-libs/fftw/ChangeLog
+++ b/sci-libs/fftw/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/fftw
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/ChangeLog,v 1.161 2014/09/02 15:09:29 dev-zero Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/ChangeLog,v 1.162 2015/01/29 22:57:00 mgorny Exp $
+
+ 29 Jan 2015; Michał Górny <mgorny@gentoo.org> fftw-3.3.3-r2.ebuild,
+ fftw-3.3.4.ebuild, metadata.xml:
+ Convert to CPU_FLAGS_X86.
02 Sep 2014; Tiziano Müller <dev-zero@gentoo.org> fftw-3.3.4.ebuild:
Disable parallel ABI-install (bug #521044).
diff --git a/sci-libs/fftw/fftw-3.3.3-r2.ebuild b/sci-libs/fftw/fftw-3.3.3-r2.ebuild
index 47f57c607d30..0e62cfacff03 100644
--- a/sci-libs/fftw/fftw-3.3.3-r2.ebuild
+++ b/sci-libs/fftw/fftw-3.3.3-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-3.3.3-r2.ebuild,v 1.12 2013/09/26 17:32:45 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-3.3.3-r2.ebuild,v 1.13 2015/01/29 22:57:00 mgorny Exp $
EAPI=5
@@ -16,7 +16,7 @@ SRC_URI="http://www.fftw.org/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="3.0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="altivec avx doc fma fortran mpi neon openmp quad sse sse2 static-libs test threads zbus"
+IUSE="altivec cpu_flags_x86_avx doc cpu_flags_x86_fma3 cpu_flags_x86_fma4 fortran mpi neon openmp quad cpu_flags_x86_sse cpu_flags_x86_sse2 static-libs test threads zbus"
# there is no abi_x86_32 port of virtual/mpi right now
REQUIRED_USE="amd64? ( abi_x86_32? ( !mpi !quad ) )"
@@ -70,7 +70,7 @@ src_configure() {
local x=${MULTIBUILD_VARIANT}
myeconfargs=(
- $(use_enable fma)
+ $(use_enable "cpu_flags_x86_fma$(usex cpu_flags_x86_fma3 3 4)" fma)
$(use_enable fortran)
$(use_enable zbus mips-zbus-timer)
$(use_enable threads)
@@ -81,15 +81,15 @@ src_configure() {
myeconfargs+=(
--enable-single
$(use_enable altivec)
- $(use_enable avx)
- $(use_enable sse)
+ $(use_enable cpu_flags_x86_avx avx)
+ $(use_enable cpu_flags_x86_sse sse)
$(use_enable mpi)
$(use_enable neon)
)
elif [[ $x == double ]]; then
myeconfargs+=(
- $(use_enable avx)
- $(use_enable sse2)
+ $(use_enable cpu_flags_x86_avx avx)
+ $(use_enable cpu_flags_x86_sse2 sse2)
$(use_enable mpi)
)
elif [[ $x == longdouble ]]; then
diff --git a/sci-libs/fftw/fftw-3.3.4.ebuild b/sci-libs/fftw/fftw-3.3.4.ebuild
index a965342a5c90..12ba7a8171b5 100644
--- a/sci-libs/fftw/fftw-3.3.4.ebuild
+++ b/sci-libs/fftw/fftw-3.3.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-3.3.4.ebuild,v 1.5 2014/09/02 15:09:29 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-3.3.4.ebuild,v 1.6 2015/01/29 22:57:00 mgorny Exp $
EAPI=5
@@ -23,7 +23,7 @@ fi
LICENSE="GPL-2"
SLOT="3.0/3"
-IUSE="altivec avx doc fma fortran mpi neon openmp quad sse sse2 static-libs test threads zbus"
+IUSE="altivec cpu_flags_x86_avx doc cpu_flags_x86_fma3 cpu_flags_x86_fma4 fortran mpi neon openmp quad cpu_flags_x86_sse cpu_flags_x86_sse2 static-libs test threads zbus"
RDEPEND="
mpi? ( virtual/mpi )
@@ -88,7 +88,7 @@ src_configure() {
fi
local myeconfargs=(
- $(use_enable fma)
+ $(use_enable "cpu_flags_x86_fma$(usex cpu_flags_x86_fma3 3 4)" fma)
$(use_enable fortran)
$(use_enable zbus mips-zbus-timer)
$(use_enable threads)
@@ -99,15 +99,15 @@ src_configure() {
myeconfargs+=(
--enable-single
$(use_enable altivec)
- $(use_enable avx)
- $(use_enable sse)
+ $(use_enable cpu_flags_x86_avx avx)
+ $(use_enable cpu_flags_x86_sse sse)
${enable_mpi}
$(use_enable neon)
)
elif [[ $x == double ]]; then
myeconfargs+=(
- $(use_enable avx)
- $(use_enable sse2)
+ $(use_enable cpu_flags_x86_avx avx)
+ $(use_enable cpu_flags_x86_sse2 sse2)
${enable_mpi}
)
elif [[ $x == longdouble ]]; then
diff --git a/sci-libs/fftw/metadata.xml b/sci-libs/fftw/metadata.xml
index c7ae6003bbab..5221b542c560 100644
--- a/sci-libs/fftw/metadata.xml
+++ b/sci-libs/fftw/metadata.xml
@@ -12,10 +12,8 @@
publicly available FFT software.
</longdescription>
<use>
- <flag name="avx">Adds support for Advanced Vector Extensions</flag>
<flag name="float">Link default library to single precision instead of
double (symlinks only and fftw-2.1)</flag>
- <flag name="fma">Use the Fused Multiply Add instruction set (fma3/fma4 either one)</flag>
<flag name="quad">Build quadruple precision lib</flag>
<flag name="zbus">Adds support for ZBus cycle-counter of mips</flag>
</use>