summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-09-23 16:15:05 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-09-23 16:15:05 +0000
commitcfa6aec3c9ce9465cf10fead0188a6b70b0b2a29 (patch)
tree03721e040ff877805dab74a6dfd0436e06ec95c9 /sci-libs
parentversion bump (diff)
downloadgentoo-2-cfa6aec3c9ce9465cf10fead0188a6b70b0b2a29.tar.gz
gentoo-2-cfa6aec3c9ce9465cf10fead0188a6b70b0b2a29.tar.bz2
gentoo-2-cfa6aec3c9ce9465cf10fead0188a6b70b0b2a29.zip
version bump
(Portage version: 2.2.12-r1/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/libspatialindex/ChangeLog10
-rw-r--r--sci-libs/libspatialindex/libspatialindex-1.8.3.ebuild37
2 files changed, 45 insertions, 2 deletions
diff --git a/sci-libs/libspatialindex/ChangeLog b/sci-libs/libspatialindex/ChangeLog
index ee47f2543545..511dd14a95ad 100644
--- a/sci-libs/libspatialindex/ChangeLog
+++ b/sci-libs/libspatialindex/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/libspatialindex
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libspatialindex/ChangeLog,v 1.5 2013/06/30 19:18:14 hasufell Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libspatialindex/ChangeLog,v 1.6 2014/09/23 16:15:05 hasufell Exp $
+
+*libspatialindex-1.8.3 (23 Sep 2014)
+
+ 23 Sep 2014; Julian Ospald <hasufell@gentoo.org>
+ +libspatialindex-1.8.3.ebuild:
+ version bump
*libspatialindex-1.8.1 (30 Jun 2013)
diff --git a/sci-libs/libspatialindex/libspatialindex-1.8.3.ebuild b/sci-libs/libspatialindex/libspatialindex-1.8.3.ebuild
new file mode 100644
index 000000000000..14f4ea5edbf1
--- /dev/null
+++ b/sci-libs/libspatialindex/libspatialindex-1.8.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libspatialindex/libspatialindex-1.8.3.ebuild,v 1.1 2014/09/23 16:15:05 hasufell Exp $
+
+EAPI=5
+
+inherit autotools eutils
+
+MY_PN="spatialindex-src"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="General framework for developing spatial indices"
+HOMEPAGE="http://libspatialindex.github.com/"
+SRC_URI="http://download.osgeo.org/libspatialindex/${MY_P}.tar.bz2"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0/3"
+IUSE="debug static-libs"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.8.1-QA.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files
+}