summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-01-06 14:43:59 +0000
committerJustin Lecher <jlec@gentoo.org>2014-01-06 14:43:59 +0000
commitd01b56bb6c41f7935794253cca102bfac423e3d7 (patch)
tree02e4090dcef545a06d3c3135654f7b04a940ff40 /sci-libs
parentsci-libs/clapack: Punt base.eclass (diff)
downloadgentoo-2-d01b56bb6c41f7935794253cca102bfac423e3d7.tar.gz
gentoo-2-d01b56bb6c41f7935794253cca102bfac423e3d7.tar.bz2
gentoo-2-d01b56bb6c41f7935794253cca102bfac423e3d7.zip
sci-libs/indilib: Punt base.eclass; install udev files in correct location
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/indilib/ChangeLog10
-rw-r--r--sci-libs/indilib/indilib-0.9.6-r1.ebuild51
-rw-r--r--sci-libs/indilib/indilib-0.9.6.ebuild8
-rw-r--r--sci-libs/indilib/metadata.xml14
4 files changed, 70 insertions, 13 deletions
diff --git a/sci-libs/indilib/ChangeLog b/sci-libs/indilib/ChangeLog
index 8749a909c2f1..64fbe0029738 100644
--- a/sci-libs/indilib/ChangeLog
+++ b/sci-libs/indilib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/indilib
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/indilib/ChangeLog,v 1.35 2013/04/02 20:57:00 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/indilib/ChangeLog,v 1.36 2014/01/06 14:43:59 jlec Exp $
+
+*indilib-0.9.6-r1 (06 Jan 2014)
+
+ 06 Jan 2014; Justin Lecher <jlec@gentoo.org> indilib-0.9.6.ebuild,
+ +indilib-0.9.6-r1.ebuild, metadata.xml:
+ Punt base.eclass; install udev files in correct location
02 Apr 2013; Agostino Sarubbo <ago@gentoo.org> indilib-0.9.6.ebuild:
Stable for ppc64, wrt bug #462890
diff --git a/sci-libs/indilib/indilib-0.9.6-r1.ebuild b/sci-libs/indilib/indilib-0.9.6-r1.ebuild
new file mode 100644
index 000000000000..341aad00920f
--- /dev/null
+++ b/sci-libs/indilib/indilib-0.9.6-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/indilib/indilib-0.9.6-r1.ebuild,v 1.1 2014/01/06 14:43:59 jlec Exp $
+
+EAPI=5
+
+MY_PN="lib${PN/lib/}"
+
+inherit cmake-utils udev
+
+DESCRIPTION="INDI Astronomical Control Protocol library"
+HOMEPAGE="http://www.indilib.org/"
+SRC_URI="mirror://sourceforge/${PN/lib/}/${MY_PN}_${PV}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="nova v4l"
+
+RDEPEND="
+ >=sci-libs/cfitsio-3.140
+ sys-libs/zlib
+ virtual/libusb:0
+ nova? ( >=sci-libs/libnova-0.12.1 )
+"
+DEPEND="${RDEPEND}
+ v4l? ( >=sys-kernel/linux-headers-2.6 )
+"
+
+DOCS=( AUTHORS ChangeLog README README.drivers TODO )
+
+PATCHES=(
+ "${FILESDIR}/0.9.1-fix_symlinks.patch"
+ "${FILESDIR}/${P}-underlinking.patch"
+)
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ sed -e "s|/etc/udev/rules.d|$(get_udevdir)|" \
+ -i CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with nova)
+ )
+ cmake-utils_src_configure
+}
diff --git a/sci-libs/indilib/indilib-0.9.6.ebuild b/sci-libs/indilib/indilib-0.9.6.ebuild
index fd7e79aa8979..b26b2421a097 100644
--- a/sci-libs/indilib/indilib-0.9.6.ebuild
+++ b/sci-libs/indilib/indilib-0.9.6.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/indilib/indilib-0.9.6.ebuild,v 1.7 2013/04/02 20:57:00 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/indilib/indilib-0.9.6.ebuild,v 1.8 2014/01/06 14:43:59 jlec Exp $
EAPI=5
MY_PN="lib${PN/lib/}"
-inherit base cmake-utils
+inherit cmake-utils
DESCRIPTION="INDI Astronomical Control Protocol library"
HOMEPAGE="http://www.indilib.org/"
@@ -37,7 +37,7 @@ PATCHES=(
S=${WORKDIR}/${MY_PN}-${PV}
src_prepare() {
- base_src_prepare
+ cmake-utils_src_prepare
sed -e "s|/etc/udev/rules.d|/lib/udev/rules.d|" \
-i CMakeLists.txt || die
diff --git a/sci-libs/indilib/metadata.xml b/sci-libs/indilib/metadata.xml
index d3ea48b91e99..890d46e0301a 100644
--- a/sci-libs/indilib/metadata.xml
+++ b/sci-libs/indilib/metadata.xml
@@ -1,11 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>kde</herd>
- <use>
- <flag name="nova">Enable support for nova celestial mechanics calculations</flag>
- </use>
- <upstream>
- <remote-id type="sourceforge">indi</remote-id>
- </upstream>
+ <herd>kde</herd>
+ <use>
+ <flag name="nova">Enable support for nova celestial mechanics calculations</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">indi</remote-id>
+ </upstream>
</pkgmetadata>