summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-03-04 17:19:40 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-03-04 17:19:40 +0000
commitd7b6c1ad1fab4c2b9b47ecc42bece1fc7b687c8e (patch)
tree2cd814ffd88e57cf1865db0888ccb37dc6878784 /sci-libs
parentVersion bump wrt bug #457742. (diff)
downloadgentoo-2-d7b6c1ad1fab4c2b9b47ecc42bece1fc7b687c8e.tar.gz
gentoo-2-d7b6c1ad1fab4c2b9b47ecc42bece1fc7b687c8e.tar.bz2
gentoo-2-d7b6c1ad1fab4c2b9b47ecc42bece1fc7b687c8e.zip
Remove pure C++ tests when testing C library, bug #460284
(Portage version: 2.2.01.21688-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/nlopt/ChangeLog5
-rw-r--r--sci-libs/nlopt/nlopt-2.3-r2.ebuild15
2 files changed, 15 insertions, 5 deletions
diff --git a/sci-libs/nlopt/ChangeLog b/sci-libs/nlopt/ChangeLog
index 7b0dfd2b5650..c7743941bedc 100644
--- a/sci-libs/nlopt/ChangeLog
+++ b/sci-libs/nlopt/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-libs/nlopt
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/ChangeLog,v 1.20 2013/03/03 05:21:04 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/ChangeLog,v 1.21 2013/03/04 17:19:40 bicatali Exp $
+
+ 04 Mar 2013; Sébastien Fabbro <bicatali@gentoo.org> nlopt-2.3-r2.ebuild:
+ Remove pure C++ tests when testing C library, bug #460284
*nlopt-2.3-r2 (03 Mar 2013)
diff --git a/sci-libs/nlopt/nlopt-2.3-r2.ebuild b/sci-libs/nlopt/nlopt-2.3-r2.ebuild
index a2025cc13998..b7017e205366 100644
--- a/sci-libs/nlopt/nlopt-2.3-r2.ebuild
+++ b/sci-libs/nlopt/nlopt-2.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/nlopt-2.3-r2.ebuild,v 1.1 2013/03/03 05:21:04 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/nlopt-2.3-r2.ebuild,v 1.2 2013/03/04 17:19:40 bicatali Exp $
EAPI=5
@@ -45,8 +45,9 @@ src_prepare() {
src_configure() {
if use octave; then
- export OCT_INSTALL_DIR="${EPREFIX}"/usr/libexec/octave/site/oct/${CHOST}
- export M_INSTALL_DIR="${EPREFIX}"/usr/share/octave/site/m
+ export OCT_INSTALL_DIR="$(octave-config -p LOCALOCTFILEDIR)"
+ export M_INSTALL_DIR="$(octave-config -p LOCALFCNFILEDIR)"
+
else
export MKOCTFILE=None
fi
@@ -82,8 +83,14 @@ src_compile() {
}
src_test() {
- cd "${AUTOTOOLS_BUILD_DIR}"/test
local a f
+ cd "${BUILD_DIR}"/test
+ for a in {1..7}; do
+ for f in {5..9}; do
+ ./testopt -a $a -o $f || die "algorithm $a function $f failed"
+ done
+ done
+ cd "${BUILD_DIR}_cxx"/test
for a in {1..9}; do
for f in {5..9}; do
./testopt -a $a -o $f || die "algorithm $a function $f failed"