summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-01-07 23:44:35 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-01-07 23:44:35 +0000
commite98f27873dba7aeba9ac37878e6004c464159093 (patch)
treeb1c66eca9540fcfb3d590cdf2ecc3eb8bfb13cdd /sci-mathematics/euler
parentWe no longer need to depend on gnome-vfs. (diff)
downloadgentoo-2-e98f27873dba7aeba9ac37878e6004c464159093.tar.gz
gentoo-2-e98f27873dba7aeba9ac37878e6004c464159093.tar.bz2
gentoo-2-e98f27873dba7aeba9ac37878e6004c464159093.zip
Changed default browser from netscape to xdg-open, now installs docs in standard Gentoo directories. Also added pkgconfig in DEPEND, closing bug #204782.
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'sci-mathematics/euler')
-rw-r--r--sci-mathematics/euler/ChangeLog10
-rw-r--r--sci-mathematics/euler/euler-1.61.0.ebuild27
-rw-r--r--sci-mathematics/euler/files/euler-xdg.patch23
3 files changed, 50 insertions, 10 deletions
diff --git a/sci-mathematics/euler/ChangeLog b/sci-mathematics/euler/ChangeLog
index db78f9509bb2..25783f513f70 100644
--- a/sci-mathematics/euler/ChangeLog
+++ b/sci-mathematics/euler/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/euler
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/euler/ChangeLog,v 1.15 2007/07/25 17:40:26 drac Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/euler/ChangeLog,v 1.16 2008/01/07 23:44:34 bicatali Exp $
+
+ 07 Jan 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/euler-xdg.patch, euler-1.61.0.ebuild:
+ Changed default browser from netscape to xdg-open, now installs docs in
+ standard Gentoo directories. Also added pkgconfig in DEPEND, closing bug
+ #204782.
25 Jul 2007; Samuli Suominen <drac@gentoo.org> -euler-1.60.6-r1.ebuild:
Prune unused version, GTK+-1.2 deprecation.
diff --git a/sci-mathematics/euler/euler-1.61.0.ebuild b/sci-mathematics/euler/euler-1.61.0.ebuild
index ecd35ad06f8a..047c2c8ac02b 100644
--- a/sci-mathematics/euler/euler-1.61.0.ebuild
+++ b/sci-mathematics/euler/euler-1.61.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/euler/euler-1.61.0.ebuild,v 1.6 2007/07/13 05:28:09 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/euler/euler-1.61.0.ebuild,v 1.7 2008/01/07 23:44:34 bicatali Exp $
inherit autotools eutils
@@ -11,7 +11,12 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc -sparc x86"
IUSE=""
-DEPEND=">=x11-libs/gtk+-2"
+
+DEPEND=">=x11-libs/gtk+-2
+ dev-util/pkgconfig"
+
+RDEPEND=">=x11-libs/gtk+-2
+ x11-misc/xdg-utils"
src_unpack() {
unpack ${A}
@@ -19,13 +24,19 @@ src_unpack() {
epatch "${FILESDIR}"/configure-gentoo.patch
epatch "${FILESDIR}"/command-gcc4-gentoo.patch
- epatch "${FILESDIR}"/euler-glibc-2.4-gentoo.patch
+ epatch "${FILESDIR}"/${PN}-glibc-2.4-gentoo.patch
+ epatch "${FILESDIR}"/${PN}-xdg.patch
+ # gentoo specific stuff
+ sed -i -e '/COPYING/d' -e '/INSTALL/d' Makefile.am
+ sed -i \
+ -e "s:doc/euler:doc/${PF}:g" \
+ Makefile.am docs/Makefile.am \
+ docs/*/Makefile.am docs/*/images/Makefile.am \
+ src/main.c \
+ || die "sed for docs failed"
eautoreconf
-
- sed -e 's:g77:g77 gfortran:g' -i ./configure || \
- die "Failed to patch configure"
}
src_install() {
- make DESTDIR="${D}" install || die "install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
}
diff --git a/sci-mathematics/euler/files/euler-xdg.patch b/sci-mathematics/euler/files/euler-xdg.patch
new file mode 100644
index 000000000000..cb1bf54a2bbb
--- /dev/null
+++ b/sci-mathematics/euler/files/euler-xdg.patch
@@ -0,0 +1,23 @@
+--- docs/doc.html.orig 2008-01-07 23:11:25.490634852 +0000
++++ docs/doc.html 2008-01-07 23:13:57.652980222 +0000
+@@ -184,7 +184,8 @@
+ <div align=center><img src="images/pref3.gif"></div>
+
+ <p align="justify">Finally, You can set a flag to let Euler save preferences at exit (the default).
+-You may choose another browser than the one suggested (netscape by default). And
++You may choose another browser than the one suggested (your default
++ desktop browser is selected with xdg-open by default). And
+ You can also reset the preferences to the default values.</p>
+ <div align=center><img src="images/pref4.gif"></div>
+
+--- src/rc.h.orig 2008-01-07 23:15:36.617118688 +0000
++++ src/rc.h 2008-01-07 23:15:54.097371330 +0000
+@@ -26,7 +26,7 @@
+ #define E_GSTACK_DEFAULT 4*1024l
+ #define E_GLINES_DEFAULT 40
+
+-#define E_BROWSER_DEFAULT "netscape"
++#define E_BROWSER_DEFAULT "xdg-open"
+
+ #define MAX_COLORS 16
+