summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2007-09-25 13:39:20 +0000
committerMarkus Dittrich <markusle@gentoo.org>2007-09-25 13:39:20 +0000
commit58719aa38640fe39f99c2cbcf1d41f6f5ac2c83e (patch)
tree2a496dd0f7b2c15989f756320be987b0f884008f /sci-mathematics/geomview
parentRemove dev version; prep for unmask (diff)
downloadgentoo-2-58719aa38640fe39f99c2cbcf1d41f6f5ac2c83e.tar.gz
gentoo-2-58719aa38640fe39f99c2cbcf1d41f6f5ac2c83e.tar.bz2
gentoo-2-58719aa38640fe39f99c2cbcf1d41f6f5ac2c83e.zip
Version bump (see bug #193722).
(Portage version: 2.1.3.9)
Diffstat (limited to 'sci-mathematics/geomview')
-rw-r--r--sci-mathematics/geomview/ChangeLog7
-rw-r--r--sci-mathematics/geomview/files/digest-geomview-1.9.43
-rw-r--r--sci-mathematics/geomview/geomview-1.9.4.ebuild92
3 files changed, 101 insertions, 1 deletions
diff --git a/sci-mathematics/geomview/ChangeLog b/sci-mathematics/geomview/ChangeLog
index ad21aa92306c..ed034dcbda04 100644
--- a/sci-mathematics/geomview/ChangeLog
+++ b/sci-mathematics/geomview/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/geomview
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/geomview/ChangeLog,v 1.7 2007/07/09 01:33:37 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/geomview/ChangeLog,v 1.8 2007/09/25 13:39:19 markusle Exp $
+
+*geomview-1.9.4 (25 Sep 2007)
+
+ 25 Sep 2007; Markus Dittrich <markusle@gentoo.org> +geomview-1.9.4.ebuild:
+ Version bump (see bug #193722).
09 Jul 2007; Steve Arnold <nerdboy@gentoo.org> geomview-1.9.2.ebuild:
removed extra postinst
diff --git a/sci-mathematics/geomview/files/digest-geomview-1.9.4 b/sci-mathematics/geomview/files/digest-geomview-1.9.4
new file mode 100644
index 000000000000..b46bcf860870
--- /dev/null
+++ b/sci-mathematics/geomview/files/digest-geomview-1.9.4
@@ -0,0 +1,3 @@
+MD5 4da5a241a068b362c819ecca419d1f3d geomview-1.9.4.tar.bz2 4037982
+RMD160 6d53d7e6bce17e3298dc6f55e1e1770918b868a5 geomview-1.9.4.tar.bz2 4037982
+SHA256 a384790429541b8c86c41c4b27d157d5a92ee7c46e6a78741e55d81bd9a46c5b geomview-1.9.4.tar.bz2 4037982
diff --git a/sci-mathematics/geomview/geomview-1.9.4.ebuild b/sci-mathematics/geomview/geomview-1.9.4.ebuild
new file mode 100644
index 000000000000..2b650dfccbdb
--- /dev/null
+++ b/sci-mathematics/geomview/geomview-1.9.4.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/geomview/geomview-1.9.4.ebuild,v 1.1 2007/09/25 13:39:19 markusle Exp $
+
+inherit eutils flag-o-matic fdo-mime
+
+DESCRIPTION="Interactive Geometry Viewer"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://geomview.sourceforge.net"
+
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="avg bzip2 debug emacs netpbm pdf zlib"
+
+DEPEND="zlib? ( sys-libs/zlib )
+ virtual/motif
+ virtual/opengl"
+
+RDEPEND="${DEPEND}
+ netpbm? ( >=media-libs/netpbm-10.37.0 )
+ bzip2? ( app-arch/bzip2 )
+ app-arch/gzip
+ pdf? ( || ( app-text/xpdf
+ kde-base/kpdf
+ kde-base/kghostview
+ app-text/gv
+ app-text/gsview
+ app-text/epdfview
+ app-text/acroread )
+ )
+ virtual/w3m"
+
+S="${WORKDIR}/${P/_/-}"
+
+src_compile() {
+ # GNU standard is /usr/share/doc/${PN}, so override this; also note
+ # that motion averaging is still experimental.
+ if use pdf; then
+ local myconf="--docdir=/usr/share/doc/${PF}"
+ else
+ local myconf="--docdir=/usr/share/doc/${PF} --without-pdfviewer"
+ fi
+
+ econf ${myconf} $(use_enable debug d1debug) $(use_with zlib) \
+ $(use_enable avg motion-averaging) \
+ || die "could not configure"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ doicon "${FILESDIR}"/geomview.png
+ make_desktop_entry geomview "GeomView ${PV}" \
+ "/usr/share/pixmaps/geomview.png" \
+ "Science;Math;Education"
+
+ dodoc AUTHORS ChangeLog NEWS INSTALL.Geomview
+
+ if ! use pdf; then
+ rm "${D}"/usr/share/doc/${PF}/${PN}.pdf
+ fi
+
+ if use emacs; then
+ insinto /usr/share/geomview
+ doins "${FILESDIR}"/gvcl-mode.el || die
+ fi
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+
+ elog "GeomView expects you to have both Firefox and Xpdf installed for"
+ elog "viewing the documentation (this can be changed at runtime)."
+ elog ""
+ elog "The w3m virtual should handle the HTML browser part, and if"
+ elog "you wish to use an alternate PDF viewer, feel free to remove"
+ elog "xpdf and use the viewer of your choice (see the docs for how"
+ elog "to setup the \'(ui-pdf-viewer VIEWER)\' GCL-command)."
+ elog ""
+ elog "If you use emacs, enable the corresponding use flag and check"
+ elog "out the provided mode file for editing the GeomView command"
+ elog "language (courtesy of Claus-Justus Heine). Incorporating it"
+ elog "into your emacs configuration is left as an exercise..."
+ elog ""
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}