summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-07-26 20:23:42 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-07-26 20:23:42 +0000
commit66046ae824f6d716fcd082044ea40f52773d64cf (patch)
tree68121605f91ec20b748b77e31e4addf9b279bd41 /sci-mathematics/lpsolve
parenthtml files are missing, dont install them (diff)
downloadgentoo-2-66046ae824f6d716fcd082044ea40f52773d64cf.tar.gz
gentoo-2-66046ae824f6d716fcd082044ea40f52773d64cf.tar.bz2
gentoo-2-66046ae824f6d716fcd082044ea40f52773d64cf.zip
Fix duplication of the README per bug #376513. Add switch for static libs. Punt .la file for shared lib.
(Portage version: 2.2.0_alpha47/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/lpsolve')
-rw-r--r--sci-mathematics/lpsolve/ChangeLog6
-rw-r--r--sci-mathematics/lpsolve/lpsolve-5.5.2.0.ebuild16
2 files changed, 19 insertions, 3 deletions
diff --git a/sci-mathematics/lpsolve/ChangeLog b/sci-mathematics/lpsolve/ChangeLog
index 81685491d049..4b6149e42d23 100644
--- a/sci-mathematics/lpsolve/ChangeLog
+++ b/sci-mathematics/lpsolve/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/lpsolve
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/lpsolve/ChangeLog,v 1.1 2011/07/24 11:43:57 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/lpsolve/ChangeLog,v 1.2 2011/07/26 20:23:42 scarabeus Exp $
+
+ 26 Jul 2011; Tomáš Chvátal <scarabeus@gentoo.org> lpsolve-5.5.2.0.ebuild:
+ Fix duplication of the README per bug #376513. Add switch for static libs.
+ Punt .la file for shared lib.
*lpsolve-5.5.2.0 (24 Jul 2011)
diff --git a/sci-mathematics/lpsolve/lpsolve-5.5.2.0.ebuild b/sci-mathematics/lpsolve/lpsolve-5.5.2.0.ebuild
index 3f488f9905f6..c618839add0a 100644
--- a/sci-mathematics/lpsolve/lpsolve-5.5.2.0.ebuild
+++ b/sci-mathematics/lpsolve/lpsolve-5.5.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/lpsolve/lpsolve-5.5.2.0.ebuild,v 1.1 2011/07/24 11:43:57 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/lpsolve/lpsolve-5.5.2.0.ebuild,v 1.2 2011/07/26 20:23:42 scarabeus Exp $
EAPI=4
@@ -11,7 +11,19 @@ SRC_URI="http://dev.gentooexperimental.org/~scarabeus/${P}.tar.xz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
+IUSE="static-libs"
DEPEND="sci-libs/colamd"
RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+}
+
+src_install() {
+ default
+ # required because it does not provide .pc file
+ use static-libs || find "${ED}" -name '*.la' -exec rm -f {} +
+}