summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-07-26 00:16:47 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-07-26 00:16:47 +0000
commit303bf2b2414fb78a803604b0373da969748f1c90 (patch)
treef5868e8b008fb04c455eb1c29b863f6c3ef86bd2 /sci-mathematics/mathomatic
parentFix Musepack deps for SV8. (diff)
downloadgentoo-2-303bf2b2414fb78a803604b0373da969748f1c90.tar.gz
gentoo-2-303bf2b2414fb78a803604b0373da969748f1c90.tar.bz2
gentoo-2-303bf2b2414fb78a803604b0373da969748f1c90.zip
Version bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/mathomatic')
-rw-r--r--sci-mathematics/mathomatic/ChangeLog8
-rw-r--r--sci-mathematics/mathomatic/mathomatic-14.5.2.ebuild (renamed from sci-mathematics/mathomatic/mathomatic-14.3.3.ebuild)13
2 files changed, 18 insertions, 3 deletions
diff --git a/sci-mathematics/mathomatic/ChangeLog b/sci-mathematics/mathomatic/ChangeLog
index cdfca8d8535e..9d2ae55cc0bd 100644
--- a/sci-mathematics/mathomatic/ChangeLog
+++ b/sci-mathematics/mathomatic/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/mathomatic
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/ChangeLog,v 1.42 2009/06/24 04:34:02 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/ChangeLog,v 1.43 2009/07/26 00:16:47 bicatali Exp $
+
+*mathomatic-14.5.2 (26 Jul 2009)
+
+ 26 Jul 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ -mathomatic-14.3.3.ebuild, +mathomatic-14.5.2.ebuild:
+ Version bump
24 Jun 2009; Sébastien Fabbro <bicatali@gentoo.org>
mathomatic-14.4.5.ebuild:
diff --git a/sci-mathematics/mathomatic/mathomatic-14.3.3.ebuild b/sci-mathematics/mathomatic/mathomatic-14.5.2.ebuild
index 6ce4ec8c9fe4..4aea004e12ac 100644
--- a/sci-mathematics/mathomatic/mathomatic-14.3.3.ebuild
+++ b/sci-mathematics/mathomatic/mathomatic-14.5.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/mathomatic-14.3.3.ebuild,v 1.1 2009/02/26 18:12:19 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/mathomatic-14.5.2.ebuild,v 1.1 2009/07/26 00:16:47 bicatali Exp $
inherit eutils
@@ -11,17 +11,23 @@ SRC_URI="http://www.panix.com/~gesslein/${P}.tar.bz2"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="doc"
+IUSE="doc secure"
DEPEND="sys-libs/readline
sys-libs/ncurses"
+RDEPEND="${DEPEND}"
src_compile() {
+ # respect the user's CFLAGS
sed -i \
-e '/^CFLAGS/ s/-O.//' \
makefile primes/makefile || die "sed failed"
+ sed -i -e "s/-s.*-O/${CFLAGS}/" compile.secure || die
emake READLINE=1 || die "emake failed"
emake -C primes || die "emake in primes failed"
+ if use secure; then
+ ./compile.secure || die "compiling secure version failed"
+ fi
}
src_test() {
@@ -42,4 +48,7 @@ src_install() {
insinto /usr/share/doc/${PF}
doins -r tests factorial m4 || die
fi
+ if use secure; then
+ dobin mathomatic_secure || die
+ fi
}