summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2007-04-16 08:51:11 +0000
committerChristian Faulhammer <opfer@gentoo.org>2007-04-16 08:51:11 +0000
commit603a3854cc63ae8a4b3f2c9b08fabf1e0b16b500 (patch)
treeab7f6a99cba40b7bf276fa565f61b07f623cd04b /sci-mathematics/maxima
parentstable amd64, bug 173040 (diff)
downloadgentoo-2-603a3854cc63ae8a4b3f2c9b08fabf1e0b16b500.tar.gz
gentoo-2-603a3854cc63ae8a4b3f2c9b08fabf1e0b16b500.tar.bz2
gentoo-2-603a3854cc63ae8a4b3f2c9b08fabf1e0b16b500.zip
moved from USE flag tcltk to tk, see bug 17808; added check for TEXMFSITE and install there to avoid possible collisions, see bug 169178, reported by Sebastian Schubert <sebastian-schubert@gmx.de>
(Portage version: 2.1.2.2)
Diffstat (limited to 'sci-mathematics/maxima')
-rw-r--r--sci-mathematics/maxima/ChangeLog10
-rw-r--r--sci-mathematics/maxima/files/digest-maxima-5.11.0-r13
-rw-r--r--sci-mathematics/maxima/maxima-5.11.0-r1.ebuild173
-rw-r--r--sci-mathematics/maxima/maxima-5.9.3.ebuild12
4 files changed, 191 insertions, 7 deletions
diff --git a/sci-mathematics/maxima/ChangeLog b/sci-mathematics/maxima/ChangeLog
index d070a49d0641..8b9c02cfd820 100644
--- a/sci-mathematics/maxima/ChangeLog
+++ b/sci-mathematics/maxima/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-mathematics/maxima
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/maxima/ChangeLog,v 1.25 2007/03/08 07:12:41 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/maxima/ChangeLog,v 1.26 2007/04/16 08:51:11 opfer Exp $
+
+*maxima-5.11.0-r1 (16 Apr 2007)
+
+ 16 Apr 2007; Christian Faulhammer <opfer@gentoo.org> maxima-5.9.3.ebuild,
+ +maxima-5.11.0-r1.ebuild:
+ moved from USE flag tcltk to tk, see bug 17808; added check for TEXMFSITE
+ and install there to avoid possible collisions, see bug 169178, reported by
+ Sebastian Schubert <sebastian-schubert@gmx.de>
08 Mar 2007; Christian Faulhammer <opfer@gentoo.org>
files/50maxima-gentoo.el:
diff --git a/sci-mathematics/maxima/files/digest-maxima-5.11.0-r1 b/sci-mathematics/maxima/files/digest-maxima-5.11.0-r1
new file mode 100644
index 000000000000..706606789654
--- /dev/null
+++ b/sci-mathematics/maxima/files/digest-maxima-5.11.0-r1
@@ -0,0 +1,3 @@
+MD5 d9ae353e8eba9b9d5686e119e59ab88c maxima-5.11.0.tar.gz 13924132
+RMD160 8f7fb1b8bc7438ffdc393a0eb0f86b5efa79ef3e maxima-5.11.0.tar.gz 13924132
+SHA256 7a7259123bd81a7de3609c7e59b561d49e2710a8f7117c42f373afdd6a6786ac maxima-5.11.0.tar.gz 13924132
diff --git a/sci-mathematics/maxima/maxima-5.11.0-r1.ebuild b/sci-mathematics/maxima/maxima-5.11.0-r1.ebuild
new file mode 100644
index 000000000000..c782667cf0e1
--- /dev/null
+++ b/sci-mathematics/maxima/maxima-5.11.0-r1.ebuild
@@ -0,0 +1,173 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/maxima/maxima-5.11.0-r1.ebuild,v 1.1 2007/04/16 08:51:11 opfer Exp $
+
+inherit eutils elisp-common autotools
+
+DESCRIPTION="Free computer algebra environment based on Macsyma"
+HOMEPAGE="http://maxima.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 AECA"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="cmucl clisp sbcl gcl tetex emacs auctex tk nls unicode"
+
+# rlwrap is recommended for cmucl and sbcl
+RDEPEND=">=sci-visualization/gnuplot-4.0
+ app-text/gv
+ tetex? ( virtual/tetex )
+ emacs? ( virtual/emacs )
+ auctex? ( app-emacs/auctex )
+ clisp? ( >=dev-lisp/clisp-2.33.2-r1 )
+ gcl? ( >=dev-lisp/gcl-2.6.7 )
+ sbcl? ( >=dev-lisp/sbcl-0.9.4 app-misc/rlwrap )
+ cmucl? ( >=dev-lisp/cmucl-19a app-misc/rlwrap )
+ !clisp? ( !sbcl? ( !cmucl? ( >=dev-lisp/gcl-2.6.7 ) ) )
+ tk? ( >=dev-lang/tk-8.3.3 )"
+
+DEPEND="${RDEPEND} >=sys-apps/texinfo-4.3"
+
+for lang in es pt; do
+ IUSE="${IUSE} linguas_${lang}"
+done
+
+pkg_setup() {
+# Don't install in the main tree, as this may cause file collisions
+ if use tetex; then
+ local TEXMFPATH="$(kpsewhich -var-value=TEXMFSITE)"
+ local TEXMFCONFIGFILE="$(kpsewhich texmf.cnf)"
+
+ if [ -z "${TEXMFPATH}" ]; then
+ eerror "You haven't defined the TEXMFSITE variable in your TeX config."
+ eerror "Please do so in the file ${TEXMFCONFIGFILE:-/var/lib/texmf/web2c/texmf.cnf}"
+ die "Define TEXMFSITE in TeX configuration!"
+ else
+ # go through the colon separated list of directories (maybe only one) provided in the variable
+ # TEXMFPATH (generated from TEXMFSITE from TeX's config) and choose only the first entry.
+ # All entries are separated by colons, even when defined with semi-colons, kpsewhich changes
+ # the output to a generic format, so IFS has to be redefined.
+ local IFS="${IFS}:"
+
+ for strippedpath in ${TEXMFPATH}
+ do
+ if [ -d ${strippedpath} ]; then
+ MAXIMA_TEXMFDIR="${strippedpath}"
+ break
+ fi
+ done
+
+ # verify if an existing path was chosen to prevent from installing into the wrong directory
+ if [ -z ${MAXIMA_TEXMFDIR} ]; then
+ eerror "TEXMFSITE does not contain any existing directory."
+ eerror "Please define an existing directory in your TeX config file"
+ eerror "${TEXMFCONFIGFILE:-/var/lib/texmf/web2c/texmf.cnf} or create at least one of the there specified directories"
+ die "TEXMFSITE variable did not contain an existing directory"
+ fi
+ fi
+ fi
+}
+
+# chosen apps are hardcoded in maxima source:
+# - ghostview for postscript (changed to gv)
+# - acroread for pdf
+# - xdvi for dvi. this could change, with pain.
+
+src_unpack() {
+ unpack ${A}
+ # replace obsolete netscape with firefox, add opera as choices
+ epatch "${FILESDIR}"/${P}-default-browser.patch
+ # replace ugly ghostview with gv
+ epatch "${FILESDIR}"/${P}-default-psviewer.patch
+ # no debug during compile
+ epatch "${FILESDIR}"/${P}-sbcl-disable-debugger.patch
+ # diff_form autoloading
+ epatch "${FILESDIR}/${P}-diff_form.patch"
+}
+
+src_compile() {
+ # automake version mismatch otherwise (sbcl only)
+ use sbcl && eautoreconf
+
+ # remove rmaxima if neither cmucl nor sbcl
+ if ! use sbcl && ! use cmucl ; then
+ sed -i -e '/^@WIN32_FALSE@bin_SCRIPTS/s/rmaxima//' src/Makefile.in
+ fi
+
+ # remove xmaxima if no tk
+ local myconf=""
+ if use tk; then
+ myconf="${myconf} --with-wish=wish"
+ else
+ myconf="${myconf} --with-wish=none"
+ sed -i -e '/^SUBDIRS/s/xmaxima//' interfaces/Makefile.in
+ fi
+
+ # enable gcl if no other lisp selected
+ if use gcl || (! use cmucl && ! use clisp && ! use sbcl ); then
+ if ! built_with_use dev-lisp/gcl ansi; then
+ eerror "GCL must be installed with ANSI."
+ eerror "Try USE=\"ansi\" emerge gcl"
+ die "This package needs gcl with USE=ansi"
+ fi
+ myconf="${myconf} --enable-gcl"
+ fi
+
+ # enable existing translated doc
+ if use nls; then
+ for lang in es pt; do
+ if use linguas_${lang}; then
+ myconf="${myconf} --enable-lang-${lang}"
+ use unicode && myconf="${myconf} --enable-lang-${lang}-utf8"
+ fi
+ done
+ fi
+
+ econf \
+ $(use_enable cmucl) \
+ $(use_enable clisp) \
+ $(use_enable sbcl) \
+ ${myconf} \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ use tk && make_desktop_entry xmaxima xmaxima \
+ /usr/share/${PN}/${PV}/xmaxima/maxima-new.png
+
+ if use emacs; then
+ sed -e "s/PV/${PV}/" "${FILESDIR}"/50maxima-gentoo.el > 50maxima-gentoo.el
+ elisp-site-file-install 50maxima-gentoo.el
+ fi
+
+ if use tetex; then
+ insinto "${MAXIMA_TEXMFDIR}/tex/latex/emaxima"
+ doins interfaces/emacs/emaxima/emaxima.sty
+ fi
+
+ insinto /usr/share/${PN}/${PV}/doc
+ doins AUTHORS ChangeLog COPYING NEWS README*
+ dodir /usr/share/doc
+ dosym /usr/share/${PN}/${PV}/doc /usr/share/doc/${PF}
+}
+
+pkg_preinst() {
+ # some lisp do not gunzip info files on the fly
+ if use cmucl || use clisp || use sbcl; then
+ for infofile in $(ls ${D}/usr/share/info/*.gz); do
+ gunzip ${infofile}
+ done
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ use tetex && mktexlsr
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/sci-mathematics/maxima/maxima-5.9.3.ebuild b/sci-mathematics/maxima/maxima-5.9.3.ebuild
index ddfc21c6039e..60227fab1d95 100644
--- a/sci-mathematics/maxima/maxima-5.9.3.ebuild
+++ b/sci-mathematics/maxima/maxima-5.9.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/maxima/maxima-5.9.3.ebuild,v 1.2 2006/07/12 15:34:43 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/maxima/maxima-5.9.3.ebuild,v 1.3 2007/04/16 08:51:11 opfer Exp $
inherit eutils elisp-common autotools
@@ -11,7 +11,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2 AECA"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="cmucl clisp sbcl gcl tetex emacs auctex tcltk nls unicode"
+IUSE="cmucl clisp sbcl gcl tetex emacs auctex tk nls unicode"
DEPEND=">=sys-apps/texinfo-4.3
tetex? ( virtual/tetex )
@@ -28,7 +28,7 @@ RDEPEND=">=sci-visualization/gnuplot-4.0
app-text/gv
sbcl? ( app-misc/rlwrap )
cmucl? ( app-misc/rlwrap )
- tcltk? ( >=dev-lang/tk-8.3.3 )"
+ tk? ( >=dev-lang/tk-8.3.3 )"
# chosen apps are hardcoded in maxima source:
# - ghostview for postscript (changed to gv)
@@ -58,7 +58,7 @@ src_compile() {
# remove xmaxima if no tk
local myconf=""
- if use tcltk; then
+ if use tk; then
myconf="${myconf} --with-wish=wish"
else
myconf="${myconf} --with-wish=none"
@@ -97,7 +97,7 @@ src_compile() {
src_install() {
make DESTDIR="${D}" install || die "make install failed"
- use tcltk && make_desktop_entry xmaxima xmaxima \
+ use tk && make_desktop_entry xmaxima xmaxima \
/usr/share/${PN}/${PV}/xmaxima/maxima-new.png
if use emacs; then