summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-06-19 11:56:26 +0000
committerJustin Lecher <jlec@gentoo.org>2012-06-19 11:56:26 +0000
commit8a56b527608d6b4900261f0a230a013b3e32c65c (patch)
tree438730e29bb488c744ac9c7b44cb3a0b62022ba8 /sci-mathematics/num-utils
parentsci-biology/bowtie: Version Bump, Fix compilation with gcc-4.7, #421919 (diff)
downloadgentoo-2-8a56b527608d6b4900261f0a230a013b3e32c65c.tar.gz
gentoo-2-8a56b527608d6b4900261f0a230a013b3e32c65c.tar.bz2
gentoo-2-8a56b527608d6b4900261f0a230a013b3e32c65c.zip
sci-mathematics/num-utils: Bump EAPI=4, fix recursive-relative path in patches, #421787
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/num-utils')
-rw-r--r--sci-mathematics/num-utils/ChangeLog8
-rw-r--r--sci-mathematics/num-utils/metadata.xml2
-rw-r--r--sci-mathematics/num-utils/num-utils-0.5-r1.ebuild27
3 files changed, 22 insertions, 15 deletions
diff --git a/sci-mathematics/num-utils/ChangeLog b/sci-mathematics/num-utils/ChangeLog
index 43041552de85..c8dfcd5ea437 100644
--- a/sci-mathematics/num-utils/ChangeLog
+++ b/sci-mathematics/num-utils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/num-utils
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/num-utils/ChangeLog,v 1.9 2011/01/03 18:11:18 bicatali Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/num-utils/ChangeLog,v 1.10 2012/06/19 11:56:26 jlec Exp $
+
+ 19 Jun 2012; Justin Lecher <jlec@gentoo.org> num-utils-0.5-r1.ebuild,
+ metadata.xml:
+ Bump EAPI=4, fix recursive-relative path in patches, #421787
*num-utils-0.5-r1 (03 Jan 2011)
diff --git a/sci-mathematics/num-utils/metadata.xml b/sci-mathematics/num-utils/metadata.xml
index 5a2f1c7b832e..2b0bd5314823 100644
--- a/sci-mathematics/num-utils/metadata.xml
+++ b/sci-mathematics/num-utils/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-mathematics</herd>
+ <herd>sci-mathematics</herd>
</pkgmetadata>
diff --git a/sci-mathematics/num-utils/num-utils-0.5-r1.ebuild b/sci-mathematics/num-utils/num-utils-0.5-r1.ebuild
index 05745aaa05f4..9ca843030209 100644
--- a/sci-mathematics/num-utils/num-utils-0.5-r1.ebuild
+++ b/sci-mathematics/num-utils/num-utils-0.5-r1.ebuild
@@ -1,43 +1,46 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/num-utils/num-utils-0.5-r1.ebuild,v 1.1 2011/01/03 18:11:18 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/num-utils/num-utils-0.5-r1.ebuild,v 1.2 2012/06/19 11:56:26 jlec Exp $
+
+EAPI=4
-EAPI="3"
inherit eutils
DEB_PR=11
DESCRIPTION="A set of programs for dealing with numbers from the command line"
-SRC_URI="http://suso.suso.org/programs/num-utils/downloads/${P}.tar.gz
- mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}-${DEB_PR}.diff.gz"
-
HOMEPAGE="http://suso.suso.org/programs/num-utils/"
+SRC_URI="
+ http://suso.suso.org/programs/num-utils/downloads/${P}.tar.gz
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}-${DEB_PR}.diff.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
-DEPEND=""
-RDEPEND=""
-
src_prepare() {
epatch "${WORKDIR}"/${PN}_${PV}-${DEB_PR}.diff
+ sed \
+ -e 's:../orig/num-utils-0.5/::g' \
+ -i "${S}"/debian/patches/*.diff || die
epatch "${S}"/debian/patches/*.diff
+
local x
for x in average bound interval normalize random range round; do
mv $x num$x || die "renaming $x failed"
done
- sed -i \
+
+ sed \
-e 's/^RPMDIR/#RPMDIR/' \
-e 's/COPYING//' \
-e 's/LICENSE//' \
-e '/^DOCS/s/MANIFEST//' \
- Makefile || die "sed Makefile failed"
+ -i Makefile || die "sed Makefile failed"
}
src_install () {
- emake ROOT="${ED}" install || die "emake install failed"
+ emake ROOT="${ED}" install
}
pkg_postinst() {