summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-02-20 18:14:57 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-02-20 18:14:57 +0000
commit40c6f05c49a2fd43d03a0a60ca03cd211a13c695 (patch)
tree1d313d8d76b2d9126966f41ae9b268e36ebfd575 /sci-mathematics/qtoctave
parentVersion bump and fix path for ebin files, bug 259695. (diff)
downloadgentoo-2-40c6f05c49a2fd43d03a0a60ca03cd211a13c695.tar.gz
gentoo-2-40c6f05c49a2fd43d03a0a60ca03cd211a13c695.tar.bz2
gentoo-2-40c6f05c49a2fd43d03a0a60ca03cd211a13c695.zip
Update ebuild to use cmake-utils eclass correctly.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/qtoctave')
-rw-r--r--sci-mathematics/qtoctave/ChangeLog7
-rw-r--r--sci-mathematics/qtoctave/qtoctave-0.8.1.ebuild8
2 files changed, 9 insertions, 6 deletions
diff --git a/sci-mathematics/qtoctave/ChangeLog b/sci-mathematics/qtoctave/ChangeLog
index 5946f94cf482..7fba3280c537 100644
--- a/sci-mathematics/qtoctave/ChangeLog
+++ b/sci-mathematics/qtoctave/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-mathematics/qtoctave
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/qtoctave/ChangeLog,v 1.3 2008/11/02 21:30:55 markusle Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/qtoctave/ChangeLog,v 1.4 2009/02/20 18:14:57 scarabeus Exp $
+
+ 20 Feb 2009; Tomas Chvatal <scarabeus@gentoo.org> qtoctave-0.8.1.ebuild:
+ Update ebuild to use cmake-utils eclass correctly.
02 Nov 2008; Markus Dittrich <markusle@gentoo.org> qtoctave-0.8.1.ebuild:
Restrict dependency on Qt to >=Qt-4.4 since the source code uses
diff --git a/sci-mathematics/qtoctave/qtoctave-0.8.1.ebuild b/sci-mathematics/qtoctave/qtoctave-0.8.1.ebuild
index 56b91a956bff..3a8c1e36acce 100644
--- a/sci-mathematics/qtoctave/qtoctave-0.8.1.ebuild
+++ b/sci-mathematics/qtoctave/qtoctave-0.8.1.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/qtoctave/qtoctave-0.8.1.ebuild,v 1.2 2008/11/02 21:30:55 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/qtoctave/qtoctave-0.8.1.ebuild,v 1.3 2009/02/20 18:14:57 scarabeus Exp $
EAPI="1"
+CMAKE_IN_SOURCE_BUILD=1
inherit cmake-utils
DESCRIPTION="QtOctave is a Qt4 front-end for Octave"
@@ -25,8 +26,7 @@ S="${WORKDIR}"/${P}/${PN}
src_compile() {
mycmakeargs="-DCMAKE_SKIP_RPATH:BOOL=YES"
- cmake-utils_src_configurein
- cmake-utils_src_make
+ cmake-utils_src_compile
}
src_install() {