summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2005-02-10 11:43:22 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2005-02-10 11:43:22 +0000
commit00d430b5d88af0ac48a97cfff6dfed373050dadd (patch)
tree4140480c3fe3f3faa1134e8eff06eb2dd82756cf /sci-mathematics/snns
parentVersion bumped; bug #77199. (diff)
downloadgentoo-2-00d430b5d88af0ac48a97cfff6dfed373050dadd.tar.gz
gentoo-2-00d430b5d88af0ac48a97cfff6dfed373050dadd.tar.bz2
gentoo-2-00d430b5d88af0ac48a97cfff6dfed373050dadd.zip
one more patch
(Portage version: 2.0.51-r15)
Diffstat (limited to 'sci-mathematics/snns')
-rw-r--r--sci-mathematics/snns/ChangeLog7
-rw-r--r--sci-mathematics/snns/Manifest2
-rw-r--r--sci-mathematics/snns/files/digest-snns-4.2-r75
-rw-r--r--sci-mathematics/snns/snns-4.2-r7.ebuild118
4 files changed, 131 insertions, 1 deletions
diff --git a/sci-mathematics/snns/ChangeLog b/sci-mathematics/snns/ChangeLog
index 37322330cdd9..5b38c3a29e8a 100644
--- a/sci-mathematics/snns/ChangeLog
+++ b/sci-mathematics/snns/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/snns
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/snns/ChangeLog,v 1.3 2005/01/30 16:07:04 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/snns/ChangeLog,v 1.4 2005/02/10 11:43:22 phosphan Exp $
+
+*snns-4.2-r7 (10 Feb 2005)
+
+ 10 Feb 2005; Patrick Kursawe <phosphan@gentoo.org> +snns-4.2-r7.ebuild:
+ New patch for python function calls from the SNNS kernel
30 Jan 2005; Jan Brinkmann <luckyduck@gentoo.org>
+files/4.2-fPIC-python.patch, snns-4.2-r6.ebuild:
diff --git a/sci-mathematics/snns/Manifest b/sci-mathematics/snns/Manifest
index 64cf14e67673..9eaccc60af9a 100644
--- a/sci-mathematics/snns/Manifest
+++ b/sci-mathematics/snns/Manifest
@@ -1,7 +1,9 @@
+MD5 55577720b6cd591021025bdddb825d6d snns-4.2-r7.ebuild 2809
MD5 74eb817bd528c04a396576ef594eb643 snns-4.2-r4.ebuild 1640
MD5 fb190457a7a8d464b3c180b3b23fa000 snns-4.2-r6.ebuild 2602
MD5 eafd92b0519149c824ec45a66df4aed6 ChangeLog 2488
MD5 c000c0728c9136f1b54cbc3a5fc07644 metadata.xml 220
MD5 409a7ed863845a91ab923aee9873a062 files/digest-snns-4.2-r4 196
MD5 13bc6c016dc3aa799a25598dead6346e files/digest-snns-4.2-r6 262
+MD5 5ff18c8925d0470f7a9e21fac5aa030e files/digest-snns-4.2-r7 345
MD5 e810e01b587c8fc167a868700f105be6 files/4.2-fPIC-python.patch 498
diff --git a/sci-mathematics/snns/files/digest-snns-4.2-r7 b/sci-mathematics/snns/files/digest-snns-4.2-r7
new file mode 100644
index 000000000000..4d755504cad0
--- /dev/null
+++ b/sci-mathematics/snns/files/digest-snns-4.2-r7
@@ -0,0 +1,5 @@
+MD5 4609dfd61714bfbb0842d4e8e905e584 SNNSv4.2.tar.gz 2170375
+MD5 73a999a41bb91a4f8b5653ddddfcc527 snns-4.2-20040227.patch.gz 55476
+MD5 e91242fdc43877013ade3b5f2213659a SNNSv4.2.Manual.pdf 2103861
+MD5 fd63676eabeab8c633b176c01cbf8d44 PySNNS-20040605.tar.gz 20158
+MD5 df45b551a3daaf6fd7974388f81d8917 PythonFunctionSupport-20050210.patch.gz 15728
diff --git a/sci-mathematics/snns/snns-4.2-r7.ebuild b/sci-mathematics/snns/snns-4.2-r7.ebuild
new file mode 100644
index 000000000000..fb8c047235be
--- /dev/null
+++ b/sci-mathematics/snns/snns-4.2-r7.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/snns/snns-4.2-r7.ebuild,v 1.1 2005/02/10 11:43:22 phosphan Exp $
+
+inherit eutils python
+
+MY_P="SNNSv${PV}"
+MYPATCH="${P}-20040227"
+MYPYTHONEXT="PySNNS-20040605"
+MYPYTHONPATCH="PythonFunctionSupport-20050210.patch"
+
+DESCRIPTION="Stuttgart Neural Network Simulator"
+HOMEPAGE="http://www-ra.informatik.uni-tuebingen.de/SNNS/"
+SRC_URI="http://www-ra.informatik.uni-tuebingen.de/downloads/SNNS/${MY_P}.tar.gz
+ http://download.berlios.de/snns-dev/${MYPATCH}.patch.gz
+ doc? ( http://www-ra.informatik.uni-tuebingen.de/downloads/SNNS/${MY_P}.Manual.pdf )
+ python? ( http://download.berlios.de/snns-dev/${MYPYTHONEXT}.tar.gz
+ http://download.berlios.de/snns-dev/${MYPYTHONPATCH}.gz )"
+
+LICENSE="SNNS-${PV}"
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+IUSE="X doc python"
+
+DEPEND="X? ( virtual/x11
+ x11-libs/Xaw3d )
+ >=sys-apps/sed-4
+ python? ( >=dev-lang/python-2.3 )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ unpack ${MYPATCH}.patch.gz
+ epatch ${MYPATCH}.patch
+ if use python; then
+ unpack ${MYPYTHONEXT}.tar.gz
+
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-fPIC-python.patch
+ cd ${WORKDIR}
+ unpack ${MYPYTHONPATCH}.gz
+ cd ${S}
+ epatch ${WORKDIR}/${MYPYTHONPATCH}
+ fi
+}
+
+src_compile() {
+ local myconf="--enable-global"
+ local compileopts="compile-kernel compile-tools"
+
+ if use X; then
+ myconf="${myconf} --with-x"
+ compileopts="${compileopts} compile-xgui"
+ else
+ myconf="${myconf} --without-x"
+ fi
+
+ econf ${myconf} || die "econf failed"
+ # parallel make sometimes fails (phosphan)
+ make ${compileopts} || die "make failed"
+
+ if use python; then
+ cd python
+ python setup.py build || die "could not build python extension"
+ fi
+}
+
+src_install() {
+ for file in `find tools -type f -perm +100`; do
+ dobin $file
+ done
+
+ if use X; then
+ newbin xgui/sources/xgui snns
+
+ dodir /etc/env.d
+ echo XGUILOADPATH=/usr/share/doc/${PF}/ > ${D}/etc/env.d/99snns
+
+ insinto /usr/share/doc/${PF}
+ doins default.cfg help.hdoc
+ fi
+
+ if use python; then
+ cd python
+ python setup.py install --prefix=${D}/usr || die "could not install python module"
+ cp -a examples ${D}/usr/share/doc/${PF}/python-examples
+ chmod +x ${D}/usr/share/doc/${PF}/python-examples/*.py
+ newdoc README README.python
+ cd ${S}
+ fi
+
+ insinto /usr/share/doc/${PF}
+ use doc && doins ${DISTDIR}/${MY_P}.Manual.pdf
+
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+
+ doman man/man*/*
+}
+
+pkg_postinst() {
+ if use python; then
+ einfo "Pre-compiling Python module"
+ python_version
+ for file in __init__.py util.py; do
+ python_mod_compile \
+ ${ROOT}/usr/lib/python${PYVER}/site-packages/snns/${file}
+ done
+ fi
+}
+
+pkg_postrm() {
+ if use python; then
+ einfo "Cleaning up python stuff"
+ python_mod_cleanup
+ fi
+}