summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2015-04-16 14:44:32 +0000
committerAndrey Grozin <grozin@gentoo.org>2015-04-16 14:44:32 +0000
commit090ec1a63e41701565b800e8cf1e536dc701d028 (patch)
tree6d86cd94c44379f26725a3ebc1e43c3936a45d25 /sci-mathematics
parentVersion bump (diff)
downloadgentoo-2-090ec1a63e41701565b800e8cf1e536dc701d028.tar.gz
gentoo-2-090ec1a63e41701565b800e8cf1e536dc701d028.tar.bz2
gentoo-2-090ec1a63e41701565b800e8cf1e536dc701d028.zip
Version bump
(Portage version: 2.2.18/cvs/Linux i686, signed Manifest commit with key 0x3AFFCE974D34BD8C!)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/wxmaxima/ChangeLog7
-rw-r--r--sci-mathematics/wxmaxima/wxmaxima-15.04.0.ebuild76
2 files changed, 82 insertions, 1 deletions
diff --git a/sci-mathematics/wxmaxima/ChangeLog b/sci-mathematics/wxmaxima/ChangeLog
index cc2e1f8275c1..28f55bf86314 100644
--- a/sci-mathematics/wxmaxima/ChangeLog
+++ b/sci-mathematics/wxmaxima/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/wxmaxima
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/wxmaxima/ChangeLog,v 1.45 2015/03/27 16:30:47 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/wxmaxima/ChangeLog,v 1.46 2015/04/16 14:44:32 grozin Exp $
+
+*wxmaxima-15.04.0 (16 Apr 2015)
+
+ 16 Apr 2015; Andrey Grozin <grozin@gentoo.org> +wxmaxima-15.04.0.ebuild:
+ Version bump
27 Mar 2015; Agostino Sarubbo <ago@gentoo.org> wxmaxima-13.04.2.ebuild:
Stable for amd64, wrt bug #406779
diff --git a/sci-mathematics/wxmaxima/wxmaxima-15.04.0.ebuild b/sci-mathematics/wxmaxima/wxmaxima-15.04.0.ebuild
new file mode 100644
index 000000000000..41f3eb0d4e1d
--- /dev/null
+++ b/sci-mathematics/wxmaxima/wxmaxima-15.04.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/wxmaxima/wxmaxima-15.04.0.ebuild,v 1.1 2015/04/16 14:44:32 grozin Exp $
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+
+inherit eutils gnome2-utils wxwidgets fdo-mime
+
+DESCRIPTION="Graphical frontend to Maxima, using the wxWidgets toolkit"
+HOMEPAGE="http://andrejv.github.io/wxmaxima/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="
+ dev-libs/libxml2:2
+ x11-libs/wxGTK:${WX_GTK_VER}"
+RDEPEND="${DEPEND}
+ media-fonts/jsmath
+ sci-visualization/gnuplot[wxwidgets]
+ sci-mathematics/maxima"
+
+src_prepare() {
+ local i
+
+ # consistent package names
+ sed -e "s:\${datadir}/wxMaxima:\${datadir}/${PN}:g" \
+ -i Makefile.in data/Makefile.in || die "sed failed"
+
+ sed -e 's:share/wxMaxima:share/wxmaxima:g' \
+ -i src/wxMaxima.cpp src/wxMaximaFrame.cpp src/Config.cpp \
+ || die "sed failed"
+
+ # correct gettext behavior
+ if [[ -n "${LINGUAS+x}" ]] ; then
+ for i in $(cd "${S}"/locales ; echo *.mo) ; do
+ if ! has ${i%.mo} ${LINGUAS} ; then
+ sed -i \
+ -e "/^WXMAXIMA_LINGUAS/s# ${i%.mo}##" \
+ -e "/^WXWIN_LINGUAS/s# ${i%.mo}##" \
+ locales/Makefile.in || die
+ fi
+ done
+ fi
+}
+
+src_configure() {
+ econf \
+ --enable-printing \
+ --with-wx-config=${WX_CONFIG}
+}
+
+src_install () {
+ default
+ doicon -s 128 data/wxmaxima.png
+ make_desktop_entry wxmaxima wxMaxima wxmaxima
+ dosym /usr/share/${PN}/README /usr/share/doc/${PF}/README
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}