summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Gardner <je_fro@gentoo.org>2006-10-31 11:24:06 +0000
committerJeffrey Gardner <je_fro@gentoo.org>2006-10-31 11:24:06 +0000
commit0b3bbb5c0389677fc5efb988a829de95a2bf68f2 (patch)
treee6efa0f4ef730da2d54668f7f4ece97d5dddc715 /sci-mathematics
parentmarked ~x86 as requested in bug #153132 (diff)
downloadgentoo-2-0b3bbb5c0389677fc5efb988a829de95a2bf68f2.tar.gz
gentoo-2-0b3bbb5c0389677fc5efb988a829de95a2bf68f2.tar.bz2
gentoo-2-0b3bbb5c0389677fc5efb988a829de95a2bf68f2.zip
Version bump for bug #136289.
(Portage version: 2.1.1-r1)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/maxima/ChangeLog7
-rw-r--r--sci-mathematics/maxima/files/digest-maxima-5.10.03
-rw-r--r--sci-mathematics/maxima/maxima-5.10.0.ebuild131
3 files changed, 140 insertions, 1 deletions
diff --git a/sci-mathematics/maxima/ChangeLog b/sci-mathematics/maxima/ChangeLog
index f088b0d4aaf2..1cc69ae41313 100644
--- a/sci-mathematics/maxima/ChangeLog
+++ b/sci-mathematics/maxima/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/maxima
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/maxima/ChangeLog,v 1.21 2006/07/12 15:34:43 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/maxima/ChangeLog,v 1.22 2006/10/31 11:24:06 je_fro Exp $
+
+*maxima-5.10.0 (31 Oct 2006)
+
+ 31 Oct 2006; Jeff Gardner <je_fro@gentoo.org> +maxima-5.10.0.ebuild:
+ New version for bug #136289
12 Jul 2006; Danny van Dyk <kugelfang@gentoo.org> maxima-5.9.3.ebuild:
QA: Corrected typo: tcktk vs tcltk.
diff --git a/sci-mathematics/maxima/files/digest-maxima-5.10.0 b/sci-mathematics/maxima/files/digest-maxima-5.10.0
new file mode 100644
index 000000000000..305a1626da24
--- /dev/null
+++ b/sci-mathematics/maxima/files/digest-maxima-5.10.0
@@ -0,0 +1,3 @@
+MD5 1e7f5ecabf990f350c5f662f106d83b7 maxima-5.10.0.tar.gz 9957907
+RMD160 6ec60429f3720c9d8dca5d628e49d2eb01e24fc1 maxima-5.10.0.tar.gz 9957907
+SHA256 b59e3af8a771b92158410bed6327f18a6a69bccd4e776d83a3952a67bd388c49 maxima-5.10.0.tar.gz 9957907
diff --git a/sci-mathematics/maxima/maxima-5.10.0.ebuild b/sci-mathematics/maxima/maxima-5.10.0.ebuild
new file mode 100644
index 000000000000..166461322051
--- /dev/null
+++ b/sci-mathematics/maxima/maxima-5.10.0.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/maxima/maxima-5.10.0.ebuild,v 1.1 2006/10/31 11:24:06 je_fro Exp $
+
+inherit eutils elisp-common autotools
+
+DESCRIPTION="Free computer algebra environment, based on Macsyma"
+HOMEPAGE="http://maxima.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 AECA"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="cmucl clisp sbcl gcl tetex emacs auctex tk nls unicode"
+
+RDEPEND=">=sci-visualization/gnuplot-4.0
+ app-text/gv
+ tetex? ( virtual/tetex )
+ emacs? ( virtual/emacs )
+ auctex? ( app-emacs/auctex )
+ clisp? ( >=dev-lisp/clisp-2.33.2-r1 )
+ gcl? ( >=dev-lisp/gcl-2.6.7 )
+ sbcl? ( >=dev-lisp/sbcl-0.9.4 app-misc/rlwrap )
+ cmucl? ( >=dev-lisp/cmucl-19a app-misc/rlwrap )
+ !clisp? ( !sbcl? ( !cmucl? ( >=dev-lisp/gcl-2.6.7 ) ) )
+ tk? ( >=dev-lang/tk-8.3.3 )"
+DEPEND="${RDEPEND} >=sys-apps/texinfo-4.3"
+
+for lang in es pt; do
+ IUSE="${IUSE} linguas_${lang}"
+done
+
+# chosen apps are hardcoded in maxima source:
+# - ghostview for postscript (changed to gv)
+# - acroread for pdf
+# - xdvi for dvi. this could change, with pain.
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}/${P}.patch"
+}
+
+src_compile() {
+
+# automake version mismatch otherwise (sbcl only)
+ use sbcl && eautoreconf
+
+# remove rmaxima if neither cmucl nor sbcl
+ if ! use sbcl && ! use cmucl ; then
+ sed -i -e '/^@WIN32_FALSE@bin_SCRIPTS/s/rmaxima//' src/Makefile.in
+ fi
+
+# remove xmaxima if no tk in USE
+ local myconf=""
+ if use tk; then
+ myconf="${myconf} --with-wish=wish"
+ else
+ myconf="${myconf} --with-wish=none"
+ sed -i -e '/^SUBDIRS/s/xmaxima//' interfaces/Makefile.in
+ fi
+
+# enable gcl if no other lisp is selected
+ if use gcl || (! use cmucl && ! use clisp && ! use sbcl ); then
+ if ! built_with_use dev-lisp/gcl ansi; then
+ eerror "GCL must be installed with ANSI."
+ eerror "Try USE=\"ansi\" emerge gcl"
+ die "This package needs gcl with USE=ansi"
+ fi
+ myconf="${myconf} --enable-gcl"
+ fi
+
+# use existing translated docs
+ if use nls; then
+ for lang in es pt; do
+ if use linguas_${lang}; then
+ myconf="${myconf} --enable-lang-${lang}"
+ use unicode && myconf="${myconf} --enable-lang-${lang}-utf8"
+ fi
+ done
+ fi
+
+ econf \
+ $(use_enable cmucl) \
+ $(use_enable clisp) \
+ $(use_enable sbcl) \
+ ${myconf} \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ use tk && make_desktop_entry xmaxima xmaxima \
+ /usr/share/${PN}/${PV}/xmaxima/maxima-new.png
+
+ if use emacs; then
+ sed -e "s/PV/${PV}/" "${FILESDIR}"/50maxima-gentoo.el > 50maxima-gentoo.el
+ elisp-site-file-install 50maxima-gentoo.el
+ fi
+
+ if use tetex; then
+ insinto /usr/share/texmf/tex/latex/emaxima
+ doins interfaces/emacs/emaxima/emaxima.sty
+ fi
+
+ insinto /usr/share/${PN}/${PV}/doc
+ doins AUTHORS ChangeLog COPYING NEWS README*
+ dodir /usr/share/doc
+ dosym /usr/share/${PN}/${PV}/doc /usr/share/doc/${PF}
+}
+
+pkg_preinst() {
+# some lisp do not gunzip info files on the fly
+
+ if use cmucl || use clisp || use sbcl; then
+ for infofile in $(ls ${D}/usr/share/info/*.gz); do
+ gunzip ${infofile}
+ done
+ fi
+}
+
+pkg_postinst() {
+
+ use emacs && elisp-site-regen
+ use tetex && mktexlsr
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}