summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2014-08-03 08:18:14 +0000
committerAndrey Grozin <grozin@gentoo.org>2014-08-03 08:18:14 +0000
commit1f4f6b092ca3e8c247aa03a2c39c80699da19252 (patch)
tree6a5b161685dd1d169e8ffc972c983ffc373f2b8d /sci-mathematics
parentVersion bump (diff)
downloadgentoo-2-1f4f6b092ca3e8c247aa03a2c39c80699da19252.tar.gz
gentoo-2-1f4f6b092ca3e8c247aa03a2c39c80699da19252.tar.bz2
gentoo-2-1f4f6b092ca3e8c247aa03a2c39c80699da19252.zip
Default lisp on arm is now gcl
(Portage version: 2.2.10/cvs/Linux i686, signed Manifest commit with key 0x3AFFCE974D34BD8C!)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/maxima/ChangeLog5
-rw-r--r--sci-mathematics/maxima/maxima-5.33.0.ebuild17
2 files changed, 16 insertions, 6 deletions
diff --git a/sci-mathematics/maxima/ChangeLog b/sci-mathematics/maxima/ChangeLog
index d88b16e9ee51..f60818861192 100644
--- a/sci-mathematics/maxima/ChangeLog
+++ b/sci-mathematics/maxima/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-mathematics/maxima
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/maxima/ChangeLog,v 1.110 2014/04/06 11:11:41 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/maxima/ChangeLog,v 1.111 2014/08/03 08:18:14 grozin Exp $
+
+ 03 Aug 2014; Andrey Grozin <grozin@gentoo.org> maxima-5.33.0.ebuild:
+ Default lisp on arm is now gcl
*maxima-5.33.0 (06 Apr 2014)
diff --git a/sci-mathematics/maxima/maxima-5.33.0.ebuild b/sci-mathematics/maxima/maxima-5.33.0.ebuild
index d82d1bd321e4..329405f7f02b 100644
--- a/sci-mathematics/maxima/maxima-5.33.0.ebuild
+++ b/sci-mathematics/maxima/maxima-5.33.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/maxima/maxima-5.33.0.ebuild,v 1.1 2014/04/06 11:11:41 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/maxima/maxima-5.33.0.ebuild,v 1.2 2014/08/03 08:18:14 grozin Exp $
EAPI=5
@@ -14,7 +14,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-# Supported lisps (the first one is the default)
+# Supported lisps
LISPS=( sbcl cmucl gcl ecls clozurecl clisp )
# <lisp> supports readline: . - no, y - yes
SUPP_RL=( . . y . . y )
@@ -62,7 +62,14 @@ for ((n--; n >= 0; n--)); do
fi
done
-DEF_DEP="${DEF_DEP} `depends 0`"
+# default lisp
+if use arm; then
+ DEF_LISP=2 # gcl
+else
+ DEF_LISP=0 # sbcl
+fi
+
+DEF_DEP="${DEF_DEP} `depends ${DEF_LISP}`"
n=${#LISPS[*]}
for ((n--; n > 0; n--)); do
@@ -87,8 +94,8 @@ pkg_setup() {
done
if [ -z "${NLISPS}" ]; then
- ewarn "No lisp specified in USE flags, choosing ${LISPS[0]} as default"
- NLISPS=0
+ ewarn "No lisp specified in USE flags, choosing ${LISPS[${DEF_LISP}]} as default"
+ NLISPS=${DEF_LISP}
fi
}