summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-02-15 12:22:34 +0000
committerPacho Ramos <pacho@gentoo.org>2014-02-15 12:22:34 +0000
commit3abbd646670b91ec0fd80e3ce7c2df06739fab9a (patch)
tree6d4993fc4d4a70f3c1a04e8cc704411ee2ff3285 /sci-mathematics
parentremoved -100 as -1.100 is the replacement (diff)
downloadgentoo-2-3abbd646670b91ec0fd80e3ce7c2df06739fab9a.tar.gz
gentoo-2-3abbd646670b91ec0fd80e3ce7c2df06739fab9a.tar.bz2
gentoo-2-3abbd646670b91ec0fd80e3ce7c2df06739fab9a.zip
Add unit file (#499120 by Paolo Pedroni)
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/gimps/ChangeLog8
-rw-r--r--sci-mathematics/gimps/files/gimps.service14
-rw-r--r--sci-mathematics/gimps/files/gimps.tmpfiles1
-rw-r--r--sci-mathematics/gimps/gimps-28.3-r1.ebuild67
4 files changed, 89 insertions, 1 deletions
diff --git a/sci-mathematics/gimps/ChangeLog b/sci-mathematics/gimps/ChangeLog
index 5c959444aea9..15a5a7003ab1 100644
--- a/sci-mathematics/gimps/ChangeLog
+++ b/sci-mathematics/gimps/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/gimps
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gimps/ChangeLog,v 1.62 2014/02/07 14:38:21 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gimps/ChangeLog,v 1.63 2014/02/15 12:22:34 pacho Exp $
+
+*gimps-28.3-r1 (15 Feb 2014)
+
+ 15 Feb 2014; Pacho Ramos <pacho@gentoo.org> +files/gimps.service,
+ +files/gimps.tmpfiles, +gimps-28.3-r1.ebuild:
+ Add unit file (#499120 by Paolo Pedroni)
*gimps-28.3 (07 Feb 2014)
diff --git a/sci-mathematics/gimps/files/gimps.service b/sci-mathematics/gimps/files/gimps.service
new file mode 100644
index 000000000000..d3436717b175
--- /dev/null
+++ b/sci-mathematics/gimps/files/gimps.service
@@ -0,0 +1,14 @@
+[Unit]
+Description=Great Internet Mersenne Prime Search client
+After=network.target local-fs.target
+Wants=local-fs.target
+
+[Service]
+User=nobody
+Group=nobody
+ExecStart=/opt/gimps/mprime -w/var/lib/gimps
+StandardOutput=null
+StandardError=journal
+
+[Install]
+WantedBy=multi-user.target
diff --git a/sci-mathematics/gimps/files/gimps.tmpfiles b/sci-mathematics/gimps/files/gimps.tmpfiles
new file mode 100644
index 000000000000..c965e7de5352
--- /dev/null
+++ b/sci-mathematics/gimps/files/gimps.tmpfiles
@@ -0,0 +1 @@
+d /var/lib/gimps 0755 nobody nobody -
diff --git a/sci-mathematics/gimps/gimps-28.3-r1.ebuild b/sci-mathematics/gimps/gimps-28.3-r1.ebuild
new file mode 100644
index 000000000000..24425409ce63
--- /dev/null
+++ b/sci-mathematics/gimps/gimps-28.3-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gimps/gimps-28.3-r1.ebuild,v 1.1 2014/02/15 12:22:34 pacho Exp $
+
+EAPI=4
+
+inherit pax-utils systemd
+
+DESCRIPTION="The Great Internet Mersenne Prime Search"
+HOMEPAGE="http://mersenne.org/"
+SRC_URI="
+ amd64? ( ftp://mersenne.org/gimps/p95v${PV/./}.linux64.tar.gz )"
+
+SLOT="0"
+LICENSE="GIMPS"
+KEYWORDS="-* ~amd64"
+IUSE=""
+
+# Since there are no statically linked binaries for this version of mprime,
+# and no static binaries for amd64 in general, we use the dynamically linked
+# ones and try to cover the .so deps with the packages listed in RDEPEND.
+DEPEND=""
+RDEPEND="net-misc/curl"
+
+RESTRICT="binchecks"
+
+S="${WORKDIR}"
+I="/opt/gimps"
+
+QA_PREBUILT="opt/gimps/mprime"
+
+src_install() {
+ dodir ${I} /var/lib/gimps
+ pax-mark m mprime
+ cp mprime "${D}/${I}"
+ fperms a-w "${I}/mprime"
+ fowners root:0 "${I}"
+ fowners root:0 "${I}/mprime"
+
+ dodoc license.txt readme.txt stress.txt whatsnew.txt undoc.txt
+
+ newinitd "${FILESDIR}/${PN}-26.6-r1-init.d" gimps
+ newconfd "${FILESDIR}/${PN}-25.6-conf.d" gimps
+
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ systemd_newtmpfilesd "${FILESDIR}/${PN}.tmpfiles" "${PN}.conf"
+}
+
+pkg_postinst() {
+ echo
+ einfo "You can use \`/etc/init.d/gimps start\` to start a GIMPS client in the"
+ einfo "background at boot. Have a look at /etc/conf.d/gimps and check some"
+ einfo "configuration options."
+ einfo
+ einfo "If you don't want to use the init script to start gimps, remember to"
+ einfo "pass it an additional command line parameter specifying where the data"
+ einfo "files are to be stored, e.g.:"
+ einfo " ${I}/mprime -w/var/lib/gimps"
+ echo
+}
+
+pkg_postrm() {
+ echo
+ einfo "GIMPS data files were not removed."
+ einfo "Remove them manually from /var/lib/gimps/"
+ echo
+}