summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-11-03 15:44:39 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-11-03 15:44:39 +0000
commit3ee7bdbfd2034d94af282543ce6b9b24531c2c5b (patch)
treed6304bb4be97e1d6eadf7ba8f5460efc13299de6 /sci-mathematics
parentStable on ppc wrt bug 153936 (diff)
downloadgentoo-2-3ee7bdbfd2034d94af282543ce6b9b24531c2c5b.tar.gz
gentoo-2-3ee7bdbfd2034d94af282543ce6b9b24531c2c5b.tar.bz2
gentoo-2-3ee7bdbfd2034d94af282543ce6b9b24531c2c5b.zip
Fixed test case that failed inside the sandbox and added dejagnu as dependency which is needed for src_test. This fixes bug #140808.
(Portage version: 2.1.2_rc1-r1)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/octave/ChangeLog6
-rw-r--r--sci-mathematics/octave/files/octave-example-fix.patch9
-rw-r--r--sci-mathematics/octave/octave-2.1.73-r1.ebuild4
3 files changed, 17 insertions, 2 deletions
diff --git a/sci-mathematics/octave/ChangeLog b/sci-mathematics/octave/ChangeLog
index 4bd44140cbe3..d50358b7c60c 100644
--- a/sci-mathematics/octave/ChangeLog
+++ b/sci-mathematics/octave/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/octave
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.40 2006/11/02 16:29:22 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.41 2006/11/03 15:44:39 markusle Exp $
+
+ 03 Nov 2006; Markus Dittrich <markusle@gentoo.org> ChangeLog:
+ Fixed test case that failed inside the sandbox and added dejagnu
+ as dependency which is needed for src_test. This fixes bug #140808.
*octave-2.1.73-r1 (02 Nov 2006)
diff --git a/sci-mathematics/octave/files/octave-example-fix.patch b/sci-mathematics/octave/files/octave-example-fix.patch
new file mode 100644
index 000000000000..bfd664ce109d
--- /dev/null
+++ b/sci-mathematics/octave/files/octave-example-fix.patch
@@ -0,0 +1,9 @@
+diff -Naur octave-2.1.73/test/octave.test/system/tilde_expand-1.m octave-2.1.73-new/test/octave.test/system/tilde_expand-1.m
+--- octave-2.1.73/test/octave.test/system/tilde_expand-1.m 1997-02-25 23:29:27.000000000 -0500
++++ octave-2.1.73-new/test/octave.test/system/tilde_expand-1.m 2006-11-03 10:09:37.000000000 -0500
+@@ -1,4 +1,3 @@
+ x = getpwuid (getuid ());
+-(strcmp (x.dir, tilde_expand ("~"))
+- && strcmp (x.dir, tilde_expand (sprintf ("~%s", x.name)))
++( strcmp (x.dir, tilde_expand (sprintf ("~%s", x.name)))
+ && strcmp ("foobar", tilde_expand ("foobar")))
diff --git a/sci-mathematics/octave/octave-2.1.73-r1.ebuild b/sci-mathematics/octave/octave-2.1.73-r1.ebuild
index fca3035313df..afcd4658d7c6 100644
--- a/sci-mathematics/octave/octave-2.1.73-r1.ebuild
+++ b/sci-mathematics/octave/octave-2.1.73-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.73-r1.ebuild,v 1.1 2006/11/02 16:29:22 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-2.1.73-r1.ebuild,v 1.2 2006/11/03 15:44:39 markusle Exp $
inherit flag-o-matic fortran autotools
@@ -15,6 +15,7 @@ IUSE="emacs static readline zlib doc hdf5 mpi blas"
KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
DEPEND="virtual/libc
+ dev-util/dejagnu
>=sys-libs/ncurses-5.2-r3
>=sci-visualization/gnuplot-3.7.1-r3
>=sci-libs/fftw-2.1.3
@@ -37,6 +38,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/${P}-gcc4.1-gentoo.patch
+ epatch "${FILESDIR}"/${PN}-example-fix.patch
epatch "${FILESDIR}"/${P}-f2c-fix.patch
eautoconf
}