summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-04-05 17:44:25 +0000
committerJustin Lecher <jlec@gentoo.org>2014-04-05 17:44:25 +0000
commit50e45e7fd927f3c21889bc33ce3a35dac781a17b (patch)
tree8cc6d36f6a9afcedf15a8d9d2c14922e547d250b /sci-mathematics
parentForce rebuild after liboxygenstyle upgrade (diff)
downloadgentoo-2-50e45e7fd927f3c21889bc33ce3a35dac781a17b.tar.gz
gentoo-2-50e45e7fd927f3c21889bc33ce3a35dac781a17b.tar.bz2
gentoo-2-50e45e7fd927f3c21889bc33ce3a35dac781a17b.zip
sci-mathematics/genius: Add fix for gcc-4.8
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/genius/ChangeLog8
-rw-r--r--sci-mathematics/genius/files/genius-1.0.17-gcc4.8.patch28
-rw-r--r--sci-mathematics/genius/genius-1.0.17.ebuild6
3 files changed, 38 insertions, 4 deletions
diff --git a/sci-mathematics/genius/ChangeLog b/sci-mathematics/genius/ChangeLog
index f28a55e1390f..33a5bf0e5feb 100644
--- a/sci-mathematics/genius/ChangeLog
+++ b/sci-mathematics/genius/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/genius
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/genius/ChangeLog,v 1.8 2013/06/28 15:49:20 jlec Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/genius/ChangeLog,v 1.9 2014/04/05 17:44:25 jlec Exp $
+
+ 05 Apr 2014; Justin Lecher <jlec@gentoo.org> genius-1.0.17.ebuild,
+ +files/genius-1.0.17-gcc4.8.patch:
+ Add fix for gcc-4.8
*genius-1.0.17 (28 Jun 2013)
diff --git a/sci-mathematics/genius/files/genius-1.0.17-gcc4.8.patch b/sci-mathematics/genius/files/genius-1.0.17-gcc4.8.patch
new file mode 100644
index 000000000000..34427a72dda1
--- /dev/null
+++ b/sci-mathematics/genius/files/genius-1.0.17-gcc4.8.patch
@@ -0,0 +1,28 @@
+ src/genius-readline-helper.c | 2 +-
+ src/inter.c | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/genius-readline-helper.c b/src/genius-readline-helper.c
+index 7e9e84b..dbf8fd2 100644
+--- a/src/genius-readline-helper.c
++++ b/src/genius-readline-helper.c
+@@ -183,7 +183,7 @@ main(int argc, char *argv[])
+ rl_terminal_name = "xterm";
+ rl_readline_name = "Genius";
+ rl_attempted_completion_function =
+- (CPPFunction *)tab_completion;
++ (rl_completion_func_t *)tab_completion;
+
+ while(fgets(buf,4096,infp)) {
+ int count;
+diff --git a/src/inter.c b/src/inter.c
+index 915f115..f0d2558 100644
+--- a/src/inter.c
++++ b/src/inter.c
+@@ -367,5 +367,5 @@ init_inter(void)
+ {
+ rl_readline_name = "Genius";
+ rl_attempted_completion_function =
+- (CPPFunction *)tab_completion;
++ (rl_completion_func_t *)tab_completion;
+ }
diff --git a/sci-mathematics/genius/genius-1.0.17.ebuild b/sci-mathematics/genius/genius-1.0.17.ebuild
index 376a7eee6f45..643c548c2f5d 100644
--- a/sci-mathematics/genius/genius-1.0.17.ebuild
+++ b/sci-mathematics/genius/genius-1.0.17.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/genius/genius-1.0.17.ebuild,v 1.1 2013/06/28 15:49:20 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/genius/genius-1.0.17.ebuild,v 1.2 2014/04/05 17:44:25 jlec Exp $
EAPI=5
@@ -48,6 +48,8 @@ src_prepare() {
GCONF_DEBUG="no"
DOCS="AUTHORS ChangeLog NEWS README TODO"
USE_DESTDIR="1"
+
+ epatch "${FILESDIR}"/${P}-gcc4.8.patch
}
src_install() {