summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-03-07 09:06:37 +0000
committerJustin Lecher <jlec@gentoo.org>2013-03-07 09:06:37 +0000
commit53089f46c6bea3134d6b1f1150941cd647fd1910 (patch)
treea1c7027394491e31d5962d0b5d06678e20d2132d /sci-mathematics
parentMake repoman a bit more happy (whitespace) (diff)
downloadgentoo-2-53089f46c6bea3134d6b1f1150941cd647fd1910.tar.gz
gentoo-2-53089f46c6bea3134d6b1f1150941cd647fd1910.tar.bz2
gentoo-2-53089f46c6bea3134d6b1f1150941cd647fd1910.zip
sci-mathematics/gmp-ecm: Fix underlinking; add static-libs support
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/gmp-ecm/ChangeLog8
-rw-r--r--sci-mathematics/gmp-ecm/gmp-ecm-6.4.4-r1.ebuild (renamed from sci-mathematics/gmp-ecm/gmp-ecm-6.4.4.ebuild)21
2 files changed, 22 insertions, 7 deletions
diff --git a/sci-mathematics/gmp-ecm/ChangeLog b/sci-mathematics/gmp-ecm/ChangeLog
index 3da8477991ca..9e7d408c704d 100644
--- a/sci-mathematics/gmp-ecm/ChangeLog
+++ b/sci-mathematics/gmp-ecm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/gmp-ecm
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gmp-ecm/ChangeLog,v 1.9 2013/03/07 08:05:21 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gmp-ecm/ChangeLog,v 1.10 2013/03/07 09:06:37 jlec Exp $
+
+*gmp-ecm-6.4.4-r1 (07 Mar 2013)
+
+ 07 Mar 2013; Justin Lecher <jlec@gentoo.org> -gmp-ecm-6.4.4.ebuild,
+ +gmp-ecm-6.4.4-r1.ebuild:
+ Fix underlinking; add static-libs support
07 Mar 2013; Justin Lecher <jlec@gentoo.org> gmp-ecm-6.4.3-r5.ebuild,
gmp-ecm-6.4.4.ebuild, gmp-ecm-9999.ebuild, metadata.xml:
diff --git a/sci-mathematics/gmp-ecm/gmp-ecm-6.4.4.ebuild b/sci-mathematics/gmp-ecm/gmp-ecm-6.4.4-r1.ebuild
index 45aee228deb7..6d095303bfe4 100644
--- a/sci-mathematics/gmp-ecm/gmp-ecm-6.4.4.ebuild
+++ b/sci-mathematics/gmp-ecm/gmp-ecm-6.4.4-r1.ebuild
@@ -1,19 +1,19 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gmp-ecm/gmp-ecm-6.4.4.ebuild,v 1.2 2013/03/07 08:05:21 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gmp-ecm/gmp-ecm-6.4.4-r1.ebuild,v 1.1 2013/03/07 09:06:37 jlec Exp $
EAPI=5
+inherit autotools eutils flag-o-matic multilib
+
DESCRIPTION="Elliptic Curve Method for Integer Factorization"
HOMEPAGE="http://ecm.gforge.inria.fr/"
SRC_URI="https://gforge.inria.fr/frs/download.php/32159/${P}.tar.gz"
-inherit eutils flag-o-matic
-
LICENSE="GPL-3 LGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="+blas +custom-tune gwnum -openmp test"
+IUSE="+blas +custom-tune gwnum -openmp static-libs test"
DEPEND="
dev-libs/gmp
@@ -29,10 +29,19 @@ S=${WORKDIR}/ecm-${PV}
MAKEOPTS+=" -j1"
+src_prepare() {
+ sed -e '/libecm_la_LIBADD/s:$: -lgmp:g' -i Makefile.am || die
+ eautoreconf
+}
+
src_configure() {
- if use gwnum; then myconf="--with-gwnum=/usr/lib"; fi
+ use gwnum && local myconf="--with-gwnum="${EPREFIX}"/usr/$(get_libdir)"
# --enable-shellcmd is broken
- econf $(use_enable openmp) $myconf
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static)
+ $(use_enable openmp) \
+ ${myconf}
}
src_compile() {