summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-10-28 16:47:32 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-10-28 16:47:32 +0000
commit8d1d4fa963ee7bebdccc8a16fbc821f857e352a8 (patch)
tree58222547916cf9f4815ee95cc6766e21afec9601 /sci-mathematics
parentVersion bump to 2.0.0, fixing bug #242240 (diff)
downloadgentoo-2-8d1d4fa963ee7bebdccc8a16fbc821f857e352a8.tar.gz
gentoo-2-8d1d4fa963ee7bebdccc8a16fbc821f857e352a8.tar.bz2
gentoo-2-8d1d4fa963ee7bebdccc8a16fbc821f857e352a8.zip
Version bump, more complete doc installation, added missing dependencies and fix for crashing GUI, bug #244631
(Portage version: 2.2_rc11/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/pspp/ChangeLog9
-rw-r--r--sci-mathematics/pspp/metadata.xml14
-rw-r--r--sci-mathematics/pspp/pspp-0.6.1.ebuild87
3 files changed, 102 insertions, 8 deletions
diff --git a/sci-mathematics/pspp/ChangeLog b/sci-mathematics/pspp/ChangeLog
index 8d2d08e269aa..47d75294fea5 100644
--- a/sci-mathematics/pspp/ChangeLog
+++ b/sci-mathematics/pspp/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-mathematics/pspp
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pspp/ChangeLog,v 1.8 2008/10/28 13:36:24 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pspp/ChangeLog,v 1.9 2008/10/28 16:47:32 bicatali Exp $
+
+*pspp-0.6.1 (28 Oct 2008)
+
+ 28 Oct 2008; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml,
+ +pspp-0.6.1.ebuild:
+ Version bump, more complete doc installation, added missing dependencies
+ and fix for crashing GUI, bug #244631
28 Oct 2008; Markus Dittrich <markusle@gentoo.org>
+files/pspp-0.6.0-as-needed.patch, pspp-0.6.0.ebuild:
diff --git a/sci-mathematics/pspp/metadata.xml b/sci-mathematics/pspp/metadata.xml
index 329287f962a1..cf11e8ce1105 100644
--- a/sci-mathematics/pspp/metadata.xml
+++ b/sci-mathematics/pspp/metadata.xml
@@ -3,14 +3,14 @@
<pkgmetadata>
<herd>sci-mathematics</herd>
<longdescription lang="en">
-PSPP is a program for statistical analysis of sampled data. It
-interprets commands in the SPSS language and produces tabular and
-graphical output in ASCII, HTML, or PostScript format.
-PSPP supports a large subset of SPSS's transformation language. Its
-statistical procedure support is limited but growing.
-PSPP has both text-based and graphical user interfaces.
+ PSPP is a program for statistical analysis of sampled data. It
+ interprets commands in the SPSS language and produces tabular and
+ graphical output in ASCII, HTML, or PostScript format.
+ PSPP supports a large subset of SPSS's transformation language. Its
+ statistical procedure support is limited but growing.
+ PSPP has both text-based and a GTK+ based graphical user interfaces.
</longdescription>
<use>
- <flag name='psppire'>Enable psppire GUI</flag>
+ <flag name='psppire'>Enable GTK psppire GUI</flag>
</use>
</pkgmetadata>
diff --git a/sci-mathematics/pspp/pspp-0.6.1.ebuild b/sci-mathematics/pspp/pspp-0.6.1.ebuild
new file mode 100644
index 000000000000..7a1494c54bec
--- /dev/null
+++ b/sci-mathematics/pspp/pspp-0.6.1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/pspp/pspp-0.6.1.ebuild,v 1.1 2008/10/28 16:47:32 bicatali Exp $
+
+EAPI=2
+inherit eutils elisp-common autotools
+
+DESCRIPTION="Program for statistical analysis of sampled data."
+HOMEPAGE="http://www.gnu.org/software/pspp/pspp.html"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc emacs gtk ncurses nls plotutils postgres"
+
+RDEPEND="sci-libs/gsl
+ sys-libs/readline
+ sys-devel/gettext
+ virtual/libiconv
+ sys-libs/zlib
+ dev-libs/libxml2
+ emacs? ( virtual/emacs )
+ gtk? ( >=x11-libs/gtk+-2.12 gnome-base/libglade )
+ ncurses? ( sys-libs/ncurses )
+ plotutils? ( media-libs/plotutils )
+ postgres? ( virtual/postgresql-server )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( virtual/latex-base )"
+
+SITEFILE=50${PN}-gentoo.el
+
+src_prepare() {
+ # this patch is hacky, but should not be needed for 0.7
+ epatch "${FILESDIR}"/${PN}-0.6.0-as-needed.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-rpath \
+ $(use_enable nls) \
+ $(use_with gtk gui) \
+ $(use_with ncurses libncurses) \
+ $(use_with plotutils libplot) \
+ $(use_with postgres libpq)
+}
+
+src_compile() {
+ emake pkglibdir=/usr/$(get_libdir) || die "emake failed"
+ if use doc; then
+ emake html || die "emake html failed"
+ emake pdf || die "emake pdf failed"
+ fi
+ use emacs && elisp-compile *.el
+}
+
+src_install() {
+ emake pkglibdir=/usr/$(get_libdir) DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog NEWS ONEWS README THANKS TODO
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die
+
+ if use doc; then
+ doins -r doc/pspp.html doc/pspp-dev.html || die
+ doins doc/pspp.pdf doc/pspp-dev.pdf || die
+ fi
+ if use emacs; then
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+ if use gtk; then
+ doicon src/ui/gui/${PN}icon.png
+ make_desktop_entry psppire psppire ${PN}icon.png
+ fi
+}
+
+pkg_postinst () {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}