summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-09-14 17:42:30 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-09-14 17:42:30 +0000
commit93d0217f09a77b2a7aee453fe1de62153a81c506 (patch)
treed7207f35b68609d68c64058118876f40451a0634 /sci-mathematics
parentMarked ppc stable. (diff)
downloadgentoo-2-93d0217f09a77b2a7aee453fe1de62153a81c506.tar.gz
gentoo-2-93d0217f09a77b2a7aee453fe1de62153a81c506.tar.bz2
gentoo-2-93d0217f09a77b2a7aee453fe1de62153a81c506.zip
Version bump
(Portage version: 2.2_rc81/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/mathomatic/ChangeLog8
-rw-r--r--sci-mathematics/mathomatic/mathomatic-15.2.1.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/sci-mathematics/mathomatic/ChangeLog b/sci-mathematics/mathomatic/ChangeLog
index a3d1adc2c306..fccc434a4964 100644
--- a/sci-mathematics/mathomatic/ChangeLog
+++ b/sci-mathematics/mathomatic/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/mathomatic
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/ChangeLog,v 1.49 2010/06/18 00:10:46 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/ChangeLog,v 1.50 2010/09/14 17:42:30 bicatali Exp $
+
+*mathomatic-15.2.1 (14 Sep 2010)
+
+ 14 Sep 2010; Sébastien Fabbro <bicatali@gentoo.org>
+ +mathomatic-15.2.1.ebuild:
+ Version bump
*mathomatic-15.1.3 (18 Jun 2010)
diff --git a/sci-mathematics/mathomatic/mathomatic-15.2.1.ebuild b/sci-mathematics/mathomatic/mathomatic-15.2.1.ebuild
new file mode 100644
index 000000000000..1b809cfea7e7
--- /dev/null
+++ b/sci-mathematics/mathomatic/mathomatic-15.2.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/mathomatic-15.2.1.ebuild,v 1.1 2010/09/14 17:42:30 bicatali Exp $
+
+inherit eutils
+
+DESCRIPTION="Automatic algebraic manipulator"
+HOMEPAGE="http://www.mathomatic.com/math/"
+SRC_URI="http://www.panix.com/~gesslein/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc gnuplot"
+
+DEPEND="sys-libs/readline
+ sys-libs/ncurses"
+RDEPEND="${DEPEND}
+ gnuplot? ( sci-visualization/gnuplot )"
+
+src_compile() {
+ emake READLINE=1 OPTFLAGS="" || die "emake failed"
+ emake OPTFLAGS="" -C primes || die "emake in primes failed"
+}
+
+src_test() {
+ emake test || die "emake test failed"
+ emake -C primes test || die "emake test in primes failed"
+}
+
+src_install() {
+ dobin mathomatic || die
+ dobin primes/matho-{mult,primes,pascal,sumsq} primes/primorial || die
+ dodoc changes.txt README.txt AUTHORS
+ doman mathomatic.1 primes/*.1 || die
+ doicon icons/mathomatic.png || die
+ domenu icons/mathomatic.desktop || die
+ newdoc primes/README.txt README-primes.txt || die
+ if use doc; then
+ dohtml doc/* || die
+ insinto /usr/share/doc/${PF}
+ doins -r tests factorial m4 || die
+ fi
+}