summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2014-12-20 15:45:16 +0000
committerAndrey Grozin <grozin@gentoo.org>2014-12-20 15:45:16 +0000
commitc0e05e31c9957ae6e62c3c4618e5192167c0984e (patch)
tree321f4ab30869613e737749c31be383f9618ad646 /sci-mathematics
parentVersion bump (diff)
downloadgentoo-2-c0e05e31c9957ae6e62c3c4618e5192167c0984e.tar.gz
gentoo-2-c0e05e31c9957ae6e62c3c4618e5192167c0984e.tar.bz2
gentoo-2-c0e05e31c9957ae6e62c3c4618e5192167c0984e.zip
Version bump
(Portage version: 2.2.15/cvs/Linux i686, signed Manifest commit with key 0x3AFFCE974D34BD8C!)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/wxmaxima/ChangeLog7
-rw-r--r--sci-mathematics/wxmaxima/wxmaxima-14.12.0.ebuild76
2 files changed, 82 insertions, 1 deletions
diff --git a/sci-mathematics/wxmaxima/ChangeLog b/sci-mathematics/wxmaxima/ChangeLog
index ee287498e684..de85f7a505a2 100644
--- a/sci-mathematics/wxmaxima/ChangeLog
+++ b/sci-mathematics/wxmaxima/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/wxmaxima
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/wxmaxima/ChangeLog,v 1.43 2014/08/10 20:24:29 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/wxmaxima/ChangeLog,v 1.44 2014/12/20 15:45:16 grozin Exp $
+
+*wxmaxima-14.12.0 (20 Dec 2014)
+
+ 20 Dec 2014; Andrey Grozin <grozin@gentoo.org> +wxmaxima-14.12.0.ebuild:
+ Version bump
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> wxmaxima-0.8.2.ebuild,
wxmaxima-12.01.0.ebuild, wxmaxima-12.04.0.ebuild, wxmaxima-12.09.0.ebuild,
diff --git a/sci-mathematics/wxmaxima/wxmaxima-14.12.0.ebuild b/sci-mathematics/wxmaxima/wxmaxima-14.12.0.ebuild
new file mode 100644
index 000000000000..6b87505a1d73
--- /dev/null
+++ b/sci-mathematics/wxmaxima/wxmaxima-14.12.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/wxmaxima/wxmaxima-14.12.0.ebuild,v 1.1 2014/12/20 15:45:16 grozin Exp $
+
+EAPI=5
+
+WX_GTK_VER="2.8"
+
+inherit eutils gnome2-utils wxwidgets fdo-mime
+
+DESCRIPTION="Graphical frontend to Maxima, using the wxWidgets toolkit"
+HOMEPAGE="http://andrejv.github.io/wxmaxima/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="
+ dev-libs/libxml2:2
+ x11-libs/wxGTK:${WX_GTK_VER}"
+RDEPEND="${DEPEND}
+ media-fonts/jsmath
+ sci-visualization/gnuplot[wxwidgets]
+ sci-mathematics/maxima"
+
+src_prepare() {
+ local i
+
+ # consistent package names
+ sed -e "s:\${datadir}/wxMaxima:\${datadir}/${PN}:g" \
+ -i Makefile.in data/Makefile.in || die "sed failed"
+
+ sed -e 's:share/wxMaxima:share/wxmaxima:g' \
+ -i src/wxMaxima.cpp src/wxMaximaFrame.cpp src/Config.cpp \
+ || die "sed failed"
+
+ # correct gettext behavior
+ if [[ -n "${LINGUAS+x}" ]] ; then
+ for i in $(cd "${S}"/locales ; echo *.mo) ; do
+ if ! has ${i%.mo} ${LINGUAS} ; then
+ sed -i \
+ -e "/^WXMAXIMA_LINGUAS/s# ${i%.mo}##" \
+ -e "/^WXWIN_LINGUAS/s# ${i%.mo}##" \
+ locales/Makefile.in || die
+ fi
+ done
+ fi
+}
+
+src_configure() {
+ econf \
+ --enable-printing \
+ --with-wx-config=${WX_CONFIG}
+}
+
+src_install () {
+ default
+ doicon -s 128 data/wxmaxima.png
+ make_desktop_entry wxmaxima wxMaxima wxmaxima
+ dosym /usr/share/${PN}/README /usr/share/doc/${PF}/README
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}