summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-21 13:30:58 +0000
committerJustin Lecher <jlec@gentoo.org>2013-02-21 13:30:58 +0000
commitce35c65e01bf77ae70f46a215d176d59c07c5149 (patch)
treeb98ff34554eea25b7dcbf86e8c863a7aef3e8214 /sci-mathematics
parentStable for ia64, wrt bug #457458 (diff)
downloadgentoo-2-ce35c65e01bf77ae70f46a215d176d59c07c5149.tar.gz
gentoo-2-ce35c65e01bf77ae70f46a215d176d59c07c5149.tar.bz2
gentoo-2-ce35c65e01bf77ae70f46a215d176d59c07c5149.zip
sci-mathematics/octave: Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of plain pkg-config
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/octave/ChangeLog6
-rw-r--r--sci-mathematics/octave/metadata.xml16
-rw-r--r--sci-mathematics/octave/octave-3.4.3-r1.ebuild8
3 files changed, 17 insertions, 13 deletions
diff --git a/sci-mathematics/octave/ChangeLog b/sci-mathematics/octave/ChangeLog
index 6b12f72fc788..c7410ccdcca4 100644
--- a/sci-mathematics/octave/ChangeLog
+++ b/sci-mathematics/octave/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/octave
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.135 2013/01/11 21:44:11 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.136 2013/02/21 13:30:58 jlec Exp $
+
+ 21 Feb 2013; Justin Lecher <jlec@gentoo.org> octave-3.4.3-r1.ebuild,
+ metadata.xml:
+ Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of plain pkg-config
11 Jan 2013; Sébastien Fabbro <bicatali@gentoo.org> octave-3.6.3.ebuild:
Forgot transfig dependency
diff --git a/sci-mathematics/octave/metadata.xml b/sci-mathematics/octave/metadata.xml
index d18fb9aa8276..c2dde1ee64bd 100644
--- a/sci-mathematics/octave/metadata.xml
+++ b/sci-mathematics/octave/metadata.xml
@@ -1,18 +1,18 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-mathematics</herd>
-<longdescription lang='en'>
+ <herd>sci-mathematics</herd>
+ <longdescription lang="en">
Octave is a high-level language, primarily intended for numerical
computations. It provides a convenient command line interface for
solving linear and nonlinear problems numerically, and for performing
other numerical experiments. It may also be used as a batch-oriented
language.
</longdescription>
-<use>
- <flag name='glpk'>Add support for <pkg>sci-libs/glpk</pkg> for linear programming</flag>
- <flag name='qhull'>Add support for <pkg>sci-libs/qhull</pkg>, to allow `delaunay', `convhull', and related functions</flag>
- <flag name='qrupdate'>Add support for <pkg>sci-libs/qrupdate</pkg>for QR and Cholesky update functions</flag>
- <flag name='sparse'>Add enhanced support for sparse matrix algebra with SuiteSparse</flag>
-</use>
+ <use>
+ <flag name="glpk">Add support for <pkg>sci-libs/glpk</pkg> for linear programming</flag>
+ <flag name="qhull">Add support for <pkg>sci-libs/qhull</pkg>, to allow `delaunay', `convhull', and related functions</flag>
+ <flag name="qrupdate">Add support for <pkg>sci-libs/qrupdate</pkg>for QR and Cholesky update functions</flag>
+ <flag name="sparse">Add enhanced support for sparse matrix algebra with SuiteSparse</flag>
+ </use>
</pkgmetadata>
diff --git a/sci-mathematics/octave/octave-3.4.3-r1.ebuild b/sci-mathematics/octave/octave-3.4.3-r1.ebuild
index 7812f73c7345..d32348004f9a 100644
--- a/sci-mathematics/octave/octave-3.4.3-r1.ebuild
+++ b/sci-mathematics/octave/octave-3.4.3-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-3.4.3-r1.ebuild,v 1.14 2012/05/04 07:46:51 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-3.4.3-r1.ebuild,v 1.15 2013/02/21 13:30:58 jlec Exp $
EAPI=4
inherit eutils base autotools toolchain-funcs
@@ -75,8 +75,8 @@ src_configure() {
--localstatedir="${EPREFIX}/var/state/octave" \
--enable-shared \
--without-hdf5 \
- --with-blas="$(pkg-config --libs blas)" \
- --with-lapack="$(pkg-config --libs lapack)" \
+ --with-blas="$($(tc-getPKG_CONFIG) --libs blas)" \
+ --with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)" \
$(use_enable doc docs) \
$(use_enable readline) \
$(use_with curl) \