summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-12-26 09:13:20 +0000
committerJustin Lecher <jlec@gentoo.org>2014-12-26 09:13:20 +0000
commitd1fab441e066ed5be750928b78803f5a90a61950 (patch)
tree0eb17003797cdefce5a586becf6236b5ef06673b /sci-mathematics
parentFix compilation with ctemplate 2.3. Thanks to Marcel Pennewiß and others in ... (diff)
downloadgentoo-2-d1fab441e066ed5be750928b78803f5a90a61950.tar.gz
gentoo-2-d1fab441e066ed5be750928b78803f5a90a61950.tar.bz2
gentoo-2-d1fab441e066ed5be750928b78803f5a90a61950.zip
sci-mathematics/genius: Version BUmp, #523604; fix SRC_URI, thanks leio
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/genius/ChangeLog8
-rw-r--r--sci-mathematics/genius/genius-1.0.17.ebuild4
-rw-r--r--sci-mathematics/genius/genius-1.0.19.ebuild56
3 files changed, 65 insertions, 3 deletions
diff --git a/sci-mathematics/genius/ChangeLog b/sci-mathematics/genius/ChangeLog
index 33a5bf0e5feb..79c173fb9793 100644
--- a/sci-mathematics/genius/ChangeLog
+++ b/sci-mathematics/genius/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/genius
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/genius/ChangeLog,v 1.9 2014/04/05 17:44:25 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/genius/ChangeLog,v 1.10 2014/12/26 09:13:20 jlec Exp $
+
+*genius-1.0.19 (26 Dec 2014)
+
+ 26 Dec 2014; Justin Lecher <jlec@gentoo.org> genius-1.0.17.ebuild,
+ +genius-1.0.19.ebuild:
+ Version BUmp, #523604; fix SRC_URI, thanks leio
05 Apr 2014; Justin Lecher <jlec@gentoo.org> genius-1.0.17.ebuild,
+files/genius-1.0.17-gcc4.8.patch:
diff --git a/sci-mathematics/genius/genius-1.0.17.ebuild b/sci-mathematics/genius/genius-1.0.17.ebuild
index 643c548c2f5d..806d84bb9817 100644
--- a/sci-mathematics/genius/genius-1.0.17.ebuild
+++ b/sci-mathematics/genius/genius-1.0.17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/genius/genius-1.0.17.ebuild,v 1.2 2014/04/05 17:44:25 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/genius/genius-1.0.17.ebuild,v 1.3 2014/12/26 09:13:20 jlec Exp $
EAPI=5
@@ -9,7 +9,7 @@ inherit eutils gnome2
DESCRIPTION="Genius Mathematics Tool and the GEL Language"
HOMEPAGE="http://www.jirka.org/genius.html"
SRC_URI="
- http://ftp.gnome.org/pub/GNOME/sources/${PN}/1.0/${P}.tar.xz
+ mirror://gnome/sources/${PN}/1.0/${P}.tar.xz
doc? ( http://www.jirka.org/${PN}-reference.pdf )"
LICENSE="GPL-3"
diff --git a/sci-mathematics/genius/genius-1.0.19.ebuild b/sci-mathematics/genius/genius-1.0.19.ebuild
new file mode 100644
index 000000000000..11f076ce5776
--- /dev/null
+++ b/sci-mathematics/genius/genius-1.0.19.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/genius/genius-1.0.19.ebuild,v 1.1 2014/12/26 09:13:20 jlec Exp $
+
+EAPI=5
+
+inherit eutils gnome2
+
+DESCRIPTION="Genius Mathematics Tool and the GEL Language"
+HOMEPAGE="http://www.jirka.org/genius.html"
+SRC_URI="
+ mirror://gnome/sources/${PN}/1.0/${P}.tar.xz
+ doc? ( http://www.jirka.org/${PN}-reference.pdf )"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc gnome nls"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/gmp
+ dev-libs/mpfr
+ dev-libs/popt
+ sys-libs/ncurses
+ sys-libs/readline
+ gnome? (
+ x11-libs/gtk+:2
+ gnome-base/libgnome
+ gnome-base/libgnomeui
+ gnome-base/libglade:2.0
+ x11-libs/gtksourceview:2.0
+ x11-libs/vte:0 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ || ( sys-devel/bison dev-util/yacc )
+ sys-devel/flex
+ app-text/scrollkeeper
+ app-text/gnome-doc-utils
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ G2CONF="${G2CONF} $(use_enable gnome) $(use_enable nls) \
+ --disable-update-mimedb --disable-scrollkeeper \
+ --disable-extra-gcc-optimization"
+ # gnome2.eclass adds --disable-gtk-doc or --enable-gtk-doc to G2CONF
+ # if there is the USE flag doc, thus leading to QA warnings
+ GCONF_DEBUG="no"
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+ USE_DESTDIR="1"
+}
+
+src_install() {
+ use doc && DOCS+=" ${DISTDIR}/${PN}-reference.pdf"
+ gnome2_src_install
+}