summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Jackson <tsunam@gentoo.org>2008-01-17 03:58:41 +0000
committerJoshua Jackson <tsunam@gentoo.org>2008-01-17 03:58:41 +0000
commit725f18bb8de2108418b1ecbed5f2d2ca041c26ca (patch)
treec980d2ad6c96481e866625a2f35a987d56aef94c /sci-misc/boinc
parentnew local use flag for x11-plugins/bfm, gkrellm. (diff)
downloadgentoo-2-725f18bb8de2108418b1ecbed5f2d2ca041c26ca.tar.gz
gentoo-2-725f18bb8de2108418b1ecbed5f2d2ca041c26ca.tar.bz2
gentoo-2-725f18bb8de2108418b1ecbed5f2d2ca041c26ca.zip
fixing my breaking setiathome
(Portage version: 2.1.3.19)
Diffstat (limited to 'sci-misc/boinc')
-rw-r--r--sci-misc/boinc/ChangeLog7
-rw-r--r--sci-misc/boinc/boinc-4.72.20050813-r3.ebuild94
-rw-r--r--sci-misc/boinc/boinc-5.2.14.ebuild105
-rw-r--r--sci-misc/boinc/boinc-5.4.11.ebuild105
-rw-r--r--sci-misc/boinc/boinc-5.5.6.ebuild111
5 files changed, 421 insertions, 1 deletions
diff --git a/sci-misc/boinc/ChangeLog b/sci-misc/boinc/ChangeLog
index 2cbef8314d7d..643c23315df2 100644
--- a/sci-misc/boinc/ChangeLog
+++ b/sci-misc/boinc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-misc/boinc
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.35 2008/01/17 03:21:39 tsunam Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.36 2008/01/17 03:58:41 tsunam Exp $
+
+ 17 Jan 2008; Joshua Jackson <tsunam@gentoo.org>
+ +boinc-4.72.20050813-r3.ebuild, +boinc-5.2.14.ebuild,
+ +boinc-5.4.11.ebuild, +boinc-5.5.6.ebuild:
+ I forgot about setiathome
*boinc-5.10.28 (17 Jan 2008)
diff --git a/sci-misc/boinc/boinc-4.72.20050813-r3.ebuild b/sci-misc/boinc/boinc-4.72.20050813-r3.ebuild
new file mode 100644
index 000000000000..b832cd3f0f80
--- /dev/null
+++ b/sci-misc/boinc/boinc-4.72.20050813-r3.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-4.72.20050813-r3.ebuild,v 1.11 2008/01/17 03:58:41 tsunam Exp $
+
+inherit eutils wxwidgets
+
+MY_PN="boinc_public-cvs"
+MY_PV="2005-08-13"
+S=${WORKDIR}/boinc_public
+
+DESCRIPTION="The Berkeley Open Infrastructure for Network Computing"
+HOMEPAGE="http://boinc.ssl.berkeley.edu/"
+SRC_URI="http://boinc.ssl.berkeley.edu/source/nightly/${MY_PN}-${MY_PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="server X"
+
+RDEPEND="sys-libs/zlib
+ X? ( =x11-libs/wxGTK-2.6* )
+ server? ( www-servers/apache
+ >=virtual/mysql-4.0
+ virtual/php
+ >=dev-lang/python-2.2.3
+ >=dev-python/mysql-python-0.9.2 )"
+DEPEND=">=sys-devel/gcc-3.0.4
+ >=sys-devel/autoconf-2.59
+ >=sys-devel/automake-1.9.3
+ X? ( x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libX11
+ x11-proto/xproto
+ virtual/glut
+ virtual/glu
+ media-libs/jpeg )
+ server? ( virtual/imap-c-client )
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # GCC 4 patch, bug 112133.
+ epatch ${FILESDIR}/${P}-gcc4-fix.patch
+
+ # point to a proper mouse device
+ sed -e "s:/dev/mouse:/dev/input/mice:g" -i client/hostinfo_unix.C || die
+}
+
+src_compile() {
+ if use X; then
+ WX_GTK_VER=2.6
+ need-wxwidgets gtk2
+ wxconf="--with-wx-config=${WX_CONFIG}"
+ fi
+
+ econf \
+ --enable-client \
+ --disable-static-client \
+ ${wxconf} \
+ $(use_enable server) \
+ $(use_with X x) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed"
+
+ newinitd ${FILESDIR}/boinc.init boinc
+ newconfd ${FILESDIR}/boinc.conf boinc
+
+ make_desktop_entry boinc_gui BOINC boinc Science /var/lib/boinc
+}
+
+pkg_preinst() {
+ enewgroup boinc
+ enewuser boinc -1 -1 /var/lib/boinc boinc
+}
+
+pkg_postinst() {
+ echo
+ einfo "You need to attach to a project to do anything useful with boinc."
+ einfo "You can do this by running /etc/init.d/boinc attach"
+ einfo "BOINC The howto for configuration is located at:"
+ einfo "http://boinc.berkeley.edu/anonymous_platform.php"
+ if use server;then
+ echo
+ einfo "You have chosen to enable server mode. this ebuild has installed"
+ einfo "the necessary packages to be a server. You will need to have a"
+ einfo "project. Contact BOINC directly for further information."
+ fi
+ echo
+}
diff --git a/sci-misc/boinc/boinc-5.2.14.ebuild b/sci-misc/boinc/boinc-5.2.14.ebuild
new file mode 100644
index 000000000000..8c138ae6bcaf
--- /dev/null
+++ b/sci-misc/boinc/boinc-5.2.14.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-5.2.14.ebuild,v 1.13 2008/01/17 03:58:41 tsunam Exp $
+
+inherit eutils wxwidgets
+
+DESCRIPTION="The Berkeley Open Infrastructure for Network Computing"
+HOMEPAGE="http://boinc.ssl.berkeley.edu/"
+SRC_URI="mirror://gentoo//${P}.tar.bz2
+ mirror://gentoo/${P}-patches.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="server X unicode"
+
+RDEPEND="sys-libs/zlib
+ >=net-misc/curl-7.15.0
+ >=dev-libs/openssl-0.9.7
+ X? ( =x11-libs/wxGTK-2.6* )
+ server? ( www-servers/apache
+ >=virtual/mysql-4.0
+ virtual/php
+ >=dev-lang/python-2.2.3
+ >=dev-python/mysql-python-0.9.2 )"
+DEPEND=">=sys-devel/gcc-3.0.4
+ >=sys-devel/autoconf-2.59
+ >=sys-devel/automake-1.9.3
+ X? ( x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libX11
+ x11-proto/xproto
+ virtual/glut
+ virtual/glu
+ media-libs/jpeg )
+ server? ( virtual/imap-c-client )
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Apply patches, most of which from Debian
+ EPATCH_SOURCE="${WORKDIR}/patches" EPATCH_SUFFIX="patch" epatch
+ epatch ${FILESDIR}/08_all_Makefile.patch
+ epatch ${FILESDIR}/${P}-gcc-4.1.patch
+
+ # point to a proper mouse device
+ sed -e "s:/dev/mouse:/dev/input/mice:g" -i client/hostinfo_unix.C || die
+}
+
+src_compile() {
+ if use X; then
+ WX_GTK_VER=2.6
+ if use unicode; then
+ need-wxwidgets unicode
+ else
+ need-wxwidgets gtk2
+ fi
+ wxconf="--with-wx-config=${WX_CONFIG}"
+ fi
+
+ econf \
+ --enable-client \
+ --disable-static-client \
+ ${wxconf} \
+ $(use_enable unicode) \
+ $(use_enable server) \
+ $(use_with X x) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed"
+
+ newinitd ${FILESDIR}/boinc.init boinc
+ newconfd ${FILESDIR}/boinc.conf boinc
+
+ make_desktop_entry boinc_gui BOINC boinc Science /var/lib/boinc
+}
+
+pkg_preinst() {
+ enewgroup boinc
+ enewuser boinc -1 -1 /var/lib/boinc boinc
+}
+
+pkg_postinst() {
+ echo
+ einfo "You need to attach to a project to do anything useful with boinc."
+ einfo "You can do this by running /etc/init.d/boinc attach"
+ einfo "BOINC The howto for configuration is located at:"
+ einfo "http://boinc.berkeley.edu/anonymous_platform.php"
+ if use server;then
+ echo
+ einfo "You have chosen to enable server mode. this ebuild has installed"
+ einfo "the necessary packages to be a server. You will need to have a"
+ einfo "project. Contact BOINC directly for further information."
+ fi
+ echo
+ # Add warning about the new password for the client, bug 121896.
+ einfo "If you need to use the graphical client the password is in "
+ einfo "/var/lib/boinc/gui_rpc_auth.cfg which is randomly generated "
+ einfo "by BOINC. You can change this to something more memorable."
+ echo
+}
diff --git a/sci-misc/boinc/boinc-5.4.11.ebuild b/sci-misc/boinc/boinc-5.4.11.ebuild
new file mode 100644
index 000000000000..de61068e7198
--- /dev/null
+++ b/sci-misc/boinc/boinc-5.4.11.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-5.4.11.ebuild,v 1.8 2008/01/17 03:58:41 tsunam Exp $
+
+inherit eutils wxwidgets
+
+DESCRIPTION="The Berkeley Open Infrastructure for Network Computing"
+HOMEPAGE="http://boinc.ssl.berkeley.edu/"
+SRC_URI="mirror://gentoo//${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="server X unicode"
+
+RDEPEND="sys-libs/zlib
+ >=net-misc/curl-7.15.0
+ >=dev-libs/openssl-0.9.7
+ X? ( =x11-libs/wxGTK-2.6* )
+ server? ( www-servers/apache
+ >=virtual/mysql-4.0
+ virtual/php
+ >=dev-lang/python-2.2.3
+ >=dev-python/mysql-python-0.9.2 )"
+DEPEND=">=sys-devel/gcc-3.0.4
+ >=sys-devel/autoconf-2.58
+ >=sys-devel/automake-1.8
+ >=dev-util/pkgconfig-0.15
+ >=sys-devel/m4-1.4
+ X? ( x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libX11
+ x11-proto/xproto
+ virtual/glut
+ virtual/glu
+ media-libs/jpeg )
+ server? ( virtual/imap-c-client )
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # point to a proper mouse device
+ sed -e "s:/dev/mouse:/dev/input/mice:g" -i client/hostinfo_unix.C || die
+}
+
+src_compile() {
+ if use X; then
+ WX_GTK_VER=2.6
+ if use unicode; then
+ need-wxwidgets unicode
+ else
+ need-wxwidgets gtk2
+ fi
+ wxconf="--with-wx-config=${WX_CONFIG}"
+ fi
+
+ econf \
+ --enable-client \
+ --disable-static-client \
+ ${wxconf} \
+ $(use_enable unicode) \
+ $(use_enable server) \
+ $(use_with X x) || die "econf failed"
+ # Make it link to the compiled libs, not the installed ones
+ sed -e "s|LDFLAGS = |LDFLAGS = -L../lib |g" -i */Makefile || \
+ die "sed failed"
+ # Force -j1 - bug 136374.
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed"
+
+ newinitd ${FILESDIR}/boinc.init boinc
+ newconfd ${FILESDIR}/boinc.conf boinc
+
+ make_desktop_entry boinc_gui BOINC boinc Science /var/lib/boinc
+}
+
+pkg_preinst() {
+ enewgroup boinc
+ enewuser boinc -1 -1 /var/lib/boinc boinc
+}
+
+pkg_postinst() {
+ echo
+ einfo "You need to attach to a project to do anything useful with boinc."
+ einfo "You can do this by running /etc/init.d/boinc attach"
+ einfo "BOINC The howto for configuration is located at:"
+ einfo "http://boinc.berkeley.edu/anonymous_platform.php"
+ if use server;then
+ echo
+ einfo "You have chosen to enable server mode. this ebuild has installed"
+ einfo "the necessary packages to be a server. You will need to have a"
+ einfo "project. Contact BOINC directly for further information."
+ fi
+ echo
+ # Add warning about the new password for the client, bug 121896.
+ einfo "If you need to use the graphical client the password is in "
+ einfo "/var/lib/boinc/gui_rpc_auth.cfg which is randomly generated "
+ einfo "by BOINC. You can change this to something more memorable."
+ echo
+}
diff --git a/sci-misc/boinc/boinc-5.5.6.ebuild b/sci-misc/boinc/boinc-5.5.6.ebuild
new file mode 100644
index 000000000000..c35b0841eef9
--- /dev/null
+++ b/sci-misc/boinc/boinc-5.5.6.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-5.5.6.ebuild,v 1.11 2008/01/17 03:58:41 tsunam Exp $
+
+inherit eutils wxwidgets
+
+DESCRIPTION="The Berkeley Open Infrastructure for Network Computing"
+HOMEPAGE="http://boinc.ssl.berkeley.edu/"
+SRC_URI="mirror://gentoo//${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="server X unicode"
+
+RDEPEND="sys-libs/zlib
+ >=net-misc/curl-7.15.0
+ >=dev-libs/openssl-0.9.7
+ X? ( =x11-libs/wxGTK-2.6* )
+ server? ( www-servers/apache
+ >=virtual/mysql-4.0
+ virtual/php
+ >=dev-lang/python-2.2.3
+ >=dev-python/mysql-python-0.9.2 )"
+DEPEND=">=sys-devel/gcc-3.0.4
+ >=sys-devel/autoconf-2.58
+ >=sys-devel/automake-1.8
+ >=dev-util/pkgconfig-0.15
+ >=sys-devel/m4-1.4
+ X? ( x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libX11
+ x11-proto/xproto
+ virtual/glut
+ virtual/glu
+ media-libs/jpeg )
+ server? ( virtual/imap-c-client )
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # point to a proper mouse device
+ sed -e "s:/dev/mouse:/dev/input/mice:g" -i client/hostinfo_unix.C || die
+}
+
+src_compile() {
+ if use X; then
+ WX_GTK_VER=2.6
+ if use unicode; then
+ need-wxwidgets unicode
+ else
+ need-wxwidgets gtk2
+ fi
+ wxconf="--with-wx-config=${WX_CONFIG}"
+ fi
+
+ # Just run the necessary tools directly
+ einfo "Running necessary autotools..."
+ aclocal -I m4 || die "aclocal failed."
+ autoheader || die "autoheader failed."
+ automake || die "automake failed."
+ autoconf || die "autoconf failed."
+ econf \
+ --enable-client \
+ --disable-static-client \
+ ${wxconf} \
+ $(use_enable unicode) \
+ $(use_enable server) \
+ $(use_with X x) || die "econf failed"
+ # Make it link to the compiled libs, not the installed ones
+ sed -e "s|LDFLAGS = |LDFLAGS = -L../lib |g" -i */Makefile || \
+ die "sed failed"
+ # Force -j1 - bug 136374.
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed"
+
+ newinitd ${FILESDIR}/boinc.init boinc
+ newconfd ${FILESDIR}/boinc.conf boinc
+
+ make_desktop_entry boinc_gui BOINC boinc Science /var/lib/boinc
+}
+
+pkg_preinst() {
+ enewgroup boinc
+ enewuser boinc -1 -1 /var/lib/boinc boinc
+}
+
+pkg_postinst() {
+ echo
+ einfo "You need to attach to a project to do anything useful with boinc."
+ einfo "You can do this by running /etc/init.d/boinc attach"
+ einfo "BOINC The howto for configuration is located at:"
+ einfo "http://boinc.berkeley.edu/anonymous_platform.php"
+ if use server;then
+ echo
+ einfo "You have chosen to enable server mode. this ebuild has installed"
+ einfo "the necessary packages to be a server. You will need to have a"
+ einfo "project. Contact BOINC directly for further information."
+ fi
+ echo
+ # Add warning about the new password for the client, bug 121896.
+ einfo "If you need to use the graphical client the password is in "
+ einfo "/var/lib/boinc/gui_rpc_auth.cfg which is randomly generated "
+ einfo "by BOINC. You can change this to something more memorable."
+ echo
+}