summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2006-07-11 12:06:04 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2006-07-11 12:06:04 +0000
commita63bc568c7f6662a35508d807b28d2c38c2722ac (patch)
tree191cf98df444b51f8d32bdc6818a4e84af44f20b /sci-misc/boinc
parentversion bump and cleanout (diff)
downloadgentoo-2-a63bc568c7f6662a35508d807b28d2c38c2722ac.tar.gz
gentoo-2-a63bc568c7f6662a35508d807b28d2c38c2722ac.tar.bz2
gentoo-2-a63bc568c7f6662a35508d807b28d2c38c2722ac.zip
Updated to call the necessary autotools directly, should fix bug 139923.
(Portage version: 2.1.1_pre2-r6)
Diffstat (limited to 'sci-misc/boinc')
-rw-r--r--sci-misc/boinc/ChangeLog5
-rw-r--r--sci-misc/boinc/boinc-5.5.6.ebuild15
2 files changed, 15 insertions, 5 deletions
diff --git a/sci-misc/boinc/ChangeLog b/sci-misc/boinc/ChangeLog
index 10319eeb07ff..7ab95725f1a4 100644
--- a/sci-misc/boinc/ChangeLog
+++ b/sci-misc/boinc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-misc/boinc
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.22 2006/07/10 13:14:38 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.23 2006/07/11 12:06:04 cryos Exp $
+
+ 11 Jul 2006; Marcus D. Hanwell <cryos@gentoo.org> boinc-5.5.6.ebuild:
+ Updated to call the necessary autotools directly, should fix bug 139923.
*boinc-5.5.6 (10 Jul 2006)
diff --git a/sci-misc/boinc/boinc-5.5.6.ebuild b/sci-misc/boinc/boinc-5.5.6.ebuild
index 67ca9816f9f6..42cc58ceaec6 100644
--- a/sci-misc/boinc/boinc-5.5.6.ebuild
+++ b/sci-misc/boinc/boinc-5.5.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-5.5.6.ebuild,v 1.1 2006/07/10 13:14:38 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/boinc-5.5.6.ebuild,v 1.2 2006/07/11 12:06:04 cryos Exp $
inherit eutils
@@ -23,8 +23,10 @@ RDEPEND="sys-libs/zlib
>=dev-lang/python-2.2.3
>=dev-python/mysql-python-0.9.2 )"
DEPEND=">=sys-devel/gcc-3.0.4
- >=sys-devel/autoconf-2.59
- >=sys-devel/automake-1.9.3
+ >=sys-devel/autoconf-2.58
+ >=sys-devel/automake-1.8
+ >=dev-util/pkgconfig-0.15
+ >=sys-devel/m4-1.4
X? ( || ( ( x11-libs/libXmu
x11-libs/libXt
x11-libs/libX11
@@ -45,7 +47,12 @@ src_unpack() {
}
src_compile() {
- ./_autosetup || die "autosetup failed."
+ # Just run the necessary tools directly
+ einfo "Running necessary autotools..."
+ aclocal -I m4 || die "aclocal failed."
+ autoheader || die "autoheader failed."
+ automake || die "automake failed."
+ autoconf || die "autoconf failed."
econf \
--enable-client \
--disable-static-client \