summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-08-04 16:01:17 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-08-04 16:01:17 +0000
commit49c6437ac479a6f58bd772f6135c8dbdee21ed59 (patch)
treef6278576cd6e212a3f9d94ae3a192b69208f5ab1 /sci-misc
parentrespect CFLAGS wrt bug #429422 (diff)
downloadgentoo-2-49c6437ac479a6f58bd772f6135c8dbdee21ed59.tar.gz
gentoo-2-49c6437ac479a6f58bd772f6135c8dbdee21ed59.tar.bz2
gentoo-2-49c6437ac479a6f58bd772f6135c8dbdee21ed59.zip
Version bump
(Portage version: 2.2.01.20796-prefix/cvs/Linux x86_64)
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/gato/ChangeLog11
-rw-r--r--sci-misc/gato/gato-0.99c.ebuild63
-rw-r--r--sci-misc/gato/gato-1.1.2.ebuild52
3 files changed, 60 insertions, 66 deletions
diff --git a/sci-misc/gato/ChangeLog b/sci-misc/gato/ChangeLog
index 7bb59a80cfc3..963f90fa82ff 100644
--- a/sci-misc/gato/ChangeLog
+++ b/sci-misc/gato/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-misc/gato
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/gato/ChangeLog,v 1.13 2010/06/24 12:51:38 jlec Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/gato/ChangeLog,v 1.14 2012/08/04 16:01:17 bicatali Exp $
+
+*gato-1.1.2 (04 Aug 2012)
+
+ 04 Aug 2012; Sébastien Fabbro <bicatali@gentoo.org> +gato-1.1.2.ebuild,
+ -gato-0.99c.ebuild:
+ Version bump
*gato-1.02 (24 Jun 2010)
@@ -63,4 +69,3 @@
17 Dec 2003; Brandy Westcott brandy@gentoo.org gato-0.98i.ebuild:
Initial import of Gato - Graph Animation Toolbox.
-
diff --git a/sci-misc/gato/gato-0.99c.ebuild b/sci-misc/gato/gato-0.99c.ebuild
deleted file mode 100644
index dd961548549a..000000000000
--- a/sci-misc/gato/gato-0.99c.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/gato/gato-0.99c.ebuild,v 1.8 2010/06/24 12:52:40 jlec Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-PYTHON_USE_WITH="tk"
-
-inherit eutils python
-
-MY_PN="Gato"
-MY_PV=$(echo ${PV} | tr '[:lower:]' '[:upper:]')
-
-DESCRIPTION="Graph Animation Toolbox"
-HOMEPAGE="http://gato.sourceforge.net/"
-SRC_URI="http://gato.sourceforge.net/Download/${MY_PN}-${MY_PV}.tar.gz
- doc? ( http://gato.sourceforge.net/Download/${MY_PN}-Doc-${MY_PV}.tar.gz )"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="doc"
-
-S="${WORKDIR}/${MY_PN}"
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- # change TKinter call to avoid crashing of X
- sed -i \
- -e 's:self.overrideredirect(1):self.overrideredirect(0):' \
- "${S}"/GatoDialogs.py || die "failed to patch GatoDialogs.py"
-}
-
-src_install() {
- # install python code
- local instdir=$(python_get_sitedir)/${PN}
- insinto ${instdir}
- doins *.py || die "Failed to install python files"
- fperms 755 ${instdir}/{Gato,Gred}.py
- python_convert_shebangs -r 2 "${ED}"
-
- # create symlinks
- dosym ${instdir}/Gato.py /usr/bin/gato || die
- dosym ${instdir}/Gred.py /usr/bin/gred || die
-
- # install data files
- insinto /usr/share/${PN}
- doins BFS.* DFS.* sample.cat || die "failed to data files"
-
- use doc && dohtml -r "${WORKDIR}"/Doc/*
-}
-
-pkg_postinst() {
- python_mod_optimize ${PN}
-}
-
-pkg_postrm() {
- python_mod_cleanup ${PN}
-}
diff --git a/sci-misc/gato/gato-1.1.2.ebuild b/sci-misc/gato/gato-1.1.2.ebuild
new file mode 100644
index 000000000000..26db0583bf25
--- /dev/null
+++ b/sci-misc/gato/gato-1.1.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/gato/gato-1.1.2.ebuild,v 1.1 2012/08/04 16:01:17 bicatali Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+#PYTHON_USE_WITH="tk"
+
+inherit eutils python
+
+MYP="Gato-${PV}"
+
+DESCRIPTION="Graph Animation Toolbox"
+HOMEPAGE="http://gato.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MYP}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+S="${WORKDIR}/${MYP}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # change TKinter call to avoid crashing of X
+ sed -i \
+ -e 's:self.overrideredirect(1):self.overrideredirect(0):' \
+ "${S}"/GatoDialogs.py || die "failed to patch GatoDialogs.py"
+}
+
+src_install() {
+ # install python code
+ local instdir=$(python_get_sitedir)/${PN}
+ insinto ${instdir}
+ doins *.py
+ fperms 755 ${instdir}/{Gato,Gred}.py
+ python_convert_shebangs -r 2 "${ED}"
+
+ # create symlinks
+ dosym ${instdir}/Gato.py /usr/bin/gato
+ dosym ${instdir}/Gred.py /usr/bin/gred
+
+ # install data files
+ insinto /usr/share/${PN}
+ doins BFS.* DFS.* sample.cat
+}