summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJauhien Piatlicki <jauhien@gentoo.org>2015-07-07 20:45:48 +0000
committerJauhien Piatlicki <jauhien@gentoo.org>2015-07-07 20:45:48 +0000
commiteaa0b862f52a70daf6d72ef52b71513113125a83 (patch)
tree4eb14bbab973b3fb76c892bbceaa6219c9727ed5 /sci-physics/bullet
parentarm stable, bug #551814 (diff)
downloadgentoo-2-eaa0b862f52a70daf6d72ef52b71513113125a83.tar.gz
gentoo-2-eaa0b862f52a70daf6d72ef52b71513113125a83.tar.bz2
gentoo-2-eaa0b862f52a70daf6d72ef52b71513113125a83.zip
version bump: close bug 548860
(Portage version: 2.2.18/cvs/Linux i686, signed Manifest commit with key B2EFA1D4)
Diffstat (limited to 'sci-physics/bullet')
-rw-r--r--sci-physics/bullet/ChangeLog10
-rw-r--r--sci-physics/bullet/bullet-2.83.4.ebuild63
-rw-r--r--sci-physics/bullet/metadata.xml3
3 files changed, 73 insertions, 3 deletions
diff --git a/sci-physics/bullet/ChangeLog b/sci-physics/bullet/ChangeLog
index 7246518fb132..b789a6690be0 100644
--- a/sci-physics/bullet/ChangeLog
+++ b/sci-physics/bullet/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-physics/bullet
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/bullet/ChangeLog,v 1.35 2014/02/23 02:36:07 bicatali Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/bullet/ChangeLog,v 1.36 2015/07/07 20:45:48 jauhien Exp $
+
+*bullet-2.83.4 (07 Jul 2015)
+
+ 07 Jul 2015; Jauhien Piatlicki <jauhien@gentoo.org> +bullet-2.83.4.ebuild,
+ metadata.xml:
+ version bump: close bug 548860
*bullet-2.82 (23 Feb 2014)
diff --git a/sci-physics/bullet/bullet-2.83.4.ebuild b/sci-physics/bullet/bullet-2.83.4.ebuild
new file mode 100644
index 000000000000..14a451abb536
--- /dev/null
+++ b/sci-physics/bullet/bullet-2.83.4.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/bullet/bullet-2.83.4.ebuild,v 1.1 2015/07/07 20:45:48 jauhien Exp $
+
+EAPI=5
+
+inherit eutils cmake-utils
+
+DESCRIPTION="Continuous Collision Detection and Physics Library"
+HOMEPAGE="http://www.bulletphysics.com/"
+SRC_URI="https://github.com/bulletphysics/bullet3/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+bullet3 doc double-precision examples extras"
+
+RDEPEND="
+ virtual/opengl
+ media-libs/freeglut"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[dot] )"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.78-soversion.patch )
+
+S="${WORKDIR}/${PN}3-${PV}"
+
+src_prepare() {
+ # allow to generate docs
+ sed -i -e 's/GENERATE_HTMLHELP.*//g' Doxyfile || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ -DBUILD_CPU_DEMOS=OFF
+ -DBUILD_OPENGL3_DEMOS=OFF
+ -DBUILD_BULLET2_DEMOS=OFF
+ -DUSE_GRAPHICAL_BENCHMARK=OFF
+ -DINSTALL_LIBS=ON
+ -DINSTALL_EXTRA_LIBS=ON
+ $(cmake-utils_use_build bullet3 BULLET3)
+ $(cmake-utils_use_build extras EXTRAS)
+ $(cmake-utils_use_use double-precision DOUBLE_PRECISION)
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ if use doc; then
+ doxygen || die
+ fi
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dodoc docs/*.pdf && dohtml -r html/*
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r Extras examples
+ fi
+}
diff --git a/sci-physics/bullet/metadata.xml b/sci-physics/bullet/metadata.xml
index 376edda44e0d..0606b1b98b13 100644
--- a/sci-physics/bullet/metadata.xml
+++ b/sci-physics/bullet/metadata.xml
@@ -8,8 +8,9 @@
for games and animation.
</longdescription>
<use>
- <flag name="extras">Build additional libraries</flag>
+ <flag name="bullet3">Build Bullet 3</flag>
<flag name="double-precision">Build libraries in double precision</flag>
+ <flag name="extras">Build additional libraries</flag>
</use>
<upstream>
<remote-id type="google-code">bullet</remote-id>