summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-09-09 21:38:48 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-09-09 21:38:48 +0000
commit3d3d89939d6b239ad73f2a03291c78b01834f89e (patch)
treeb341e0bcd355cbb1971592ae326caee844169153 /sci-physics/lightspeed
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-3d3d89939d6b239ad73f2a03291c78b01834f89e.tar.gz
gentoo-2-3d3d89939d6b239ad73f2a03291c78b01834f89e.tar.bz2
gentoo-2-3d3d89939d6b239ad73f2a03291c78b01834f89e.zip
Cleaned and removed the eautoreconf since the Debian patch already applied it
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics/lightspeed')
-rw-r--r--sci-physics/lightspeed/ChangeLog9
-rw-r--r--sci-physics/lightspeed/lightspeed-1.2a-r1.ebuild20
2 files changed, 20 insertions, 9 deletions
diff --git a/sci-physics/lightspeed/ChangeLog b/sci-physics/lightspeed/ChangeLog
index feb9636b8007..32980b30562f 100644
--- a/sci-physics/lightspeed/ChangeLog
+++ b/sci-physics/lightspeed/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-physics/lightspeed
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/lightspeed/ChangeLog,v 1.13 2008/12/15 11:45:54 bicatali Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/lightspeed/ChangeLog,v 1.14 2009/09/09 21:38:48 bicatali Exp $
+
+ 09 Sep 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ lightspeed-1.2a-r1.ebuild:
+ Cleaned and removed the eautoreconf since the Debian patch already applied
+ it
15 Dec 2008; Sébastien Fabbro <bicatali@gentoo.org>
-lightspeed-1.2a.ebuild:
diff --git a/sci-physics/lightspeed/lightspeed-1.2a-r1.ebuild b/sci-physics/lightspeed/lightspeed-1.2a-r1.ebuild
index fd707fae2381..357004a2f10d 100644
--- a/sci-physics/lightspeed/lightspeed-1.2a-r1.ebuild
+++ b/sci-physics/lightspeed/lightspeed-1.2a-r1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/lightspeed/lightspeed-1.2a-r1.ebuild,v 1.8 2008/12/14 23:50:54 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/lightspeed/lightspeed-1.2a-r1.ebuild,v 1.9 2009/09/09 21:38:48 bicatali Exp $
+EAPI=2
inherit eutils
DEB_PATCH="${PN}_${PV}-7"
@@ -21,7 +22,7 @@ for i in ${LANGS}; do
IUSE="${IUSE} linguas_${i}"
done
-DEPEND="virtual/opengl
+RDEPEND="virtual/opengl
x11-libs/gtkglext
x11-libs/gtkglarea
>=x11-libs/gtk+-2
@@ -29,18 +30,23 @@ DEPEND="virtual/opengl
media-libs/tiff
truetype? ( media-libs/ftgl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
S2="${WORKDIR}/objects"
-src_unpack() {
- unpack ${A}
- epatch ${DEB_PATCH}.diff
+src_prepare() {
+ epatch "${WORKDIR}/${DEB_PATCH}.diff"
}
-src_compile() {
+src_configure() {
econf \
--with-gtk=2 \
$(use_enable nls) \
$(use_with truetype ftgl)
+}
+
+src_compile() {
emake || die "emake failed"
for i in ${LANGS}; do
use linguas_${i} && emake ${i}.gmo